summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2022-03-06 18:42:04 +0100
committerNicolas Bock <nicolasbock@gentoo.org>2022-03-07 11:18:50 -0700
commit3e17f8b5b798f756f723c61eb437c6bf11d7b6d5 (patch)
tree55e923cfba51dbc58db169941ba7b6a3a17450c8
parentmedia-gfx/ttfautohint: initial import at 1.8.4 (diff)
downloadgentoo-3e17f8b5b798f756f723c61eb437c6bf11d7b6d5.tar.gz
gentoo-3e17f8b5b798f756f723c61eb437c6bf11d7b6d5.tar.bz2
gentoo-3e17f8b5b798f756f723c61eb437c6bf11d7b6d5.zip
sys-cluster/charliecloud: Fix Python shebang.
Previously, /usr/bin/env python3 was used (upstream default), which is generic and hence should not be used on Gentoo. Package-Manager: Portage-3.0.30, Repoman-3.0.3 Closes: https://github.com/gentoo/gentoo/pull/24425 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Nicolas Bock <nicolasbock@gentoo.org>
-rw-r--r--sys-cluster/charliecloud/charliecloud-0.26-r1.ebuild (renamed from sys-cluster/charliecloud/charliecloud-0.26.ebuild)2
-rw-r--r--sys-cluster/charliecloud/charliecloud-9999.ebuild4
2 files changed, 5 insertions, 1 deletions
diff --git a/sys-cluster/charliecloud/charliecloud-0.26.ebuild b/sys-cluster/charliecloud/charliecloud-0.26-r1.ebuild
index 8ce74691fe62..14f8aa4a1aa5 100644
--- a/sys-cluster/charliecloud/charliecloud-0.26.ebuild
+++ b/sys-cluster/charliecloud/charliecloud-0.26-r1.ebuild
@@ -66,6 +66,8 @@ src_configure() {
--enable-buggy-build
# Do not use bundled version of dev-python/lark-parser.
--disable-bundled-lark
+ # Use correct shebang.
+ --with-python=${PYTHON}
)
econf "${econf_args[@]}"
}
diff --git a/sys-cluster/charliecloud/charliecloud-9999.ebuild b/sys-cluster/charliecloud/charliecloud-9999.ebuild
index 8a596e2fb8a1..14f8aa4a1aa5 100644
--- a/sys-cluster/charliecloud/charliecloud-9999.ebuild
+++ b/sys-cluster/charliecloud/charliecloud-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -66,6 +66,8 @@ src_configure() {
--enable-buggy-build
# Do not use bundled version of dev-python/lark-parser.
--disable-bundled-lark
+ # Use correct shebang.
+ --with-python=${PYTHON}
)
econf "${econf_args[@]}"
}