summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-11 11:11:55 +0100
committerSam James <sam@gentoo.org>2022-08-11 11:20:49 +0100
commit3e5a4be068f2f71be6dd25e8ec646175d110529f (patch)
treec51ee20ad5a8ec92e534984068125a3aefcb4324
parentpackage.mask: Last rite dev-libs/libdivsufsort (diff)
downloadgentoo-3e5a4be068f2f71be6dd25e8ec646175d110529f.tar.gz
gentoo-3e5a4be068f2f71be6dd25e8ec646175d110529f.tar.bz2
gentoo-3e5a4be068f2f71be6dd25e8ec646175d110529f.zip
app-shells/fish: fix PythonAnyMismatchedDepHasVersionCheck
has_version was checking DEPEND, not BDEPEND, so change to python_has_version for better defaults (defaults to BDEPEND) but also nicer output. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-shells/fish/fish-3.4.0.ebuild2
-rw-r--r--app-shells/fish/fish-3.4.1.ebuild2
-rw-r--r--app-shells/fish/fish-3.5.0.ebuild2
-rw-r--r--app-shells/fish/fish-9999.ebuild2
4 files changed, 4 insertions, 4 deletions
diff --git a/app-shells/fish/fish-3.4.0.ebuild b/app-shells/fish/fish-3.4.0.ebuild
index 761a34b45d20..b5f7b1b12b38 100644
--- a/app-shells/fish/fish-3.4.0.ebuild
+++ b/app-shells/fish/fish-3.4.0.ebuild
@@ -51,7 +51,7 @@ S="${WORKDIR}/${MY_P}"
python_check_deps() {
use test || return 0
- has_version -d "dev-python/pexpect[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/pexpect[${PYTHON_USEDEP}]"
}
src_prepare() {
diff --git a/app-shells/fish/fish-3.4.1.ebuild b/app-shells/fish/fish-3.4.1.ebuild
index 96644c7a999a..08acc9d3b69e 100644
--- a/app-shells/fish/fish-3.4.1.ebuild
+++ b/app-shells/fish/fish-3.4.1.ebuild
@@ -56,7 +56,7 @@ PATCHES=(
python_check_deps() {
use test || return 0
- has_version -d "dev-python/pexpect[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/pexpect[${PYTHON_USEDEP}]"
}
src_prepare() {
diff --git a/app-shells/fish/fish-3.5.0.ebuild b/app-shells/fish/fish-3.5.0.ebuild
index d0328d498838..936ed237ea77 100644
--- a/app-shells/fish/fish-3.5.0.ebuild
+++ b/app-shells/fish/fish-3.5.0.ebuild
@@ -51,7 +51,7 @@ S="${WORKDIR}/${MY_P}"
python_check_deps() {
use test || return 0
- has_version -d "dev-python/pexpect[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/pexpect[${PYTHON_USEDEP}]"
}
src_prepare() {
diff --git a/app-shells/fish/fish-9999.ebuild b/app-shells/fish/fish-9999.ebuild
index d0328d498838..936ed237ea77 100644
--- a/app-shells/fish/fish-9999.ebuild
+++ b/app-shells/fish/fish-9999.ebuild
@@ -51,7 +51,7 @@ S="${WORKDIR}/${MY_P}"
python_check_deps() {
use test || return 0
- has_version -d "dev-python/pexpect[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/pexpect[${PYTHON_USEDEP}]"
}
src_prepare() {