summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2021-12-31 05:52:41 -0600
committerJohn Helmert III <ajak@gentoo.org>2021-12-31 16:13:12 -0600
commit3e8928e8264ae4783d97f77700a0f747b31d4bab (patch)
tree1b5e5936f0d08159d1bc5b85758cf42da348d885
parentdev-util/rizin: add 0.3.2 (diff)
downloadgentoo-3e8928e8264ae4783d97f77700a0f747b31d4bab.tar.gz
gentoo-3e8928e8264ae4783d97f77700a0f747b31d4bab.tar.bz2
gentoo-3e8928e8264ae4783d97f77700a0f747b31d4bab.zip
dev-util/rizin: drop 0.3.0, 0.3.1-r1
Bug: https://bugs.gentoo.org/829129 Signed-off-by: John Helmert III <ajak@gentoo.org>
-rw-r--r--dev-util/rizin/Manifest1
-rw-r--r--dev-util/rizin/files/rizin-0.3.0-md4-openssl.patch100
-rw-r--r--dev-util/rizin/rizin-0.3.0.ebuild103
-rw-r--r--dev-util/rizin/rizin-0.3.1-r1.ebuild102
4 files changed, 0 insertions, 306 deletions
diff --git a/dev-util/rizin/Manifest b/dev-util/rizin/Manifest
index c6d198b9cfd0..fe5e33e3c58b 100644
--- a/dev-util/rizin/Manifest
+++ b/dev-util/rizin/Manifest
@@ -1,4 +1,3 @@
-DIST rizin-src-v0.3.0.tar.xz 64097204 BLAKE2B 308037ce60ec6523f337580221ea265c912ff92032fc5e1c2ab37430eae5a16cc2e8efa74447a79735c7814a35d3b08e5fc2f548612a1553c5edc2f314d22df5 SHA512 68f71e612bd4df90c79ebd4cb26c3e09bb370ccd9e51f574f2687f940b3934d9bf417108f3f7e678cabc6ddba7402e0420aab569c24316e07b2b56ed33153ed3
DIST rizin-src-v0.3.1.tar.xz 64089580 BLAKE2B 04f7e3cfa20a787f47af90c78405f295b346cc0c7d81164ff01bc6a69df526f3f9112ab4cb62092297ae2dda1fa738a2e7feff35e0f1b7f3e7467a8c6e4d1a1e SHA512 743f8f2c9ddb045f39147de9ad971d47f1a26bfcc233f41c12c64ade5e31c992104cf3f93c44c5035142b554779e895224b68f839cd87a59aaf344b4ec88d5fe
DIST rizin-src-v0.3.2.tar.xz 64170200 BLAKE2B fe11317e4acc1a803323f42fd4c2c6435a2fe4032581ed509f37f7221ec53e0afac04ebe8cb9da693ac283b61c0a70e135007d635c4c5010519a5c7e7cfa19cf SHA512 c472770ee1b156d42a98d4641f365e2255f16489b2223b117c8b88dcac0d72065d1fd7eedad70046188231889e492bafb7b8462987c68311143f14808eaab1cc
DIST rizin-testbins-d66fa0feaf3b1ecdad261ca17542f1d5d0b101cc.tar.gz 126773703 BLAKE2B f5eaeb7e99e9091b6ca043dd50d03143950adc06b75b5834886d96d6280207c0bea73101a5f9e06c38ba60c0d4cff82dbf1f00364f7d87fe183c0687b06d1904 SHA512 0a017954017c8d57133d51b441411a50aa9ed062c0cc61e1561951fdf0703f5244230cda377885199e9e35dca6780d8582a445ac92286b63ef2ac784777ec0c4
diff --git a/dev-util/rizin/files/rizin-0.3.0-md4-openssl.patch b/dev-util/rizin/files/rizin-0.3.0-md4-openssl.patch
deleted file mode 100644
index d2c3135d1c72..000000000000
--- a/dev-util/rizin/files/rizin-0.3.0-md4-openssl.patch
+++ /dev/null
@@ -1,100 +0,0 @@
-From 6a1edf5fb6967d57d1dcc8cf21ea3a6bbdf8a5b8 Mon Sep 17 00:00:00 2001
-From: wargio <wargio@libero.it>
-Date: Sat, 2 Oct 2021 22:36:32 +0200
-Subject: [PATCH 1/2] Fix nullptr due missing small_block method when openssl
- is used.
-
----
- librz/hash/algorithms/openssl_common.h | 42 ++++++++++++++++++++++++++
- 1 file changed, 42 insertions(+)
-
-diff --git a/librz/hash/algorithms/openssl_common.h b/librz/hash/algorithms/openssl_common.h
-index b29a1ae1221..e2399cff68d 100644
---- a/librz/hash/algorithms/openssl_common.h
-+++ b/librz/hash/algorithms/openssl_common.h
-@@ -76,6 +76,46 @@ EVP_sha512
- return true; \
- }
-
-+#define rz_openssl_plugin_small_block(pluginname, evpmd) \
-+ static bool openssl_plugin_##pluginname##_small_block(const ut8 *data, ut64 size, ut8 **digest, RzMsgDigestSize *digest_size) { \
-+ rz_return_val_if_fail(data &&digest, false); \
-+ const EVP_MD *evp_md = evpmd(); \
-+ if (!evp_md) { \
-+ return false; \
-+ } \
-+ RzMsgDigestSize dgst_size = EVP_MD_size(evp_md); \
-+ ut8 *dgst = malloc(dgst_size); \
-+ if (!dgst) { \
-+ return false; \
-+ } \
-+ EVP_MD_CTX *context = EVP_MD_CTX_new(); \
-+ if (!context) { \
-+ free(dgst); \
-+ return false; \
-+ } \
-+ if (EVP_DigestInit_ex(context, evp_md, NULL) != 1) { \
-+ EVP_MD_CTX_free(context); \
-+ free(dgst); \
-+ return false; \
-+ } \
-+ if (EVP_DigestUpdate(context, data, size) != 1) { \
-+ EVP_MD_CTX_free(context); \
-+ free(dgst); \
-+ return false; \
-+ } \
-+ if (EVP_DigestFinal_ex(context, dgst, NULL) != 1) { \
-+ EVP_MD_CTX_free(context); \
-+ free(dgst); \
-+ return false; \
-+ } \
-+ *digest = dgst; \
-+ if (digest_size) { \
-+ *digest_size = dgst_size; \
-+ } \
-+ EVP_MD_CTX_free(context); \
-+ return true; \
-+ }
-+
- #define rz_openssl_plugin_define_msg_digest(pluginname, evpmd, canhmac) \
- rz_openssl_plugin_context_new(pluginname); \
- rz_openssl_plugin_context_free(pluginname); \
-@@ -84,6 +124,7 @@ EVP_sha512
- rz_openssl_plugin_init(pluginname, evpmd); \
- rz_openssl_plugin_update(pluginname); \
- rz_openssl_plugin_final(pluginname); \
-+ rz_openssl_plugin_small_block(pluginname, evpmd); \
- RzMsgDigestPlugin rz_msg_digest_plugin_##pluginname = { \
- .name = #pluginname, \
- .license = "Apache 2.0", \
-@@ -96,6 +137,7 @@ EVP_sha512
- .init = openssl_plugin_##pluginname##_init, \
- .update = openssl_plugin_##pluginname##_update, \
- .final = openssl_plugin_##pluginname##_final, \
-+ .small_block = openssl_plugin_##pluginname##_small_block, \
- }
-
- #endif /* RZ_OPENSSL_COMMON_H */
-
-From f4a8e2c86be861f33327c2a8f1d181b42232069e Mon Sep 17 00:00:00 2001
-From: wargio <wargio@libero.it>
-Date: Sat, 2 Oct 2021 23:07:54 +0200
-Subject: [PATCH 2/2] Fix style
-
----
- librz/hash/algorithms/openssl_common.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/librz/hash/algorithms/openssl_common.h b/librz/hash/algorithms/openssl_common.h
-index e2399cff68d..0091fef2fa3 100644
---- a/librz/hash/algorithms/openssl_common.h
-+++ b/librz/hash/algorithms/openssl_common.h
-@@ -78,7 +78,7 @@ EVP_sha512
-
- #define rz_openssl_plugin_small_block(pluginname, evpmd) \
- static bool openssl_plugin_##pluginname##_small_block(const ut8 *data, ut64 size, ut8 **digest, RzMsgDigestSize *digest_size) { \
-- rz_return_val_if_fail(data &&digest, false); \
-+ rz_return_val_if_fail((data) && (digest), false); \
- const EVP_MD *evp_md = evpmd(); \
- if (!evp_md) { \
- return false; \
diff --git a/dev-util/rizin/rizin-0.3.0.ebuild b/dev-util/rizin/rizin-0.3.0.ebuild
deleted file mode 100644
index 0ac6575d67e4..000000000000
--- a/dev-util/rizin/rizin-0.3.0.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=(python3_{8,9,10})
-
-# This is the commit that the CI for the release commit used
-BINS_COMMIT="d4cee85f3e94f1151dc9ff1681555ebcff7931f0"
-
-inherit meson python-any-r1
-
-DESCRIPTION="reverse engineering framework for binary analysis"
-HOMEPAGE="https://rizin.re/"
-
-SRC_URI="https://github.com/rizinorg/rizin/releases/download/v${PV}/rizin-src-v${PV}.tar.xz"
- #test? ( https://github.com/rizinorg/rizin-testbins/archive/${BINS_COMMIT}.tar.gz -> rizin-testbins-${BINS_COMMIT}.tar.gz )"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-LICENSE="Apache-2.0 BSD LGPL-3 MIT"
-SLOT="0"
-IUSE="test"
-
-# Need to audit licenses of the binaries used for testing
-RESTRICT="test"
-
-RDEPEND="
- sys-apps/file
- app-arch/lz4:0=
- dev-libs/capstone:0=
- dev-libs/libuv:0=
- dev-libs/libzip:0=
- dev-libs/openssl:0=
- >=dev-libs/tree-sitter-0.19.0
- dev-libs/xxhash
- sys-libs/zlib:0=
-"
-DEPEND="${RDEPEND}"
-BDEPEND="${PYTHON_DEPS}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-${PV}-typedb-prefix.patch"
- "${FILESDIR}/${PN}-${PV}-md4-openssl.patch"
-)
-
-S="${WORKDIR}/${PN}-v${PV}"
-
-src_prepare() {
- default
-
- local py_to_mangle=(
- librz/core/cmd_descs/cmd_descs_generate.py
- subprojects/lz4-1.9.3/contrib/meson/meson/GetLz4LibraryVersion.py
- subprojects/lz4-1.9.3/contrib/meson/meson/InstallSymlink.py
- subprojects/lz4-1.9.3/tests/test-lz4-list.py
- subprojects/lz4-1.9.3/tests/test-lz4-speed.py
- subprojects/lz4-1.9.3/tests/test-lz4-versions.py
- sys/clang-format.py
- test/fuzz/scripts/fuzz_rz_asm.py
- test/scripts/gdbserver.py
- )
-
- python_fix_shebang "${py_to_mangle[@]}"
-
- if use test; then
- cp -r "${WORKDIR}/rizin-testbins-${BINS_COMMIT}" "${S}/test/bins" || die
- cp -r "${WORKDIR}/rizin-testbins-${BINS_COMMIT}" "${S}" || die
- fi
-}
-
-src_configure() {
- local emesonargs=(
- -Dcli=enabled
- -Duse_sys_capstone=enabled
- -Duse_sys_magic=enabled
- -Duse_sys_libzip=enabled
- -Duse_sys_zlib=enabled
- -Duse_sys_lz4=enabled
- -Duse_sys_xxhash=enabled
- -Duse_sys_openssl=enabled
- -Duse_sys_tree_sitter=enabled
-
- $(meson_use test enable_tests)
- $(meson_use test enable_rz_test)
- )
- meson_src_configure
-}
-
-src_test() {
- # Rizin uses data files that it expects to be installed on the
- # system. To hack around this, we create a tree of what it expects
- # in ${T}, and patch the tests to support a prefix from the
- # environment. https://github.com/rizinorg/rizin/issues/1789
- mkdir -p "${T}/usr/share/${PN}/${PV}" || die
- ln -sf "${BUILD_DIR}/librz/analysis/d" "${T}/usr/share/${PN}/${PV}/types" || die
- ln -sf "${BUILD_DIR}/librz/syscall/d" "${T}/usr/share/${PN}/${PV}/syscall" || die
- ln -sf "${BUILD_DIR}/librz/asm/d" "${T}/usr/share/${PN}/${PV}/opcodes" || die
- # https://github.com/rizinorg/rizin/issues/1797
- ln -sf "${BUILD_DIR}/librz/flag/d" "${T}/usr/share/${PN}/${PV}/flag" || die
- export RZ_PREFIX="${T}/usr"
-
- meson_src_test
-}
diff --git a/dev-util/rizin/rizin-0.3.1-r1.ebuild b/dev-util/rizin/rizin-0.3.1-r1.ebuild
deleted file mode 100644
index 84113bbf4057..000000000000
--- a/dev-util/rizin/rizin-0.3.1-r1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=(python3_{8,9,10})
-
-# This is the commit that the CI for the release commit used
-BINS_COMMIT="74b6e4511112b1a6abc571091efc32ec2a7d98a6"
-
-inherit meson python-any-r1
-
-DESCRIPTION="reverse engineering framework for binary analysis"
-HOMEPAGE="https://rizin.re/"
-
-SRC_URI="https://github.com/rizinorg/rizin/releases/download/v${PV}/rizin-src-v${PV}.tar.xz"
- #test? ( https://github.com/rizinorg/rizin-testbins/archive/${BINS_COMMIT}.tar.gz -> rizin-testbins-${BINS_COMMIT}.tar.gz )"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-LICENSE="Apache-2.0 BSD LGPL-3 MIT"
-SLOT="0/${PV}"
-IUSE="test"
-
-# Need to audit licenses of the binaries used for testing
-RESTRICT="test"
-
-RDEPEND="
- sys-apps/file
- app-arch/lz4:0=
- dev-libs/capstone:0=
- dev-libs/libuv:0=
- dev-libs/libzip:0=
- dev-libs/openssl:0=
- >=dev-libs/tree-sitter-0.19.0
- dev-libs/xxhash
- sys-libs/zlib:0=
-"
-DEPEND="${RDEPEND}"
-BDEPEND="${PYTHON_DEPS}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.3.0-typedb-prefix.patch"
-)
-
-S="${WORKDIR}/${PN}-v${PV}"
-
-src_prepare() {
- default
-
- local py_to_mangle=(
- librz/core/cmd_descs/cmd_descs_generate.py
- subprojects/lz4-1.9.3/contrib/meson/meson/GetLz4LibraryVersion.py
- subprojects/lz4-1.9.3/contrib/meson/meson/InstallSymlink.py
- subprojects/lz4-1.9.3/tests/test-lz4-list.py
- subprojects/lz4-1.9.3/tests/test-lz4-speed.py
- subprojects/lz4-1.9.3/tests/test-lz4-versions.py
- sys/clang-format.py
- test/fuzz/scripts/fuzz_rz_asm.py
- test/scripts/gdbserver.py
- )
-
- python_fix_shebang "${py_to_mangle[@]}"
-
- if use test; then
- cp -r "${WORKDIR}/rizin-testbins-${BINS_COMMIT}" "${S}/test/bins" || die
- cp -r "${WORKDIR}/rizin-testbins-${BINS_COMMIT}" "${S}" || die
- fi
-}
-
-src_configure() {
- local emesonargs=(
- -Dcli=enabled
- -Duse_sys_capstone=enabled
- -Duse_sys_magic=enabled
- -Duse_sys_libzip=enabled
- -Duse_sys_zlib=enabled
- -Duse_sys_lz4=enabled
- -Duse_sys_xxhash=enabled
- -Duse_sys_openssl=enabled
- -Duse_sys_tree_sitter=enabled
-
- $(meson_use test enable_tests)
- $(meson_use test enable_rz_test)
- )
- meson_src_configure
-}
-
-src_test() {
- # Rizin uses data files that it expects to be installed on the
- # system. To hack around this, we create a tree of what it expects
- # in ${T}, and patch the tests to support a prefix from the
- # environment. https://github.com/rizinorg/rizin/issues/1789
- mkdir -p "${T}/usr/share/${PN}/${PV}" || die
- ln -sf "${BUILD_DIR}/librz/analysis/d" "${T}/usr/share/${PN}/${PV}/types" || die
- ln -sf "${BUILD_DIR}/librz/syscall/d" "${T}/usr/share/${PN}/${PV}/syscall" || die
- ln -sf "${BUILD_DIR}/librz/asm/d" "${T}/usr/share/${PN}/${PV}/opcodes" || die
- # https://github.com/rizinorg/rizin/issues/1797
- ln -sf "${BUILD_DIR}/librz/flag/d" "${T}/usr/share/${PN}/${PV}/flag" || die
- export RZ_PREFIX="${T}/usr"
-
- meson_src_test
-}