summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Huettel <dilfridge@gentoo.org>2020-02-22 21:12:37 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-22 21:12:37 +0100
commit3f185fb37264ca8d43b5c3f1d8066d501dd9ffd6 (patch)
tree7680539d2d6a36ca91c199f32ccb3b34948c871a
parentsci-libs/armadillo: Version bump; fix HDF5 detection (diff)
downloadgentoo-3f185fb37264ca8d43b5c3f1d8066d501dd9ffd6.tar.gz
gentoo-3f185fb37264ca8d43b5c3f1d8066d501dd9ffd6.tar.bz2
gentoo-3f185fb37264ca8d43b5c3f1d8066d501dd9ffd6.zip
app-text/krop: Fix PyQt5 dependency, bug 699112
Closes: https://bugs.gentoo.org/699112 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas K. Huettel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--app-text/krop/krop-0.5.1-r1.ebuild (renamed from app-text/krop/krop-0.5.1.ebuild)16
-rw-r--r--app-text/krop/krop-9999.ebuild2
2 files changed, 12 insertions, 6 deletions
diff --git a/app-text/krop/krop-0.5.1.ebuild b/app-text/krop/krop-0.5.1-r1.ebuild
index 8dc3d8371c9..3a3c251466e 100644
--- a/app-text/krop/krop-0.5.1.ebuild
+++ b/app-text/krop/krop-0.5.1-r1.ebuild
@@ -1,23 +1,29 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_6 )
-inherit eutils distutils-r1 xdg-utils
+inherit desktop distutils-r1 xdg-utils
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/arminstraub/krop.git"
+else
+ SRC_URI="http://arminstraub.com/downloads/${PN}/${P}.tar.gz"
+ KEYWORDS="amd64 ~x86"
+fi
DESCRIPTION="A tool to crop PDF files"
HOMEPAGE="http://arminstraub.com/software/krop"
-SRC_URI="http://arminstraub.com/downloads/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="amd64 ~x86"
IUSE=""
RDEPEND="dev-python/python-poppler-qt5[${PYTHON_USEDEP}]
dev-python/PyPDF2[${PYTHON_USEDEP}]
- dev-python/PyQt5[${PYTHON_USEDEP}]"
+ dev-python/PyQt5[${PYTHON_USEDEP},gui,widgets]"
src_install() {
distutils-r1_src_install
diff --git a/app-text/krop/krop-9999.ebuild b/app-text/krop/krop-9999.ebuild
index b7f325ef3b8..67c084e81c6 100644
--- a/app-text/krop/krop-9999.ebuild
+++ b/app-text/krop/krop-9999.ebuild
@@ -23,7 +23,7 @@ IUSE=""
RDEPEND="dev-python/python-poppler-qt5[${PYTHON_USEDEP}]
dev-python/PyPDF2[${PYTHON_USEDEP}]
- dev-python/PyQt5[${PYTHON_USEDEP}]"
+ dev-python/PyQt5[${PYTHON_USEDEP},gui,widgets]"
src_install() {
distutils-r1_src_install