summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2021-09-15 12:24:11 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2021-09-15 12:35:41 +0200
commit3fb83568b8a4afa8a665ce16b57c45086d70157a (patch)
treede47c64007b942f9177e75441ff5f7e39a3c06da
parentwww-apps/element: 1.8.5 bump (diff)
downloadgentoo-3fb83568.tar.gz
gentoo-3fb83568.tar.bz2
gentoo-3fb83568.zip
net-mail/fetchmail: 6.4.22 bump
Bug: https://bugs.gentoo.org/810676 Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--net-mail/fetchmail/Manifest1
-rw-r--r--net-mail/fetchmail/fetchmail-6.4.22.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/net-mail/fetchmail/Manifest b/net-mail/fetchmail/Manifest
index 9afaec82dc0b..048cc82e3b88 100644
--- a/net-mail/fetchmail/Manifest
+++ b/net-mail/fetchmail/Manifest
@@ -1,2 +1,3 @@
DIST fetchmail-6.4.21.tar.xz 1318996 BLAKE2B 4c2befad2b7dfa6957889e029572c259be7a20e4b54b864e2cca827540d745a57ad227f8e1fce1336e8f3a1005c780d8fa7c1b10b9ee05ce68dbcfac75afa179 SHA512 c9300f63c0e4073f199a9a7d9061774a7f88aad496b696cad96c0ee85107cae506461f0cd083903c60104b1e7654461213f3f759c1cdaffaf1c85fb1956faa67
+DIST fetchmail-6.4.22.tar.xz 1330176 BLAKE2B 7086f8a3df263f68ae2034321f63c40fcf4759517f46c67ba4b5d3b33ba07d3bb4f512d749a67a2d76991b46847b6dd9df0795a7a28e8166842454001497cfc9 SHA512 ff6db2705b6e3806e22c326da8a0f6bdc0909965cd283b50f9d55bd3a18a52fc4b2f4b4afece1e81aa25b6f1037450cb2b579c4d2cfe4705d34b31d4c1a47e00
DIST fetchmail-7.0.0-alpha9.tar.xz 1213244 BLAKE2B 895fe178993cc34500e276bef5ebe9a4fd81fea522d39fd271433320afc46faa9657d8b85b2d28cd5dbc6d3dbbb233d5eb27d3e26205f5406de9f750c50d7f1b SHA512 7ac1c26edfd2a0d69ba3c1e9f47d96aa48f1cdc10060ff928f952e43141651896f5c5190c41064075fb5c5837516f63d6ff3e7fb0cdc7d389c44b6e39db01d8f
diff --git a/net-mail/fetchmail/fetchmail-6.4.22.ebuild b/net-mail/fetchmail/fetchmail-6.4.22.ebuild
new file mode 100644
index 000000000000..9d676c85c586
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.4.22.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_REQ_USE="tk"
+
+inherit autotools python-single-r1 systemd tmpfiles toolchain-funcs
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="https://www.fetchmail.info/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="ssl nls kerberos tk socks"
+REQUIRED_USE="tk? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="acct-user/fetchmail
+ ssl? (
+ >=dev-libs/openssl-1.1.1:=
+ )
+ kerberos? (
+ virtual/krb5
+ >=dev-libs/openssl-1.0.2:=
+ )
+ nls? ( virtual/libintl )
+ !elibc_glibc? ( sys-fs/e2fsprogs )
+ socks? ( net-proxy/dante )
+ tk? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/future[${PYTHON_USEDEP}]
+ ')
+ )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ sys-devel/flex
+ nls? ( sys-devel/gettext )"
+
+DOCS="FAQ FEATURES NEWS NOTES README README.NTLM README.SSL* TODO"
+HTML_DOCS="*.html"
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.3.26-python-optional.patch
+)
+S=${WORKDIR}/${P/_/.}
+
+pkg_setup() {
+ use tk && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ # don't compile during src_install
+ use tk && : > "${S}"/py-compile
+ eautoreconf
+}
+
+src_configure() {
+ use tk || export PYTHON=:
+
+ econf \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ $(use_enable nls) \
+ $(use_with ssl ssl "${EPREFIX}/usr") \
+ $(use kerberos && echo "--with-ssl=${EPREFIX}/usr") \
+ $(use_with kerberos gssapi) \
+ $(use_with kerberos kerberos5) \
+ --without-hesiod \
+ $(use_with socks)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/fetchmail.initd fetchmail
+ newconfd "${FILESDIR}"/fetchmail.confd fetchmail
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ systemd_newunit "${FILESDIR}"/${PN}_at.service "${PN}@.service"
+ dotmpfiles "${FILESDIR}"/${PN}.conf
+
+ docinto contrib
+ local f
+ for f in contrib/* ; do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+
+ use tk && python_optimize
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Please see /etc/conf.d/fetchmail if you want to adjust"
+ elog "the polling delay used by the fetchmail init script."
+ fi
+}