summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2018-02-12 20:31:12 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2018-02-12 20:31:56 -0500
commit3fe58b8e82d7a2506b32617ca50fd49ed41c5412 (patch)
treeed51a6c6c0c1e7532d0636df36fa1c342d3e5f1a
parentnet-misc/openssh: Drop libressl patch for new X509 patch (diff)
downloadgentoo-3fe58b8e82d7a2506b32617ca50fd49ed41c5412.tar.gz
gentoo-3fe58b8e82d7a2506b32617ca50fd49ed41c5412.tar.bz2
gentoo-3fe58b8e82d7a2506b32617ca50fd49ed41c5412.zip
app-crypt/yubikey-manager: bump to 0.6.0, enable tests, add readme.gentoo
Version bump to 0.6.0. The tests seem to run just fine with the distributed tarball. The package app-crypt/ccid is needed for pcscd to provide support for USB devices. Create a readme about it since it's an easy thing to miss but not so easy to debug. Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--app-crypt/yubikey-manager/Manifest1
-rw-r--r--app-crypt/yubikey-manager/yubikey-manager-0.6.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager/Manifest b/app-crypt/yubikey-manager/Manifest
index 1bef21ccee56..165cacd2dd84 100644
--- a/app-crypt/yubikey-manager/Manifest
+++ b/app-crypt/yubikey-manager/Manifest
@@ -2,3 +2,4 @@ DIST yubikey-manager-0.3.3.tar.gz 51223 BLAKE2B 41bf4e6edfb597420ebc438315c2482b
DIST yubikey-manager-0.4.5.tar.gz 55315 BLAKE2B 231706a14ba9d65474c8bd92cc57fec3f056da1e84b2303b370a7d9e29d3570283099ec30ed803ce53e6388afabee7bae4674ca34e8dc60d30e0443d4686e204 SHA512 232ce7557aaab3c8a27dfa2ceaab0491ac1f97d4332b25e7f77c968da48c9303627defd0246b1e97c7ed766e6a667ac996ac0430cfeb4e7310a0cfc4a633d1b2
DIST yubikey-manager-0.4.6.tar.gz 55065 BLAKE2B a0e8d85252836a6d99e68f637f42397266187372b0fd0723ea6d330a01e42a2b79d9fc5f283d7fab2378fe847aaf0cb307f16694ce59f41aabd7fcc668be01fe SHA512 fd52cb346e95b3184fd8e4bbb8e227c75780d7fcf5057712c6def866ea951700f8cdd1286ff857e32754d539dfc7093d809fc585191b05c57f5f983d5b288e7e
DIST yubikey-manager-0.5.0.tar.gz 59672 BLAKE2B e5dbd32ba644e7b20f03c1511a4ff608c0e6dc93c115edd50077a9a41699411a5fd0eff3d62af1fb13545d977037510f696cbd27150e21308624bfc8613f8bcb SHA512 3a503ced29a557c5adafdd1bc6025a405962cabab7388c96e8f5582165bd33111adeb3b77c7c928cbac905fb085d53ddaefbb12169b54e62b7337c1989636a8a
+DIST yubikey-manager-0.6.0.tar.gz 77823 BLAKE2B 37d9a7e72135ba859521f209896c47423f3573b2f14a56956d145334124f7bf5a4259401a9e89e3f19b2e01a476b96a984e801a28a256815a7773baa44e71773 SHA512 fb49887f4646fe63874be9cb3510ef0d1f9b931ac5fb78f3cc82fb93ada94b36aa06fd91e2ee9d4ea868abedfc206dbedd02fa0c4385d5557d33e07e8099e761
diff --git a/app-crypt/yubikey-manager/yubikey-manager-0.6.0.ebuild b/app-crypt/yubikey-manager/yubikey-manager-0.6.0.ebuild
new file mode 100644
index 000000000000..3379be37dba5
--- /dev/null
+++ b/app-crypt/yubikey-manager/yubikey-manager-0.6.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit readme.gentoo-r1 distutils-r1
+
+DESCRIPTION="Python library and command line tool for configuring a YubiKey"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-crypt/libu2f-host
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pyscard[${PYTHON_USEDEP}]
+ dev-python/pyusb[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
+ sys-auth/ykpers
+"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ local DOC_CONTENTS
+
+ distutils-r1_python_install_all
+
+ DOC_CONTENTS="
+ The 'openpgp' command may require the package 'app-crypt/ccid'
+ to be installed on the system. Furthermore, make sure that pcscd
+ daemon is running and has correct access permissions to USB
+ devices.
+ "
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}