summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2020-06-23 00:27:07 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-07-16 17:38:43 +0300
commit403e1b6a2d459405e69055941553fd326a11ab0a (patch)
tree0050fd6e8173654e436771431292d83aa76e5d3a
parentsys-cluster/spark-bin: Remove 2.4.5 (diff)
downloadgentoo-403e1b6a2d459405e69055941553fd326a11ab0a.tar.gz
gentoo-403e1b6a2d459405e69055941553fd326a11ab0a.tar.bz2
gentoo-403e1b6a2d459405e69055941553fd326a11ab0a.zip
sci-astronomy/stellarium: version 0.20.2
Also added USE-flag to install extra DSO. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/16379 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--sci-astronomy/stellarium/Manifest2
-rw-r--r--sci-astronomy/stellarium/metadata.xml1
-rw-r--r--sci-astronomy/stellarium/stellarium-0.20.2.ebuild91
3 files changed, 94 insertions, 0 deletions
diff --git a/sci-astronomy/stellarium/Manifest b/sci-astronomy/stellarium/Manifest
index 156bf5bab291..e2c36144a7bd 100644
--- a/sci-astronomy/stellarium/Manifest
+++ b/sci-astronomy/stellarium/Manifest
@@ -5,3 +5,5 @@ DIST stars_7_2v0_1.cat 305710678 BLAKE2B 1cc9b4a6bc35a9339e495f7e0da4f7e90a0e92b
DIST stars_8_2v0_1.cat 559068934 BLAKE2B c040a369cdf6885759998e1315b554d21a5e2b9b149a67967a8af45606aebf57bec407fab5ce1904978af0dc529aa6bddd267331ca45f58617bbf56d5ca99dee SHA512 06d4fa298b9dff8452f550377df99fcaa5e7107cfc7b75c9a4769b3cb6d97a822a54213c706102c1d7ef2dabc16df32a85f46b2f6d6c6f76a4e919353b739de4
DIST stellarium-0.19.3.tar.gz 326218851 BLAKE2B 286d2559a2152f030640ed88778f57f1213d0d8b9e990d0aa1ad5138396fe9641083ec76554e1296dc79d914955e289d23046af42299df6217bbfbaca76b2f18 SHA512 c2948603a3b84fd2b7002cbd9993a2432ca0908d9236aca03c03ff0cf0706728a407218096e94da2b2a623b5434c109906d94ee5069a2d57a8e35af7c8455ff7
DIST stellarium-0.20.1.tar.gz 343991703 BLAKE2B 59580dd2bca885893bfc68faaf966a727e3d7c0774f59726e23cec132cbfca4ae518983db2e52d4d3d3f1ec96c7ce876168bb23959178ebf212ee6bb357299b3 SHA512 685a306391dc681cc21834a226e35c769e11909f625ff7461d7e896ba412ad595871e93c69981b342099f46829f9f3ef3e276be867dc5ea5523fa60a99cc21d1
+DIST stellarium-0.20.2.tar.gz 344319520 BLAKE2B 0a64cfc6d5a43bf811609caa9104458768e234bad8fabd2aa88a38d860c22573d076f677f7523c95e1fc1770e73dc1e73b2e94d544cb099c7cd9a21ac79f6bdb SHA512 34f1ad5891dde84b53324046bdf1514df858335ba8f0954bb72350b057ff6dc4091a2d7bf89083489e0d8d1c750c5fb8ba8e1e241f9287a740121b377f0e510c
+DIST stellarium-dso-catalog-3.10.dat 28297970 BLAKE2B 69d8f9756986c872cde0190ae3e5f225de30d8fabd5ba3e007176c8ffc4234e964ccc3beb58f75fc4579c75cee620661728a7c6c1d6960d5cb1be027828ba127 SHA512 22068d9ebca592db214f9831765701c52d07e71616705faaf6f5827d51a65af805947bd1f84553e5768f3e82f9e1a0e81eb36943713afb924d604a4676711b1f
diff --git a/sci-astronomy/stellarium/metadata.xml b/sci-astronomy/stellarium/metadata.xml
index 2e00add2cfd9..53378dcf2286 100644
--- a/sci-astronomy/stellarium/metadata.xml
+++ b/sci-astronomy/stellarium/metadata.xml
@@ -20,6 +20,7 @@
projectors.
</longdescription>
<use>
+ <flag name="deep-sky">Install extra deep sky objects catalog (may affect performance)</flag>
<flag name="media">Enable sound and video support</flag>
<flag name="stars">Install extra star catalogs</flag>
</use>
diff --git a/sci-astronomy/stellarium/stellarium-0.20.2.ebuild b/sci-astronomy/stellarium/stellarium-0.20.2.ebuild
new file mode 100644
index 000000000000..b9d232ba2566
--- /dev/null
+++ b/sci-astronomy/stellarium/stellarium-0.20.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake desktop flag-o-matic xdg virtualx
+
+DESCRIPTION="3D photo-realistic skies in real time"
+HOMEPAGE="https://stellarium.org/"
+MY_DSO_VERSION="3.10"
+SRC_URI="
+ https://github.com/Stellarium/stellarium/releases/download/v${PV}/${P}.tar.gz
+ deep-sky? (
+ https://github.com/Stellarium/stellarium-data/releases/download/dso-${MY_DSO_VERSION}/catalog.dat -> ${PN}-dso-catalog-${MY_DSO_VERSION}.dat
+ )
+ stars? (
+ https://github.com/Stellarium/stellarium-data/releases/download/stars-2.0/stars_4_1v0_2.cat
+ https://github.com/Stellarium/stellarium-data/releases/download/stars-2.0/stars_5_2v0_1.cat
+ https://github.com/Stellarium/stellarium-data/releases/download/stars-2.0/stars_6_2v0_1.cat
+ https://github.com/Stellarium/stellarium-data/releases/download/stars-2.0/stars_7_2v0_1.cat
+ https://github.com/Stellarium/stellarium-data/releases/download/stars-2.0/stars_8_2v0_1.cat
+ )"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug deep-sky gps media nls stars test"
+
+BDEPEND="
+ nls? ( dev-qt/linguist-tools:5 )
+"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtscript:5
+ dev-qt/qtserialport:5
+ dev-qt/qtwidgets:5
+ media-fonts/dejavu
+ sys-libs/zlib
+ virtual/opengl
+ gps? ( dev-qt/qtpositioning:5 )
+ media? ( dev-qt/qtmultimedia:5[widgets] )
+"
+DEPEND="${RDEPEND}
+ dev-qt/qtconcurrent:5
+ test? ( dev-qt/qttest:5 )
+"
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ cmake_src_prepare
+ use debug || append-cppflags -DQT_NO_DEBUG #415769
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_GPS="$(usex gps)"
+ -DENABLE_MEDIA="$(usex media)"
+ -DENABLE_NLS="$(usex nls)"
+ -DENABLE_TESTING="$(usex test)"
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ virtx cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+
+ # use the more up-to-date system fonts
+ rm "${ED}"/usr/share/stellarium/data/DejaVuSans{Mono,}.ttf || die
+ dosym ../../fonts/dejavu/DejaVuSans.ttf /usr/share/stellarium/data/DejaVuSans.ttf
+ dosym ../../fonts/dejavu/DejaVuSansMono.ttf /usr/share/stellarium/data/DejaVuSansMono.ttf
+
+ if use stars ; then
+ insinto /usr/share/${PN}/stars/default
+ doins "${DISTDIR}"/stars_4_1v0_2.cat
+ doins "${DISTDIR}"/stars_{5,6,7,8}_2v0_1.cat
+ fi
+ if use deep-sky ; then
+ insinto /usr/share/${PN}/nebulae/default
+ newins "${DISTDIR}/${PN}-dso-catalog-${MY_DSO_VERSION}.dat" catalog.dat
+ fi
+ newicon doc/images/stellarium-logo.png ${PN}.png
+}