summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2020-06-12 13:29:00 -0400
committerBrian Evans <grknight@gentoo.org>2020-06-12 13:29:00 -0400
commit404cc30aff3913e0669ecc32aee66f4a2b609ae3 (patch)
treea4b70d29ef41c5d0a2eb2af0e28a900176e1877c
parentdev-lang/rust: fix cross triple detection (diff)
downloadgentoo-404cc30aff3913e0669ecc32aee66f4a2b609ae3.tar.gz
gentoo-404cc30aff3913e0669ecc32aee66f4a2b609ae3.tar.bz2
gentoo-404cc30aff3913e0669ecc32aee66f4a2b609ae3.zip
mail-client/s-nail: Version bump for 14.9.19
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Brian Evans <grknight@gentoo.org>
-rw-r--r--mail-client/s-nail/Manifest1
-rw-r--r--mail-client/s-nail/s-nail-14.9.19.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/mail-client/s-nail/Manifest b/mail-client/s-nail/Manifest
index 0c30c85a81d6..2e0b8ebf5a77 100644
--- a/mail-client/s-nail/Manifest
+++ b/mail-client/s-nail/Manifest
@@ -1,3 +1,4 @@
DIST s-nail-14.9.13.tar.xz 734416 BLAKE2B b23de9c32357d5b88ecb723dc875d3366b2b4c57dd654a4f2422e8bb81b781a76568eb0955990d4166f034bf40459fa5d2992da6e7f2b403a641a4d4c0c1e200 SHA512 6467846fab5752c708886ba7a66cd2038effc0cf8d72e2feb670283cf1d5436c27037087eeaa201c074964476ff0c213cffe74169fb03089ebf964fcc766e6ea
DIST s-nail-14.9.15.tar.xz 757180 BLAKE2B 9d3efe43e6f1f4486bb66bb0060a6b656097c4b6d95e5f22e209e7464bd92bc9cf42a36009d674a3ee032ab32f64ecef2aa0cc1b09519a7760bf5d1145e35c5d SHA512 ca95c544890a13b475fb12f882a172942f29517319956eccab1fbc2a67625fe53e3f0cc10c31daac98e28bb1fae48364d80db9ec35f0e6cc71d748290a2635df
DIST s-nail-14.9.16.tar.xz 790052 BLAKE2B c12dcb3e0f412b34a3f3214ad3be05095ac5045932f5605b59a21ae953c0edb2619cdff1c67249a2ff8a02d809af08d2559af4319462d39dab37df1f904a4d13 SHA512 147c9dbd6abf9a17778eafa36f1cd85b0f769e6acbae06d67d0aa8b9c8b940f78e115d13d277d4269ea44c9ad6dbe75228da9878d9eebb233cb354f3d548089f
+DIST s-nail-14.9.19.tar.xz 792952 BLAKE2B 6d21f48862edaee2f0c6c37e61378551365d3e5169ee4cb6c64e05e35c977b6b14b7ae2a24201df305c723ab0bbd2b6873b04126014840ad50128c45a1375161 SHA512 53c8cf7449afc3e99029ad54ed9c63edefce8ca00cd32dab138c34a7ced7d16852e45e5ad3949b2b8d7baa17421ce38079405781517cdbd3cb67d773bad561f8
diff --git a/mail-client/s-nail/s-nail-14.9.19.ebuild b/mail-client/s-nail/s-nail-14.9.19.ebuild
new file mode 100644
index 000000000000..2ab1bbc671bf
--- /dev/null
+++ b/mail-client/s-nail/s-nail-14.9.19.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+HOMEPAGE="https://www.sdaoden.eu/code.html"
+DESCRIPTION="Enhanced mailx-compatible mail client based on Hierloom mailx (nail)"
+LICENSE="BSD BSD-4 ISC RSA"
+
+SRC_URI="https://ftp.sdaoden.eu/${P}.tar.xz"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="idn kerberos libressl net ssl"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ virtual/libiconv
+ idn? ( net-dns/libidn2 )
+ net? (
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ kerberos? ( virtual/krb5 )
+ )
+ !mail-client/mailx
+ !net-mail/mailutils
+ !mail-client/nail
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/awk"
+
+src_configure() {
+ local confopts=(
+ CC=$(tc-getCC)
+ EXTRA_CFLAGS=-std=c99
+ strip=/bin/true
+ OPT_AUTOCC=no
+ VAL_PREFIX="${EPREFIX}"/usr
+ VAL_SYSCONFDIR="${EPREFIX}"/etc
+ VAL_MTA="${EPREFIX}/usr/sbin/sendmail"
+ VAL_MAIL='/var/spool/mail'
+ VAL_PAGER=less
+ $(usex idn VAL_IDNA=idn2 OPT_IDNA=no)
+ VERBOSE=1
+ )
+
+ if use net; then
+ confopts+=( OPT_TLS=$(usex ssl require no)
+ OPT_GSSAPI=$(usex kerberos require no)
+ )
+ else
+ confopts+=( OPT_NET=no )
+ fi
+
+ tc-is-cross-compiler && confopts+=( OPT_CROSS_BUILD=yes )
+
+ emake "${confopts[@]}" config
+}
+
+src_compile() {
+ emake build
+}
+
+src_install() {
+ # Use /usr/sbin/sendmail by default and provide an example
+ cat <<- EOSMTP >> nail.rc
+
+ # Use the local sendmail (/usr/sbin/sendmail) binary by default.
+ # (Uncomment the following line to use a SMTP server)
+ #set smtp=localhost
+
+ # Ask for CC: list too.
+ set askcc
+ EOSMTP
+
+ emake DESTDIR="${D}" install
+
+ dodoc INSTALL NEWS README THANKS
+
+ dodir /bin
+ dosym ../usr/bin/mailx /bin/mail
+ dosym s-nail /usr/bin/mailx
+ dosym mailx /usr/bin/mail
+ dosym mailx /usr/bin/Mail
+
+ dosym s-nail.1 /usr/share/man/man1/mailx.1
+ dosym mailx.1 /usr/share/man/man1/mail.1
+ dosym mailx.1 /usr/share/man/man1/Mail.1
+}