summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-03-17 18:58:53 +0200
committerMart Raudsepp <leio@gentoo.org>2019-03-17 18:59:08 +0200
commit408f0a1c6c390fde2122f2bbc50d091b359462f7 (patch)
tree4894e6f463129f36290fb7b62228a1fe58de91ce
parentapp-text/libgepub: bump to 0.6.0 (diff)
downloadgentoo-408f0a1c6c390fde2122f2bbc50d091b359462f7.tar.gz
gentoo-408f0a1c6c390fde2122f2bbc50d091b359462f7.tar.bz2
gentoo-408f0a1c6c390fde2122f2bbc50d091b359462f7.zip
gnome-extra/gnome-documents: bump to 3.30.1
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--gnome-extra/gnome-documents/Manifest1
-rw-r--r--gnome-extra/gnome-documents/gnome-documents-3.30.1.ebuild70
-rw-r--r--gnome-extra/gnome-documents/metadata.xml6
3 files changed, 77 insertions, 0 deletions
diff --git a/gnome-extra/gnome-documents/Manifest b/gnome-extra/gnome-documents/Manifest
index 31dea3462925..d5c8e070f5b6 100644
--- a/gnome-extra/gnome-documents/Manifest
+++ b/gnome-extra/gnome-documents/Manifest
@@ -1,2 +1,3 @@
DIST gnome-documents-3.24.3.tar.xz 2313680 BLAKE2B 920e18b0ca43cfa95945268613f15f2f417de74c8992aefe414205d3463c0cdaac81fcabb9453ac93a76ae7b221da73379d86902b483fe2f3d12063ac27acdf7 SHA512 c5b59ba4a2eb83d7c61e6e50f6af2d0b310c7b9709ea7c8a02da707cc7e335589e4bef7b6f6618bbcca729fdaed531647f7f839aa3538830a226b837d0f0118a
DIST gnome-documents-3.26.3.tar.xz 2453132 BLAKE2B e430c5f4dc68578d5fa14a87b0544f20ed6a3f90351abe3fc1505addd65b41affe46981d5035b70fb750a16193eddbfbf205040d3a96e633e8e78ff98e340156 SHA512 d37f763817f617163d1cb85fa8b4d06048a099494e129effdd8e4db7b62178925c6b238150d145565017ce9cf0e2af9acc47623493d4e2df353bab669b076fb6
+DIST gnome-documents-3.30.1.tar.xz 4777500 BLAKE2B 889a089e4968e233185a6018559487e0cede40bbe789bee3e1eaab3283bf66f797dbcf7281361432d0b3a41b68b1914efbfb5be4875fa1986cbe3241a40cbcb5 SHA512 89966d49ececa11ab49eb0e192c6a1d398ef13f2f809a02cca2d13f7ffa4cef45a29801971edec22d2f471ab4291a058c702842e323cb2a1ddd7fcc37d51b6cb
diff --git a/gnome-extra/gnome-documents/gnome-documents-3.30.1.ebuild b/gnome-extra/gnome-documents/gnome-documents-3.30.1.ebuild
new file mode 100644
index 000000000000..84723539bfd9
--- /dev/null
+++ b/gnome-extra/gnome-documents/gnome-documents-3.30.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A document manager application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Documents"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+# cairo-1.14 for cairo_surface_set_device_scale check and usage
+COMMON_DEPEND="
+ >=app-text/evince-3.13.3[introspection]
+ app-misc/tracker:0/2.0
+ >=dev-libs/gjs-1.48.0
+ >=dev-libs/glib-2.39.3:2
+ gnome-base/gnome-desktop:3=[introspection]
+ >=dev-libs/gobject-introspection-1.54:=
+ >=x11-libs/gtk+-3.22.15:3[introspection]
+ >=net-libs/libsoup-2.41.3:2.4
+ >=net-libs/webkit-gtk-2.6:4[introspection]
+
+ >=dev-libs/libgdata-0.13.3:=[crypt,gnome-online-accounts,introspection]
+ >=app-text/libgepub-0.6[introspection]
+ <app-text/libgepub-0.7
+ >=net-libs/gnome-online-accounts-3.2.0[introspection]
+ >=net-libs/libzapojit-0.0.2[introspection]
+
+ >=x11-libs/cairo-1.14
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/pango[introspection]
+"
+RDEPEND="${COMMON_DEPEND}
+ >=app-misc/tracker-miners-2
+ net-misc/gnome-online-miners
+ sys-apps/dbus
+ x11-themes/adwaita-icon-theme
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/appstream-glib
+ dev-libs/libxslt
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocumentation=true #manpage
+ -Dgetting_started=false #inkscape and pdfunite build deps
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/gnome-extra/gnome-documents/metadata.xml b/gnome-extra/gnome-documents/metadata.xml
index 39980802b1da..09d5a11a622b 100644
--- a/gnome-extra/gnome-documents/metadata.xml
+++ b/gnome-extra/gnome-documents/metadata.xml
@@ -5,4 +5,10 @@
<email>gnome@gentoo.org</email>
<name>Gentoo GNOME Desktop</name>
</maintainer>
+<longdescription lang="en">
+ A simple application to access, organize and share your documents on
+ GNOME. It is meant to be a simple and elegant replacement for using a
+ file manager to deal with documents. Seamless cloud integration is offered
+ through GNOME Online Accounts.
+</longdescription>
</pkgmetadata>