summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2022-03-18 12:57:35 +0100
committerDennis Lamm <expeditioneer@gentoo.org>2022-03-18 18:07:32 +0100
commit40cd1cf20bed784a64d2c3935543a1c0806a35aa (patch)
tree8cd4c9b90c727dee5ac8ef023c23548bff566677
parentnet-nds/389-ds-base: removed unnecessary version requirement for openldap (diff)
downloadgentoo-40cd1cf20bed784a64d2c3935543a1c0806a35aa.tar.gz
gentoo-40cd1cf20bed784a64d2c3935543a1c0806a35aa.tar.bz2
gentoo-40cd1cf20bed784a64d2c3935543a1c0806a35aa.zip
net-nds/389-ds-base: added desired changes from package maintainer
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/24637 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
-rw-r--r--net-nds/389-ds-base/389-ds-base-1.4.4.19-r1.ebuild2
-rw-r--r--net-nds/389-ds-base/389-ds-base-2.1.0.ebuild17
2 files changed, 8 insertions, 11 deletions
diff --git a/net-nds/389-ds-base/389-ds-base-1.4.4.19-r1.ebuild b/net-nds/389-ds-base/389-ds-base-1.4.4.19-r1.ebuild
index 462957b2a8a2..f7b6df4f5029 100644
--- a/net-nds/389-ds-base/389-ds-base-1.4.4.19-r1.ebuild
+++ b/net-nds/389-ds-base/389-ds-base-1.4.4.19-r1.ebuild
@@ -176,7 +176,7 @@ BDEPEND=">=sys-devel/autoconf-2.69-r5
# perl dependencies are for logconv.pl
RDEPEND="${DEPEND}
- !net-nds/389-ds-base:0
+ !net-nds/389-ds-base:2.1
acct-user/dirsrv
acct-group/dirsrv
${PYTHON_DEPS}
diff --git a/net-nds/389-ds-base/389-ds-base-2.1.0.ebuild b/net-nds/389-ds-base/389-ds-base-2.1.0.ebuild
index 05b0ebfd34ba..2a2646b7dd3a 100644
--- a/net-nds/389-ds-base/389-ds-base-2.1.0.ebuild
+++ b/net-nds/389-ds-base/389-ds-base-2.1.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
CRATES="
ahash-0.7.6
@@ -116,7 +116,7 @@ PYTHON_COMPAT=( python3_{8,9,10} )
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_SETUPTOOLS=rdepend
-inherit autotools distutils-r1 systemd tmpfiles db-use cargo
+inherit autotools distutils-r1 systemd tmpfiles cargo
DESCRIPTION="389 Directory Server (core libraries and daemons)"
HOMEPAGE="https://directory.fedoraproject.org/"
@@ -133,13 +133,12 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
# lib389 tests (which is most of the suite) can't find their own modules.
RESTRICT="test"
-# always list newer first
# Do not add any AGPL-3 BDB here!
# See bug 525110, comment 15.
-BERKDB_SLOTS=( 5.3 )
DEPEND="
>=app-crypt/mit-krb5-1.7-r100[openldap]
+ dev-db/lmdb:=
>=dev-libs/cyrus-sasl-2.1.19:2[kerberos]
>=dev-libs/icu-60.2:=
dev-libs/nspr
@@ -148,11 +147,9 @@ DEPEND="
dev-libs/libpcre:3
dev-libs/openssl:0=
>=net-analyzer/net-snmp-5.1.2:=
- >=net-nds/openldap[sasl]
- || (
- $(for slot in ${BERKDB_SLOTS[@]} ; do printf '%s\n' "sys-libs/db:${slot}" ; done)
- )
+ net-nds/openldap[sasl]
sys-libs/cracklib
+ sys-libs/db:5.3
|| ( sys-fs/e2fsprogs sys-libs/e2fsprogs-libs )
pam-passthru? ( sys-libs/pam )
selinux? (
@@ -176,7 +173,7 @@ BDEPEND=">=sys-devel/autoconf-2.69-r5
# perl dependencies are for logconv.pl
RDEPEND="${DEPEND}
- !net-nds/389-ds-base:0
+ !net-nds/389-ds-base:1.4
acct-user/dirsrv
acct-group/dirsrv
${PYTHON_DEPS}
@@ -243,7 +240,7 @@ src_configure() {
--with-pythonexec="${PYTHON}"
--with-fhs
--with-openldap
- --with-db-inc="$(db_includedir)"
+ --with-db-inc="${EPREFIX}"/usr/include/db5.3
--disable-cockpit
)