summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-04-26 18:06:21 +0200
committerJeroen Roovers <jer@gentoo.org>2018-04-26 18:17:51 +0200
commit412a016e2db2ae18afbe281a56c4ca2dd4d3585c (patch)
treefb157511709a90a119fdf4e58f794fb5ceca5fa8
parentwww-client/opera-developer: Old. (diff)
downloadgentoo-412a016e2db2ae18afbe281a56c4ca2dd4d3585c.tar.gz
gentoo-412a016e2db2ae18afbe281a56c4ca2dd4d3585c.tar.bz2
gentoo-412a016e2db2ae18afbe281a56c4ca2dd4d3585c.zip
net-analyzer/wireshark: Version 2.6.0.
Package-Manager: Portage-2.3.31, Repoman-2.3.9
-rw-r--r--net-analyzer/wireshark/Manifest1
-rw-r--r--net-analyzer/wireshark/wireshark-2.6.0.ebuild261
2 files changed, 262 insertions, 0 deletions
diff --git a/net-analyzer/wireshark/Manifest b/net-analyzer/wireshark/Manifest
index 3df54a763b28..3c55088753b7 100644
--- a/net-analyzer/wireshark/Manifest
+++ b/net-analyzer/wireshark/Manifest
@@ -2,3 +2,4 @@ DIST wireshark-2.4.5.tar.xz 28836740 BLAKE2B 797540daca259a2d5d7dc6e637f2b504b6d
DIST wireshark-2.4.6.tar.xz 28851192 BLAKE2B 19a69d077b794ab07fbfb22b7cf9e61ff54ded5dcd0396ba97d1cbd99addaeb9670d5a870f5e83c39384230def04c078d676580bded81746753716cb392ee05a SHA512 171047fa36a6cb29d1edb8e28086e24075f8b77581d9f3142fa39af8ae3d6dfe0c2e41a9335ca5d9851578b54ac9e6e74ff5bd92a96af262a5cc7a73857b8b81
DIST wireshark-2.5.0.tar.xz 28197388 BLAKE2B 5d50d3752078a71d1d83f48a85ee564d14950efab39d5679430a61a266f9b93749278cd19d155036326753fbab86f83c5edb764adec5d68325730dbba19a920f SHA512 963c03dd363850cd0ad8a32a3e8c85410f2b23fadc081f00e4e3a2ad3a324a5f35626fbb7e490ec01c61260500363fef93c52bf7796b917e9490fff4044ee67f
DIST wireshark-2.5.1.tar.xz 28229472 BLAKE2B ac832e3d8727a20754153949d7dfba9cfbc359955e55c06a9181ecbd3c9d9ddac269a745a430c47907b3e205d1b593241e0908b5b6c232613cbd4d23c96c4f61 SHA512 c3e1abb1c8b6a035640d655c59bfb8a9a846c88f49035b8086ae81a6e74cb296419f15bc4969489208fdce6578d279663c6fbc8d6eebff1b6097d1dbd0e71b75
+DIST wireshark-2.6.0.tar.xz 28314868 BLAKE2B 2121a667115474ac4b1fe05d50ffc02383bf7a8057ea072480455562c62a75d18f3c6b6886ca1e7345101d15057a67a250a3d2a2050777ff5bb1654279b1ac87 SHA512 a419ed32caeb9f25fc26e345c7baf7d847fee35730c64efad66870a786b26b9f8d5a8665b8b99be88f9cf504f6d9e640584d9849558ff09efc83400588dc6da8
diff --git a/net-analyzer/wireshark/wireshark-2.6.0.ebuild b/net-analyzer/wireshark/wireshark-2.6.0.ebuild
new file mode 100644
index 000000000000..75b779a48983
--- /dev/null
+++ b/net-analyzer/wireshark/wireshark-2.6.0.ebuild
@@ -0,0 +1,261 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils fcaps flag-o-matic gnome2-utils multilib qmake-utils user xdg-utils
+
+DESCRIPTION="A network protocol analyzer formerly known as ethereal"
+HOMEPAGE="https://www.wireshark.org/"
+SRC_URI="${HOMEPAGE}download/src/all-versions/${P/_/}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc64 ~x86"
+IUSE="
+ adns androiddump bcg729 +capinfos +caps +captype ciscodump
+ cpu_flags_x86_sse4_2 +dftest doc +dumpcap +editcap gtk kerberos libssh
+ libxml2 lua lz4 maxminddb +mergecap +netlink nghttp2 +pcap portaudio +qt5
+ +randpkt +randpktdump +reordercap sbc selinux +sharkd smi snappy spandsp
+ sshdump ssl +text2pcap tfshark +tshark +udpdump zlib
+"
+REQUIRED_USE="
+ ciscodump? ( libssh )
+ sshdump? ( libssh )
+"
+
+S=${WORKDIR}/${P/_/}
+
+CDEPEND="
+ >=dev-libs/glib-2.14:2
+ dev-libs/libgcrypt:0
+ netlink? ( dev-libs/libnl:3 )
+ adns? ( >=net-dns/c-ares-1.5 )
+ bcg729? ( media-libs/bcg729 )
+ caps? ( sys-libs/libcap )
+ gtk? (
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/pango
+ x11-misc/xdg-utils
+ )
+ kerberos? ( virtual/krb5 )
+ libssh? ( >=net-libs/libssh-0.6 )
+ libxml2? ( dev-libs/libxml2 )
+ lua? ( >=dev-lang/lua-5.1:* )
+ lz4? ( app-arch/lz4 )
+ maxminddb? ( dev-libs/libmaxminddb )
+ nghttp2? ( net-libs/nghttp2 )
+ pcap? ( net-libs/libpcap )
+ portaudio? ( media-libs/portaudio )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ || (
+ media-libs/speexdsp
+ <media-libs/speex-1.2.0
+ )
+ x11-misc/xdg-utils
+ )
+ sbc? ( media-libs/sbc )
+ smi? ( net-libs/libsmi )
+ snappy? ( app-arch/snappy )
+ spandsp? ( media-libs/spandsp )
+ ssl? ( net-libs/gnutls:= )
+ zlib? ( sys-libs/zlib !=sys-libs/zlib-1.2.4 )
+"
+# We need perl for `pod2html`. The rest of the perl stuff is to block older
+# and broken installs. #455122
+DEPEND="
+ ${CDEPEND}
+ dev-lang/perl
+ !<virtual/perl-Pod-Simple-3.170
+ !<perl-core/Pod-Simple-3.170
+ doc? (
+ app-doc/doxygen
+ dev-ruby/asciidoctor
+ )
+ qt5? (
+ dev-qt/linguist-tools:5
+ )
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+"
+RDEPEND="
+ ${CDEPEND}
+ gtk? ( virtual/freedesktop-icon-theme )
+ qt5? ( virtual/freedesktop-icon-theme )
+ selinux? ( sec-policy/selinux-wireshark )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.99.8-qtchooser.patch
+ "${FILESDIR}"/${PN}-2.1.0-sse4_2-r1.patch
+ "${FILESDIR}"/${PN}-2.4-androiddump.patch
+ "${FILESDIR}"/${PN}-99999999-androiddump.patch
+)
+
+pkg_setup() {
+ enewgroup wireshark
+}
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ # Workaround bug #213705. If krb5-config --libs has -lcrypto then pass
+ # --with-ssl to ./configure. (Mimics code from acinclude.m4).
+ if use kerberos; then
+ case $(krb5-config --libs) in
+ *-lcrypto*)
+ ewarn "Kerberos was built with ssl support: linkage with openssl is enabled."
+ ewarn "Note there are annoying license incompatibilities between the OpenSSL"
+ ewarn "license and the GPL, so do your check before distributing such package."
+ myconf+=( "--with-ssl" )
+ ;;
+ esac
+ fi
+
+ # Enable wireshark binary with any supported GUI toolkit (bug #473188)
+ if use gtk || use qt5; then
+ myconf+=( "--enable-wireshark" )
+ else
+ myconf+=( "--disable-wireshark" )
+ fi
+
+ if ! use qt5; then
+ myconf+=( "--with-qt=no" )
+ fi
+
+ if use qt5; then
+ export QT_MIN_VERSION=5.3.0
+ append-cxxflags -fPIC -DPIC
+ fi
+
+ econf \
+ $(use androiddump && use pcap && echo --enable-androiddump-use-libpcap=yes) \
+ $(use dumpcap && use_with pcap dumpcap-group wireshark) \
+ $(use_enable androiddump) \
+ $(use_enable capinfos) \
+ $(use_enable captype) \
+ $(use_enable ciscodump) \
+ $(use_enable dftest) \
+ $(use_enable doc guides) \
+ $(use_enable dumpcap) \
+ $(use_enable editcap) \
+ $(use_enable mergecap) \
+ $(use_enable randpkt) \
+ $(use_enable randpktdump) \
+ $(use_enable reordercap) \
+ $(use_enable sharkd) \
+ $(use_enable sshdump) \
+ $(use_enable text2pcap) \
+ $(use_enable tfshark) \
+ $(use_enable tshark) \
+ $(use_enable udpdump) \
+ $(use_with adns c-ares) \
+ $(use_with bcg729) \
+ $(use_with caps libcap) \
+ $(use_with gtk gtk 3) \
+ $(use_with kerberos krb5) \
+ $(use_with libssh) \
+ $(use_with libxml2) \
+ $(use_with lua) \
+ $(use_with lz4) \
+ $(use_with maxminddb) \
+ $(use_with nghttp2) \
+ $(use_with pcap) \
+ $(use_with portaudio) \
+ $(use_with sbc) \
+ $(use_with smi libsmi) \
+ $(use_with snappy) \
+ $(use_with spandsp) \
+ $(use_with ssl gnutls) \
+ $(use_with zlib) \
+ $(usex cpu_flags_x86_sse4_2 --enable-sse4_2 '') \
+ $(usex netlink --with-libnl=3 --without-libnl) \
+ $(usex qt5 --with-qt=5 '') \
+ $(usex qt5 LRELEASE=$(qt5_get_bindir)/lrelease '') \
+ $(usex qt5 MOC=$(qt5_get_bindir)/moc '') \
+ $(usex qt5 RCC=$(qt5_get_bindir)/rcc '') \
+ $(usex qt5 UIC=$(qt5_get_bindir)/uic '') \
+ --disable-warnings-as-errors \
+ --sysconfdir="${EPREFIX}"/etc/wireshark \
+ ${myconf[@]}
+}
+
+src_install() {
+ default
+
+ # FAQ is not required as is installed from help/faq.txt
+ dodoc AUTHORS ChangeLog NEWS README* doc/randpkt.txt doc/README*
+
+ # install headers
+ local wsheader
+ for wsheader in \
+ config.h \
+ epan/*.h \
+ epan/crypt/*.h \
+ epan/dfilter/*.h \
+ epan/dissectors/*.h \
+ epan/ftypes/*.h \
+ epan/wmem/*.h \
+ wiretap/*.h \
+ ws_diag_control.h \
+ ws_symbol_export.h \
+ wsutil/*.h
+ do
+ insinto /usr/include/wireshark/$( dirname ${wsheader} )
+ doins ${wsheader}
+ done
+
+ #with the above this really shouldn't be needed, but things may be looking in wiretap/ instead of wireshark/wiretap/
+ insinto /usr/include/wiretap
+ doins wiretap/wtap.h
+
+ if use gtk || use qt5; then
+ local s
+ for s in 16 32 48 64 128 256 512 1024; do
+ insinto /usr/share/icons/hicolor/${s}x${s}/apps
+ newins image/wsicon${s}.png wireshark.png
+ done
+ for s in 16 24 32 48 64 128 256 ; do
+ insinto /usr/share/icons/hicolor/${s}x${s}/mimetypes
+ newins image/WiresharkDoc-${s}.png application-vnd.tcpdump.pcap.png
+ done
+ fi
+
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+
+ # Add group for users allowed to sniff.
+ enewgroup wireshark
+
+ if use dumpcap && use pcap; then
+ fcaps -o 0 -g wireshark -m 4710 -M 0710 \
+ cap_dac_read_search,cap_net_raw,cap_net_admin \
+ "${EROOT}"/usr/bin/dumpcap
+ fi
+
+ ewarn "NOTE: To capture traffic with wireshark as normal user you have to"
+ ewarn "add yourself to the wireshark group. This security measure ensures"
+ ewarn "that only trusted users are allowed to sniff your traffic."
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}