summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2018-04-14 18:13:32 -0500
committerMatthias Maier <tamiko@gentoo.org>2018-04-14 18:17:14 -0500
commit4139273b773fdc9fc3b75185ee162f1f346c2b95 (patch)
treef42be5254de9ea769f0183484f442467067a2b3b
parentapp-emulation/libvirt: version bump to 4.2.0 (diff)
downloadgentoo-4139273b773fdc9fc3b75185ee162f1f346c2b95.tar.gz
gentoo-4139273b773fdc9fc3b75185ee162f1f346c2b95.tar.bz2
gentoo-4139273b773fdc9fc3b75185ee162f1f346c2b95.zip
dev-python/libvirt-python: version bump to 4.2.0
Package-Manager: Portage-2.3.28, Repoman-2.3.9
-rw-r--r--dev-python/libvirt-python/Manifest1
-rw-r--r--dev-python/libvirt-python/libvirt-python-4.2.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/libvirt-python/Manifest b/dev-python/libvirt-python/Manifest
index 946effe0bf79..c630c2696af5 100644
--- a/dev-python/libvirt-python/Manifest
+++ b/dev-python/libvirt-python/Manifest
@@ -1 +1,2 @@
DIST libvirt-python-4.1.0.tar.gz 186312 BLAKE2B 45ba81eb738e72e2561ab597c5cc395ae2260c7d93575391d2ce14622faf706052ea5d83adf6ca6a52c35cda4a9e80348f163f48ba318f5d0056b26a33961d25 SHA512 533c46c6827b0c3397713b39a7c6486e1bad40571907aa48da7818ad15569d4e01e33ffc787beb9486fc84b361985aa1d30ea474555d55494143f71dfea26947
+DIST libvirt-python-4.2.0.tar.gz 186496 BLAKE2B a4d556a0159c338f2a3a5fc8e6072b084aab427170b66f00dce5b8c4649bfd7d821e02846de906584a454acf2f1db34718a2f48110cf5c8faf6594a72b6e8f2b SHA512 4c06d7de470ff22ee5983598e66d26a3e850998311c8061952f9f6b5be0a7a0f437e2b214d3d66bf465acec9afb925dfb6dd0cd756ed78e818d19e15e7cfdf6a
diff --git a/dev-python/libvirt-python/libvirt-python-4.2.0.ebuild b/dev-python/libvirt-python/libvirt-python-4.2.0.ebuild
new file mode 100644
index 000000000000..172f3dc38862
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-4.2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+MY_P="${P/_rc/-rc}"
+
+inherit distutils-r1
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://libvirt.org/libvirt-python.git"
+ SRC_URI=""
+ KEYWORDS=""
+ RDEPEND="app-emulation/libvirt:=[-python(-)]"
+else
+ SRC_URI="http://libvirt.org/sources/python/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="https://www.libvirt.org"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="examples test"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}