summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2024-04-30 13:53:59 -0400
committerMike Gilbert <floppym@gentoo.org>2024-04-30 13:53:59 -0400
commit419c393e7c673893092cf1784ea456b1227ef5db (patch)
treecf0b053936378cecec67bb3ec4467de0419220df
parentapp-admin/ansible-modules-hashivault: drop 4.6.8, 5.1.0 (diff)
downloadgentoo-419c393e7c673893092cf1784ea456b1227ef5db.tar.gz
gentoo-419c393e7c673893092cf1784ea456b1227ef5db.tar.bz2
gentoo-419c393e7c673893092cf1784ea456b1227ef5db.zip
sys-devel/clang-common: reapply cet config for x86_64 only
This got dropped by accident. Bug: https://bugs.gentoo.org/928460 Fixes: f6674da9ede829fbb18e97530ca10b48d0f37e29 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--sys-devel/clang-common/clang-common-18.1.4-r4.ebuild (renamed from sys-devel/clang-common/clang-common-18.1.4-r3.ebuild)18
1 files changed, 13 insertions, 5 deletions
diff --git a/sys-devel/clang-common/clang-common-18.1.4-r3.ebuild b/sys-devel/clang-common/clang-common-18.1.4-r4.ebuild
index fff63838526d..b7d4720e0e22 100644
--- a/sys-devel/clang-common/clang-common-18.1.4-r3.ebuild
+++ b/sys-devel/clang-common/clang-common-18.1.4-r4.ebuild
@@ -73,6 +73,11 @@ _doclang_cfg() {
@gentoo-common.cfg
@gentoo-common-ld.cfg
EOF
+ if [[ ${triple} == x86_64* ]]; then
+ cat >> "${ED}/etc/clang/${tool}.cfg" <<-EOF || die
+ @gentoo-cet.cfg
+ EOF
+ fi
done
if use kernel_Darwin; then
@@ -85,6 +90,11 @@ _doclang_cfg() {
# This configuration file is used by the ${triple}-clang-cpp driver.
@gentoo-common.cfg
EOF
+ if [[ ${triple} == x86_64* ]]; then
+ cat >> "${ED}/etc/clang/${triple}-clang-cpp.cfg" <<-EOF || die
+ @gentoo-cet.cfg
+ EOF
+ fi
# Install symlinks for triples with other vendor strings since some
# programs insist on mangling the triple.
@@ -175,11 +185,9 @@ src_install() {
-include "${EPREFIX}/usr/include/gentoo/fortify.h"
EOF
- if use amd64; then
- cat >> "${ED}/etc/clang/gentoo-hardened.cfg" <<-EOF || die
- -Xarch_host -fcf-protection=$(usex cet full none)
- EOF
- fi
+ newins - gentoo-cet.cfg <<-EOF
+ -Xarch_host -fcf-protection=$(usex cet full none)
+ EOF
if use kernel_Darwin; then
newins - gentoo-hardened-ld.cfg <<-EOF