summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-25 20:34:36 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-25 20:34:36 +0200
commit42d93e3639b0c71c462e840197eb32e0cd9dad44 (patch)
treeeaacdaf9b3d6d47fdf6b1e2ee60d2c774294a1ec
parentsci-libs/alglib: Set subslot (diff)
downloadgentoo-42d93e3639b0c71c462e840197eb32e0cd9dad44.tar.gz
gentoo-42d93e3639b0c71c462e840197eb32e0cd9dad44.tar.bz2
gentoo-42d93e3639b0c71c462e840197eb32e0cd9dad44.zip
sci-visualization/qtiplot: Use optfeature
Package-Manager: portage-2.2.21 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--sci-visualization/qtiplot/qtiplot-0.9.8.9-r2.ebuild10
-rw-r--r--sci-visualization/qtiplot/qtiplot-0.9.8.9-r3.ebuild10
2 files changed, 6 insertions, 14 deletions
diff --git a/sci-visualization/qtiplot/qtiplot-0.9.8.9-r2.ebuild b/sci-visualization/qtiplot/qtiplot-0.9.8.9-r2.ebuild
index 330c1edf9b1..f93b9455b91 100644
--- a/sci-visualization/qtiplot/qtiplot-0.9.8.9-r2.ebuild
+++ b/sci-visualization/qtiplot/qtiplot-0.9.8.9-r2.ebuild
@@ -44,7 +44,7 @@ CDEPEND="
>=dev-libs/boost-1.35.0:=
dev-libs/quazip
media-libs/libpng:=
- sci-libs/alglib
+ sci-libs/alglib:=
sci-libs/gsl
sci-libs/tamu_anova
latex? ( dev-tex/qtexengine )
@@ -224,12 +224,8 @@ src_install() {
pkg_postinst() {
if use python; then
- elog "You might want to emerge"
- elog "\t dev-python/pygsl"
- elog "\t dev-python/rpy"
- elog "\t sci-libs/scipy and"
- elog "\t dev-python/sympy"
- elog "to gain full python support."
+ optfeature "Enhanced python support" \
+ dev-python/pygsl dev-python/rpy sci-libs/scipy dev-python/sympy
fi
fdo-mime_desktop_database_update
diff --git a/sci-visualization/qtiplot/qtiplot-0.9.8.9-r3.ebuild b/sci-visualization/qtiplot/qtiplot-0.9.8.9-r3.ebuild
index bcce114f3f9..eec88b2a360 100644
--- a/sci-visualization/qtiplot/qtiplot-0.9.8.9-r3.ebuild
+++ b/sci-visualization/qtiplot/qtiplot-0.9.8.9-r3.ebuild
@@ -44,7 +44,7 @@ CDEPEND="
>=dev-libs/boost-1.35.0:=
dev-libs/quazip
media-libs/libpng:=
- sci-libs/alglib
+ sci-libs/alglib:=
sci-libs/gsl
sci-libs/tamu_anova
latex? ( dev-tex/qtexengine )
@@ -226,12 +226,8 @@ src_install() {
pkg_postinst() {
if use python; then
- elog "You might want to emerge"
- elog "\t dev-python/pygsl"
- elog "\t dev-python/rpy"
- elog "\t sci-libs/scipy and"
- elog "\t dev-python/sympy"
- elog "to gain full python support."
+ optfeature "Enhanced python support" \
+ dev-python/pygsl dev-python/rpy sci-libs/scipy dev-python/sympy
fi
fdo-mime_desktop_database_update