summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-07 03:59:12 +0000
committerSam James <sam@gentoo.org>2021-01-07 03:59:12 +0000
commit43018c6c19904d60646d57b435507b9f21d4d82f (patch)
tree70844f6b719e759e82dc056a96ce03fcf4d9884b
parentnet-misc/socat: unify style (diff)
downloadgentoo-43018c6c19904d60646d57b435507b9f21d4d82f.tar.gz
gentoo-43018c6c19904d60646d57b435507b9f21d4d82f.tar.bz2
gentoo-43018c6c19904d60646d57b435507b9f21d4d82f.zip
media-libs/dav1d: bump to 0.8.1
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-libs/dav1d/Manifest1
-rw-r--r--media-libs/dav1d/dav1d-0.8.1.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/media-libs/dav1d/Manifest b/media-libs/dav1d/Manifest
index 1766c18ec5c3..57b4cf3b319e 100644
--- a/media-libs/dav1d/Manifest
+++ b/media-libs/dav1d/Manifest
@@ -1,2 +1,3 @@
DIST dav1d-0.7.1.tar.bz2 644556 BLAKE2B f3539d73b2731be882c71a0e8e90c4382282a650ff9e0aa2bb1142f59a823bbe00011e384c65ae86b8b617054a167b8c90b83d96591ad5c133b7de336c30c753 SHA512 7db0f2eb5f6cbf2809ffb9ebaa18bf1331df00dc6e9d571380b2524143ce3bfdd2e7df1a31e82a52640e7ac81b2712127a395e857d061118845011a1e5fb4751
DIST dav1d-0.8.0.tar.bz2 668627 BLAKE2B 6f45c6b0011acb74bb26fa201e667b16dbf8b691a2bc5d2043517381ca58132fa29ee828841609762737ac8637948b2bd4bac9e2c1d2ca23b1d3ad23f5883875 SHA512 906481ce5b9ce99cef2723c4c2466ba762095b9f88caccd42dcabfd4800964d7cd142736de1bf2ef25b631ee01eb26f7f1ac1754fc161b8fb7192e104df10e28
+DIST dav1d-0.8.1.tar.bz2 674110 BLAKE2B d1dc6137148ee59ccee727127655cc61310d220046f3f3367551153728a4057a92ed2af3298a7b099b4ef345be0f63c2c6d6cf8985fa84a9cb8ee3ee11f2738a SHA512 e882c11c4166a8ada0803a7f1f1de73b6d41fe94ea11300c89121a0551c04b6681e4e6e79d27753a990f7dca1723c35503eb1f02683cd4722db1ae055489e406
diff --git a/media-libs/dav1d/dav1d-0.8.1.ebuild b/media-libs/dav1d/dav1d-0.8.1.ebuild
new file mode 100644
index 000000000000..38fc32f1023f
--- /dev/null
+++ b/media-libs/dav1d/dav1d-0.8.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+SCM=""
+if [[ "${PV}" == "9999" ]]; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://code.videolan.org/videolan/dav1d"
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+ SRC_URI="https://code.videolan.org/videolan/dav1d/-/archive/${PV}/${P}.tar.bz2"
+fi
+
+inherit ${SCM} meson ninja-utils multilib-minimal
+
+DESCRIPTION="dav1d is an AV1 Decoder :)"
+HOMEPAGE="https://code.videolan.org/videolan/dav1d"
+
+LICENSE="BSD-2"
+SLOT="0/5"
+IUSE="+8bit +10bit +asm"
+
+ASM_DEPEND=">=dev-lang/nasm-2.14.02"
+BDEPEND="asm? (
+ abi_x86_32? ( ${ASM_DEPEND} )
+ abi_x86_64? ( ${ASM_DEPEND} )
+ )"
+
+DOCS=( README.md doc/PATENTS THANKS.md )
+
+multilib_src_configure() {
+ local -a bits=()
+ use 8bit && bits+=( 8 )
+ use 10bit && bits+=( 16 )
+
+ local enable_asm
+ if [[ ${MULTILIB_ABI_FLAG} == abi_x86_x32 ]]; then
+ enable_asm=false
+ else
+ enable_asm=$(usex asm true false)
+ fi
+
+ local emesonargs=(
+ -D bitdepths=$(IFS=,; echo "${bits[*]}")
+ -D enable_asm=${enable_asm}
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ eninja
+}
+
+multilib_src_test() {
+ if multilib_is_native_abi ; then
+ meson_src_test
+ fi
+}
+
+multilib_src_install() {
+ DESTDIR="${D}" eninja install
+}