summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-06-19 19:12:05 +0200
committerAaron Bauman <bman@gentoo.org>2018-07-18 18:47:35 -0400
commit431b6daabe4357d67d424fe136b4cd33bc507936 (patch)
treed04bac763d9f8aa3033e69f4f40da756352a9423
parentapp-arch/hardlink: use HTTPs (diff)
downloadgentoo-431b6daabe4357d67d424fe136b4cd33bc507936.tar.gz
gentoo-431b6daabe4357d67d424fe136b4cd33bc507936.tar.bz2
gentoo-431b6daabe4357d67d424fe136b4cd33bc507936.zip
app-arch/hardlink: EAPI7 with minor changes
-rw-r--r--app-arch/hardlink/hardlink-0.3.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-arch/hardlink/hardlink-0.3.0-r1.ebuild b/app-arch/hardlink/hardlink-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..313db6d71904
--- /dev/null
+++ b/app-arch/hardlink/hardlink-0.3.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="A tool which replaces copies of a file with hardlinks"
+HOMEPAGE="https://jak-linux.org/projects/hardlink/"
+SRC_URI="https://jak-linux.org/projects/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-libs/libpcre"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( README ${T}/README.rsync )
+
+src_prepare() {
+ default
+ sed -i -e '/^CF/s:?=:+=:' -e '/^CF/s:-O2 -g::' Makefile || die
+
+ cat <<-EOF > "${T}"/README.rsync
+ https://hardlinkpy.googlecode.com/svn/trunk/hardlink.py has regex '^\..*\.\?{6,6}$'
+ for excluding rsync temporary files by default.
+
+ To accomplish same with this version, you can use following syntax:
+ # hardlink -x '^\..*\.\?{6,6}$'
+
+ This was discussed at https://bugs.gentoo.org/416613
+ EOF
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}