summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-19 17:06:59 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-19 18:29:11 +0200
commit43616e4c646db2f239fb445a479416abdac63719 (patch)
tree73ce9d2396bcd11017d8748f18ea5b5421702182
parentdev-python/pkginfo: Add python3.5 support (diff)
downloadgentoo-43616e4c646db2f239fb445a479416abdac63719.tar.gz
gentoo-43616e4c646db2f239fb445a479416abdac63719.tar.bz2
gentoo-43616e4c646db2f239fb445a479416abdac63719.zip
dev-python/joblib: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/joblib/Manifest1
-rw-r--r--dev-python/joblib/joblib-0.9.2.ebuild47
-rw-r--r--dev-python/joblib/metadata.xml10
3 files changed, 53 insertions, 5 deletions
diff --git a/dev-python/joblib/Manifest b/dev-python/joblib/Manifest
index a713e16ef2e5..fc4332f02f09 100644
--- a/dev-python/joblib/Manifest
+++ b/dev-python/joblib/Manifest
@@ -1 +1,2 @@
DIST joblib-0.8.4.tar.gz 314213 SHA256 f185b87199525e0805281960f9f91c4f2e382e5834f05678cfcfa8ec666a4d2b SHA512 37d9a107c0f8f80c30cbcf7e4520a571eb925efdfb8729ca681fb12b3ec79cfd63c4b53660e560bbb3bc162664f79ab1d9fa7207f3dac00b5d5cddcdc12169c9 WHIRLPOOL f887c0153b4fa691e2289a9d3237a1b9ee51fabd7f6f3a54c7914f4296e23d50010ba822846723566fac5bcfd40c7b23c458121b6eff18d8ce15d6317ae5e638
+DIST joblib-0.9.2.tar.gz 480557 SHA256 aa20324c09428e35a93517156b5355aa69e070661cdcb3c983249c814d5f7b84 SHA512 8fb5362a6816cb9fb04611c7e2b0b9abdcee216932c966f960f490380d00a4931ddb2abbf3b30e73dca75d05056bcb4863ac92fe0d2a3e6d3842d1f116c1a3f9 WHIRLPOOL 0a04c3045979b23ddfd9554d748d42a7cbc7bed1cd02a7e68ceddc26273fe1c4aeb2c1b51597b5a3a4785aa180cabaa4f90ddd23988ef70cc66edcd8105e0120
diff --git a/dev-python/joblib/joblib-0.9.2.ebuild b/dev-python/joblib/joblib-0.9.2.ebuild
new file mode 100644
index 000000000000..991fe2f50cdd
--- /dev/null
+++ b/dev-python/joblib/joblib-0.9.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Tools to provide lightweight pipelining in Python"
+HOMEPAGE="http://pythonhosted.org/joblib/ https://github.com/joblib/joblib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=""
+# Usual; req'd for testsuite
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build -b html -c doc/ doc/ doc/html || die "docs failed installation"
+ fi
+}
+
+python_test() {
+ # https://github.com/joblib/joblib/issues/143
+ if [[ "${EPYTHON}" == pypy ]]; then
+ sed -e 's:test_func_inspect_errors:_&:' -i ${PN}/test/test_func_inspect.py || die
+ sed -e 's:test_parallel_pickling:_&:' -i ${PN}/test/test_parallel.py || die
+ fi
+
+ nosetests -w ${PN}/test || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/joblib/metadata.xml b/dev-python/joblib/metadata.xml
index 6be052e4dbd1..6d21330decdc 100644
--- a/dev-python/joblib/metadata.xml
+++ b/dev-python/joblib/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>python</herd>
-<longdescription>
+ <herd>python</herd>
+ <longdescription>
Joblib is a set of tools to provide lightweight pipelining in
Python. In particular, joblib offers:
* transparent disk-caching of the output values and lazy
@@ -12,7 +12,7 @@
Joblib is optimized to be fast and robust in particular on large,
long-running functions and has specific optimizations for numpy arrays.
</longdescription>
-<upstream>
- <remote-id type="pypi">joblib</remote-id>
-</upstream>
+ <upstream>
+ <remote-id type="pypi">joblib</remote-id>
+ </upstream>
</pkgmetadata>