summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-05-29 07:21:31 +0200
committerHans de Graaff <graaff@gentoo.org>2016-05-29 07:21:31 +0200
commit439f7bfc2fb387dc13c382a7935ce895d705d473 (patch)
treeb1ba8c4ce2e73665f4cbbcc57b03d8aca11296e0
parentdev-util/pkgcheck: version bump and remove old (diff)
downloadgentoo-439f7bfc2fb387dc13c382a7935ce895d705d473.tar.gz
gentoo-439f7bfc2fb387dc13c382a7935ce895d705d473.tar.bz2
gentoo-439f7bfc2fb387dc13c382a7935ce895d705d473.zip
www-servers/thin: add 1.7.0
Package-Manager: portage-2.2.28
-rw-r--r--www-servers/thin/Manifest1
-rw-r--r--www-servers/thin/thin-1.7.0.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/www-servers/thin/Manifest b/www-servers/thin/Manifest
index d13277d1c6e8..3c91b6e030e1 100644
--- a/www-servers/thin/Manifest
+++ b/www-servers/thin/Manifest
@@ -1 +1,2 @@
DIST thin-1.6.4.tar.gz 180419 SHA256 deead8d4d755fd99fa81059bef6b9767e787f027e86d44c903aa3d2a06c082c3 SHA512 f75bbfbc855769564ff6dbbcb93381d9c9387c3ee1211f53df3eb3a050940c2dd8ffba7321d88f685ec114bf78ee437844853810ff728bad6d760d0b82f95671 WHIRLPOOL a755b434c7b038ec6a0ab24c0819a945e015705ec5234199ec82ab81f85002e2d277160069e215fd86195e84258329a8319887690f1c31174a734befa6ca037f
+DIST thin-1.7.0.tar.gz 180791 SHA256 8574ea81e50fc6b46bf48c147cce26eb698f60b554228498daba88f65b043927 SHA512 a41ffb8792f5dbc732696af4914e5121e83f21d18e5aae64676dc5d035f84c0e13d352565c5004ba7ac2e42c701522a6aa6a9250303877c3ac566c30336df2c3 WHIRLPOOL 029fde0ec69b4c1bbd57cd98e483c6fa8ec2ae82e4e80c43b0d328a8c424867737b9d8db7a5f642e70b6946092c26b6594d06d884efd2a5efe98b1f387ff9fec
diff --git a/www-servers/thin/thin-1.7.0.ebuild b/www-servers/thin/thin-1.7.0.ebuild
new file mode 100644
index 000000000000..4cfb76f03a8d
--- /dev/null
+++ b/www-servers/thin/thin-1.7.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST="spec:main spec:group:0 spec:group:1 spec:group:2"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A fast and very simple Ruby web server"
+HOMEPAGE="http://code.macournoyer.com/thin/"
+SRC_URI="https://github.com/macournoyer/thin/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc test"
+
+DEPEND="${DEPEND}
+ dev-util/ragel"
+RDEPEND="${RDEPEND}"
+
+# The runtime dependencies are used at build-time as well since the
+# Rakefile loads thin!
+mydeps=">=dev-ruby/daemons-1.0.9
+ >=dev-ruby/rack-1.0.0:* <dev-ruby/rack-3:*
+ >=dev-ruby/eventmachine-1.0.4:0
+ virtual/ruby-ssl"
+
+ruby_add_rdepend "${mydeps}"
+ruby_add_bdepend "${mydeps}
+ dev-ruby/rake-compiler
+ test? ( dev-ruby/rspec:0 )"
+
+all_ruby_prepare() {
+ # Fix Ragel-based parser generation (uses a *very* old syntax that
+ # is not supported in Gentoo)
+ sed -i -e 's: | rlgen-cd::' Rakefile || die
+
+ # Fix specs' dependencies so that the extension is not rebuilt
+ # when running tests
+ sed -i -e '/:spec =>/s:^:#:' tasks/spec.rake || die
+
+ # Fix rspec version to allow newer 1.x versions
+ sed -i -e '/gem "rspec"/ s/1.2.9/1.0/' tasks/spec.rake spec/spec_helper.rb || die
+
+ # Avoid CLEAN since it may not be available and we don't need it.
+ sed -i -e '/CLEAN/ s:^:#:' tasks/*.rake || die
+
+ # Disable a test that is known for freezing the testsuite,
+ # reported upstream. In thin 1.5.1 this just fails.
+ sed -i \
+ -e '/should force kill process in pid file/,/^ end/ s:^:#:' \
+ spec/daemonizing_spec.rb || die
+
+ # nasty but too complex to fix up for now :(
+ use doc || rm tasks/rdoc.rake
+ use test || rm tasks/spec.rake
+}
+
+each_ruby_compile() {
+ ${RUBY} -S rake compile || die "rake compile failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ keepdir /etc/thin
+ newinitd "${FILESDIR}"/${PN}.initd-r4 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd-2 ${PN}
+
+ einfo
+ elog "Thin is now shipped with init scripts."
+ elog "The default script (/etc/init.d/thin) will start all servers that have"
+ elog "configuration files in /etc/thin/. You can symlink the init script to"
+ elog "files of the format 'thin.SERVER' to be able to start individual servers."
+ elog "See /etc/conf.d/thin for more configuration options."
+ einfo
+}