summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-16 08:48:46 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-16 09:06:29 +0100
commit43a39d7742155386ffc7f16cb87d52b983cdd0b7 (patch)
treef1d90d94df4a9c21ba1c44d4df098c2af73485c7
parentdev-python/boto3: Bump to 1.16.56 (diff)
downloadgentoo-43a39d7742155386ffc7f16cb87d52b983cdd0b7.tar.gz
gentoo-43a39d7742155386ffc7f16cb87d52b983cdd0b7.tar.bz2
gentoo-43a39d7742155386ffc7f16cb87d52b983cdd0b7.zip
net-misc/youtube-dl: Bump to 2021.01.16
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2021.01.16.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index c84d33357a30..21a86de26586 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,2 +1,3 @@
DIST youtube-dl-2021.01.03.tar.gz 3258305 BLAKE2B faebd2ad58b434b6c34d8ede40f5b095acfa123db306881dce4b78f7d144bd76de7d45cc248ad09bcfe86b5930db6a8f69fbdaca5b62b4942ce6c6b004c791f1 SHA512 2698e91bb176e79c3c8d621e835f58523099b7d2b3aea33df01c6f692ce68b02df12884dc276111e53296db2f284f7ac24603302e35f4e10852a1ec9ec9abd18
DIST youtube-dl-2021.01.08.tar.gz 3270591 BLAKE2B 7be0b80a80943360ed0b3385921bc4a42c9d5cbb92d5d11f159c0b374a0c86798b14f635e8d31c16aa690f736a14d6c11369b10e42722fd7b5b7a5fdca182196 SHA512 516c5ac6e0e4513e574771a9d39f643f077e18b408dc7b709b92ca99d2d72f15719b545d5f7598a3a1d5eaeae52efff283c42001ce8c846c019582490be8cac1
+DIST youtube-dl-2021.01.16.tar.gz 3275243 BLAKE2B 970bfff5db0aca7e386027e20f2b4d7e6b7209037820f3e0960f2e19b3b8e0aaf0f62bacb1794a15f359108533cbc396dddea99c84a8c88c13891329d2685326 SHA512 01b73f2e626df69249057ddc205d49dc7d6d16c66f4349fcdde5990615d1d13e0b5db15d65fb35e0c1328f7dc67d1473183228778614ccb7a3c9d27e80a0a38d
diff --git a/net-misc/youtube-dl/youtube-dl-2021.01.16.ebuild b/net-misc/youtube-dl/youtube-dl-2021.01.16.ebuild
new file mode 100644
index 000000000000..9d465c616942
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2021.01.16.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{6..9})
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://youtube-dl.org/ https://github.com/ytdl-org/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+S=${WORKDIR}/${PN}
+
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+SLOT="0"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests nose
+
+src_prepare() {
+ sed -i -e '/flake8/d' Makefile || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ emake offlinetest
+}
+
+python_install_all() {
+ doman youtube-dl.1
+
+ newbashcomp youtube-dl.bash-completion youtube-dl
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "youtube-dl(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/youtube-dl/blob/master/README.md#faq :"
+ elog
+ elog "youtube-dl works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need ffmpeg (media-video/ffmpeg)."
+ elog "On some sites - most notably YouTube - videos can be retrieved in"
+ elog "a higher quality format without sound. youtube-dl will detect whether"
+ elog "ffmpeg is present and automatically pick the best option."
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+ elog
+ elog "If you want youtube-dl to embed thumbnails from the metadata into the"
+ elog "resulting MP4 files, consider installing media-video/atomicparsley"
+}