summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThiago Donato Ferreira <flowlnlnln@gmail.com>2022-05-01 17:39:31 -0300
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-02 11:05:51 +0200
commit44225d2d8ac8d653cf9578627ca27d453f8cade4 (patch)
tree809be253414a35184f86d23dbe70480f9073c31f
parentgames-action/polymc: update live version (diff)
downloadgentoo-44225d2d8ac8d653cf9578627ca27d453f8cade4.tar.gz
gentoo-44225d2d8ac8d653cf9578627ca27d453f8cade4.tar.bz2
gentoo-44225d2d8ac8d653cf9578627ca27d453f8cade4.zip
games-action/polymc: remove 1.1.1
This version seems to have a really weird bug (#839789) that got fixed in newer versions, besides being already pretty old. Thus, users shouldn't use this anymore. Bug: https://bugs.gentoo.org/839789 Signed-off-by: Thiago Donato Ferreira <flowlnlnln@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/25280 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--games-action/polymc/Manifest1
-rw-r--r--games-action/polymc/polymc-1.1.1.ebuild108
2 files changed, 0 insertions, 109 deletions
diff --git a/games-action/polymc/Manifest b/games-action/polymc/Manifest
index 98093b7fbfd2..3ec18031f066 100644
--- a/games-action/polymc/Manifest
+++ b/games-action/polymc/Manifest
@@ -1,2 +1 @@
-DIST polymc-1.1.1.tar.gz 5116164 BLAKE2B ca251cac3c8ea21de8a59297a0e637dac078d751476fec5fe86696df270c63ff079779056f016fa656506ea205bb7ace50ab6e0df190ffca14e43297b92292af SHA512 db32479e9e8a92ec61292c97281673b3084e1085d29b764214834de872d9eddf2ed1d2e383bcd79197e0c9321eec025af652b12c863596ff6abb0f5fba9a7af5
DIST polymc-1.2.1.tar.gz 5157547 BLAKE2B 92a65cd1303b4f2dce299d2a40824de54babd47bd21a894827e7a0e94276551fc747873ba44e63ac13b3ca46649c3d5280ec9eecd92eb63678f8cbc3c27e4f69 SHA512 193415b552dbc3f540f481c22e36c2b9d0604757cb12283ec0fc2979246757937648b76821818f0742b3f5201ed7af8e535dff9ef3d5efcb22f7a1ddf9ee67d2
diff --git a/games-action/polymc/polymc-1.1.1.ebuild b/games-action/polymc/polymc-1.1.1.ebuild
deleted file mode 100644
index d036cb15c635..000000000000
--- a/games-action/polymc/polymc-1.1.1.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake java-pkg-2 optfeature xdg
-
-HOMEPAGE="https://polymc.org/ https://github.com/PolyMC/PolyMC"
-DESCRIPTION="A custom, open source Minecraft launcher"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
-
- EGIT_REPO_URI="
- https://github.com/PolyMC/PolyMC
- https://github.com/MultiMC/libnbtplusplus
- https://github.com/stachenov/quazip
- "
-
- # Include all submodules
- EGIT_SUBMODULES=( '*' )
-else
- MY_PN="PolyMC"
-
- # Let's use the vendored tarball to avoid dealing with the submodules directly
- SRC_URI="
- https://github.com/PolyMC/PolyMC/releases/download/${PV}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz
- "
-
- # The PolyMC's files are unpacked to ${WORKDIR}/PolyMC-${PV}
- S="${WORKDIR}/${MY_PN}-${PV}"
-
- KEYWORDS="~amd64"
-fi
-
-# Apache-2.0 for MultiMC (PolyMC is forked from it)
-# GPL-3 for PolyMC
-# LGPL-3 for libnbtplusplus
-# LGPL-2.1 with linking exception for Quazip
-# See the rest of PolyMC's libraries at https://github.com/PolyMC/PolyMC/tree/develop/libraries
-LICENSE="Apache-2.0 Boost-1.0 BSD BSD-2 GPL-2+ GPL-3 LGPL-3 LGPL-2.1-with-linking-exception OFL-1.1 MIT"
-
-SLOT="0"
-
-IUSE="debug"
-
-MIN_QT="5.6.0"
-
-QT_DEPS="
- >=dev-qt/qtconcurrent-${MIN_QT}:5
- >=dev-qt/qtcore-${MIN_QT}:5
- >=dev-qt/qtgui-${MIN_QT}:5
- >=dev-qt/qtnetwork-${MIN_QT}:5
- >=dev-qt/qttest-${MIN_QT}:5
- >=dev-qt/qtwidgets-${MIN_QT}:5
- >=dev-qt/qtxml-${MIN_QT}:5
-"
-
-DEPEND="
- ${QT_DEPS}
- media-libs/libglvnd
- sys-libs/zlib
- >=virtual/jdk-1.8.0:*
-"
-
-# At run-time we don't depend on JDK, only JRE
-# And we need more than just the GL headers
-RDEPEND="
- ${QT_DEPS}
- sys-libs/zlib
- >=virtual/jre-1.8.0:*
- virtual/opengl
-"
-
-src_prepare() {
- cmake_src_prepare
-}
-
-src_configure(){
- if use debug; then
- CMAKE_BUILD_TYPE=Debug
- else
- # Prepare for LTO in 1.2.0 (?)
- # See https://github.com/PolyMC/PolyMC/pull/333
- CMAKE_BUILD_TYPE=Release
- fi
-
- local mycmakeargs=(
- # Do a system install
- -DLauncher_PORTABLE=0
- -DCMAKE_INSTALL_PREFIX="/usr"
- # Resulting binary is named polymc
- -DLauncher_APP_BINARY_NAME="${PN}"
- )
-
- cmake_src_configure
-}
-
-src_compile(){
- cmake_src_compile
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- # https://github.com/PolyMC/PolyMC/issues/227
- optfeature "old Minecraft (<= 1.12.2) support" x11-libs/libXrandr
-}