summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-06-25 14:38:51 -0700
committerPatrick McLean <chutzpah@gentoo.org>2019-06-25 14:38:51 -0700
commit442a52e2ca7aaa117efc4f95349bc15bd591279f (patch)
treede523b6c3a6f277a80ae334159099e03ca2edd48
parentdev-libs/expat: fix dependencies (diff)
downloadgentoo-442a52e2ca7aaa117efc4f95349bc15bd591279f.tar.gz
gentoo-442a52e2ca7aaa117efc4f95349bc15bd591279f.tar.bz2
gentoo-442a52e2ca7aaa117efc4f95349bc15bd591279f.zip
dev-python/pyfakefs: Version bump to 3.5.8
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/pyfakefs/Manifest1
-rw-r--r--dev-python/pyfakefs/pyfakefs-3.5.8.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pyfakefs/Manifest b/dev-python/pyfakefs/Manifest
index 62329512cd34..dd6959cf260c 100644
--- a/dev-python/pyfakefs/Manifest
+++ b/dev-python/pyfakefs/Manifest
@@ -1,3 +1,4 @@
DIST pyfakefs-3.3.tar.gz 141704 BLAKE2B f805146024d9886ce6cb25b23f6f818bb37cac00a51528375b3da3e728515cb5ffd292352888861ff2b434ff71dd730bfbd84874fee0ae1f4d2cfca974f73771 SHA512 0044643964a4f2329d777476940b38d2d63c6de8f854992b4fba7b7e49f1186e7ce9811f83c9870655cbe33b7dda816c1aa1ce685e800e55c06d175c281748b7
DIST pyfakefs-3.4.1.tar.gz 151662 BLAKE2B cbfdd7ab4c2936d484b5ff1e22852438c5c653e8875b7d363324e0a1aed0bfc5c492c2cd5c64a47052fcb4d043f567819f32067527b870ab42da8cfd92d40be3 SHA512 1be0254455f6046f1d28bf4377d17e0fb943b4b0db09e933c114f587f3d917877b23ee1610cf83a6330b406bb9ae66fe79dea31a6bf75c0b9c2b79a88d07e753
DIST pyfakefs-3.4.3.tar.gz 156896 BLAKE2B 2450cb67dbb25d2029a113dd95c3d51e60ef66c6683a5898ea73800ce1269d628af9f8daa85195d5b473f18b7c3262f2f26fc9c17caf80ce2f5159c247ebea5b SHA512 aafcad5d801f625273239221c56e46229ff8ab622cfb474d92f8555cfff90279ad9a092c20878279454c59033ad23d53cfe877023ac5d20c5a67a610b62ba7f1
+DIST pyfakefs-3.5.8.tar.gz 171519 BLAKE2B 18eb784cf62108c3363b3b5fa137ec4ce830583d263dcecc6f007e6cdeb8a8eefcc4f9eecfba4a9b5b485508749f6dc75a47ff67bc8f5e77f2c0abae2cdd1778 SHA512 e72042dc80545d4a8602bf90bc832298184040389c8fd182df1ef33712061b4937623ca98d70e59b4a388677626f861ff096de939b5caa372849ee10fc3dd8bb
diff --git a/dev-python/pyfakefs/pyfakefs-3.5.8.ebuild b/dev-python/pyfakefs/pyfakefs-3.5.8.ebuild
new file mode 100644
index 000000000000..b96e426c8e2f
--- /dev/null
+++ b/dev-python/pyfakefs/pyfakefs-3.5.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy{,3} )
+DISTUTILS_IN_SOURCE_BUILD=1
+
+inherit distutils-r1
+
+DESCRIPTION="a fake file system that mocks the Python file system modules"
+HOMEPAGE="https://github.com/jmcgeheeiv/pyfakefs/ https://pypi.org/project/pyfakefs/"
+SRC_URI="https://github.com/jmcgeheeiv/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+COMMON_DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${COMMON_DEPEND}"
+DEPEND="${COMMON_DEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/pyfakefs-3.4.3-tests.patch )
+
+python_test() {
+ "${PYTHON}" -m ${PN}.tests.all_tests || die "tests failed under ${EPYTHON}"
+}