summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-06-21 14:43:49 -0400
committerMike Frysinger <vapier@gentoo.org>2016-06-21 14:47:20 -0400
commit449032a9e6f9e3013024e37f9085b17f71353ba1 (patch)
tree8ddc327d63645809f78bd4f0f73eeec17399ff1d
parentx11-libs/intel-gpu-tools: fix building due to missing inttypes.h #582430 (diff)
downloadgentoo-449032a9e6f9e3013024e37f9085b17f71353ba1.tar.gz
gentoo-449032a9e6f9e3013024e37f9085b17f71353ba1.tar.bz2
gentoo-449032a9e6f9e3013024e37f9085b17f71353ba1.zip
x11-libs/intel-gpu-tools: fix building w/newer glibc #581080
-rw-r--r--x11-apps/intel-gpu-tools/files/intel-gpu-tools-1.12-sysmacros.patch35
-rw-r--r--x11-apps/intel-gpu-tools/intel-gpu-tools-1.12.ebuild1
2 files changed, 36 insertions, 0 deletions
diff --git a/x11-apps/intel-gpu-tools/files/intel-gpu-tools-1.12-sysmacros.patch b/x11-apps/intel-gpu-tools/files/intel-gpu-tools-1.12-sysmacros.patch
new file mode 100644
index 000000000000..c805c120f552
--- /dev/null
+++ b/x11-apps/intel-gpu-tools/files/intel-gpu-tools-1.12-sysmacros.patch
@@ -0,0 +1,35 @@
+https://bugs.gentoo.org/581080
+
+From 3e8cc82d371b23303cd4f30e4bcc9c5ecb10ad11 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Tue, 21 Jun 2016 14:24:42 -0400
+Subject: [PATCH] pull in headers for major/minor/makedev funcs
+
+Use the portable autoconf helper to figure out which header to include
+for these funcs. Linux C libs are moving to not implicitly include them
+via sys/types.h anymore, and other OS's have long required you to pull
+in the right header directly.
+
+Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=96618
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ configure.ac | 1 +
+ lib/igt_sysfs.c | 9 +++++++++
+ tools/aubdump.c | 8 +++++++-
+ 3 files changed, 17 insertions(+), 1 deletion(-)
+
+--- a/tools/aubdump.c
++++ b/tools/aubdump.c
+@@ -38,6 +38,9 @@
+ #include <errno.h>
+ #include <sys/mman.h>
+ #include <dlfcn.h>
++#ifdef __linux__
++#include <sys/sysmacros.h>
++#endif
+ #include <i915_drm.h>
+
+ #include "intel_aub.h"
+--
+2.8.2
+
diff --git a/x11-apps/intel-gpu-tools/intel-gpu-tools-1.12.ebuild b/x11-apps/intel-gpu-tools/intel-gpu-tools-1.12.ebuild
index b25044b3a7cc..7bb57f6ffdf7 100644
--- a/x11-apps/intel-gpu-tools/intel-gpu-tools-1.12.ebuild
+++ b/x11-apps/intel-gpu-tools/intel-gpu-tools-1.12.ebuild
@@ -24,6 +24,7 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}"/${PN}-1.12-inttypes.patch #582430
+ "${FILESDIR}"/${PN}-1.12-sysmacros.patch #581080
)
pkg_setup() {