summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEkaterina Vaartis <vaartis@kotobank.ch>2021-05-15 23:06:17 +0300
committerMichał Górny <mgorny@gentoo.org>2021-05-18 13:39:51 +0200
commit44af788a5903baf81206ba2400af538ba4380341 (patch)
tree9b9d9d60065a31835c2026bc6cc962f31df39548
parentdev-python/pycurl: Bump to python 3.10 + disable failing tests (diff)
downloadgentoo-44af788a5903baf81206ba2400af538ba4380341.tar.gz
gentoo-44af788a5903baf81206ba2400af538ba4380341.tar.bz2
gentoo-44af788a5903baf81206ba2400af538ba4380341.zip
dev-python/m2r: Bump to python 3.10
Signed-off-by: Ekaterina Vaartis <vaartis@kotobank.ch> Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/m2r/m2r-0.2.1.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/m2r/m2r-0.2.1.ebuild b/dev-python/m2r/m2r-0.2.1.ebuild
index cc8e39ecf1ce..376b91573204 100644
--- a/dev-python/m2r/m2r-0.2.1.ebuild
+++ b/dev-python/m2r/m2r-0.2.1.ebuild
@@ -2,9 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
DESCRIPTION="Markdown to reStructuredText converter"
@@ -23,7 +22,7 @@ RDEPEND="
BDEPEND="
test? (
dev-python/pygments[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )
+ )
${RDEPEND}
"
@@ -44,6 +43,12 @@ python_prepare_all() {
cp "${FILESDIR}/"test.md tests/ || die
cp "${FILESDIR}/"test.rst tests/ || die
cp "${FILESDIR}/"m2r.1 "${S}" || die
+
+ # in python 3.10, the text changed from "optional arguments" to "options".
+ # the test matches on the concrete string, make it match on the part that is shared
+ # by both versions
+ sed -e 's/optional arguments:/option/' -i tests/test_cli.py || die
+
distutils-r1_python_prepare_all
}