summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-30 13:50:53 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-30 14:03:50 +0200
commit44bcbf61e4b4ff011e839b11a53ce30f8ba9522e (patch)
tree53878f9f8f36b849a3fffb2334a5f96ff055d8e3
parentdev-ros/clear_costmap_recovery: Initial import. Ebuild by me. (diff)
downloadgentoo-44bcbf61.tar.gz
gentoo-44bcbf61.tar.bz2
gentoo-44bcbf61.zip
dev-ros/move_base: Initial import. Ebuild by me.
Package-Manager: portage-2.2.22
-rw-r--r--dev-ros/move_base/Manifest1
-rw-r--r--dev-ros/move_base/metadata.xml5
-rw-r--r--dev-ros/move_base/move_base-1.13.0.ebuild29
-rw-r--r--dev-ros/move_base/move_base-9999.ebuild29
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-ros/move_base/Manifest b/dev-ros/move_base/Manifest
new file mode 100644
index 000000000000..2ab0c74f2366
--- /dev/null
+++ b/dev-ros/move_base/Manifest
@@ -0,0 +1 @@
+DIST navigation-1.13.0.tar.gz 336419 SHA256 5ef288325a0de4accfb4ef0cc37d9e9c4106a05d98b0ae5757f6c4823abada97 SHA512 1b686d4d1e930901dcf899fb73c8609855c3bb6d797322f6f3b9ea7ccb349f98802870b44e0fcbee4e68abebeecbaff57d453dc790fbc908cd23b8afda22e1af WHIRLPOOL 096103d8b774205995a12d294c820187fb89302285b363f6e6b9a4bb1e30a2edf9b33a451effc00b8aeec4d8f40664f61266314d389b9c668c0d7cf2152f70dd
diff --git a/dev-ros/move_base/metadata.xml b/dev-ros/move_base/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/move_base/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/move_base/move_base-1.13.0.ebuild b/dev-ros/move_base/move_base-1.13.0.ebuild
new file mode 100644
index 000000000000..c8fbfbde4434
--- /dev/null
+++ b/dev-ros/move_base/move_base-1.13.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Given a goal in the world, will attempt to reach it with a mobile base"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/pluginlib
+ dev-ros/actionlib
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/nav_core
+ dev-ros/tf
+ dev-ros/move_base_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-cpp/eigen:3
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules"
diff --git a/dev-ros/move_base/move_base-9999.ebuild b/dev-ros/move_base/move_base-9999.ebuild
new file mode 100644
index 000000000000..c8fbfbde4434
--- /dev/null
+++ b/dev-ros/move_base/move_base-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Given a goal in the world, will attempt to reach it with a mobile base"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/pluginlib
+ dev-ros/actionlib
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/nav_core
+ dev-ros/tf
+ dev-ros/move_base_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-cpp/eigen:3
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules"