summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-02 12:44:12 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-02 12:44:12 +0100
commit4504bef108b5b9b664e2fa632d687c49df0268fd (patch)
treef381375fcbf0dfd6810e5b0779b4cf458ddc6f4d
parentdev-python/python-docs: Remove old (diff)
downloadgentoo-4504bef108b5b9b664e2fa632d687c49df0268fd.tar.gz
gentoo-4504bef108b5b9b664e2fa632d687c49df0268fd.tar.bz2
gentoo-4504bef108b5b9b664e2fa632d687c49df0268fd.zip
dev-python/hypothesis: Bump to 6.66.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.66.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 88797fd43007..9a1a034b57e2 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -4,3 +4,4 @@ DIST hypothesis-6.64.0.gh.tar.gz 9345246 BLAKE2B 2ee9a14e84bb72a8248c28096a31b48
DIST hypothesis-6.65.0.gh.tar.gz 9347619 BLAKE2B 5e67e4659d883209aefe3a459620a2d9774122cb15137851f291365846b179130a1209b18aabd4cb120dd5f522e2ac1b3928904e9b25b10109ae779926712220 SHA512 93ecf5bd72e6f8ff69acb8056f2bb26011cbc997c58bbf3055f17c4690d6fe21f22d6e2a86bc3e7172063c85278b7abc42904028ac73174d6f2855ff7175449f
DIST hypothesis-6.65.1.gh.tar.gz 9347804 BLAKE2B 555b8eb742b35cffbc0985394b7b830fbff0c601c031b270ffb50c8e1e8437b99c4f827b92cfc74f5239aac43b34e70520b3674129c70338ad010b289552b14b SHA512 faa1330477a5932b47af5c0b70742a81455aba85f5ba19e355a1678a23e62612a8972e510f3bd0f133491fdd5c2f293a4ea2f75e181dedaa3304d789e3bc90cc
DIST hypothesis-6.65.2.gh.tar.gz 9349189 BLAKE2B 4a36cde376a56c9eee7645c76606777e8c40144f0495a1a6f2d2d840262be26f52e077f932e90790214decfbc3fbb9b3f64add1830e451bb8e56b8c9c5ba5f34 SHA512 0955e95d9d97f44170dfc937c3ea6b43f6c4ac74dbb48e16a4998e735310f72448083382f6628b4bb9620ac0d21d6c749a5464c6a7caee24cdb7af8cd0c01dcb
+DIST hypothesis-6.66.0.gh.tar.gz 9349578 BLAKE2B 3dcdd9bcca00849d68a4bf1368784099bf69e25634b7d1dae13b40be2ac67959151c1b9cdf233349197de1a0f100d57baebbeb9a691ce56ec2d81d21c9f48989 SHA512 a73648ba0b4e3a0621e843ad3ea32f3f692374b82881b096c86a9609f4f7d1a277dd5265a4104863c648c6d5ee4dbccdb1d80ffe62bcc303f837cea26f7d40f2
diff --git a/dev-python/hypothesis/hypothesis-6.66.0.ebuild b/dev-python/hypothesis/hypothesis-6.66.0.ebuild
new file mode 100644
index 000000000000..c793a8a143d2
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.66.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" python3_11 pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+
+ epytest tests/cover tests/pytest tests/quality -n "$(makeopts_jobs)"
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}