summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2022-06-17 22:28:02 +0800
committerYixun Lan <dlan@gentoo.org>2022-06-17 22:30:53 +0800
commit45288132c1881de3d6e4a2b556847b5eb9682019 (patch)
treeba982042c03202f27e10762ce40cbdc3e98fb167
parentdev-python/urllib3: Skip unstable test (diff)
downloadgentoo-45288132c1881de3d6e4a2b556847b5eb9682019.tar.gz
gentoo-45288132c1881de3d6e4a2b556847b5eb9682019.tar.bz2
gentoo-45288132c1881de3d6e4a2b556847b5eb9682019.zip
dev-util/bootconfig: fix QA issue, respect CFLAGS
Closes: https://bugs.gentoo.org/852773 Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--dev-util/bootconfig/bootconfig-5.18.ebuild6
-rw-r--r--dev-util/bootconfig/files/bootconfig-5.18-cflags.patch13
2 files changed, 18 insertions, 1 deletions
diff --git a/dev-util/bootconfig/bootconfig-5.18.ebuild b/dev-util/bootconfig/bootconfig-5.18.ebuild
index 728bae95e34c..3db6300cf029 100644
--- a/dev-util/bootconfig/bootconfig-5.18.ebuild
+++ b/dev-util/bootconfig/bootconfig-5.18.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit estack
+inherit estack linux-info
DESCRIPTION="Bootconfig tools for kernel command line to support key-value"
HOMEPAGE="https://kernel.org/"
@@ -46,6 +46,10 @@ DEPEND="${RDEPEND}
S_K="${WORKDIR}/linux-${LINUX_VER}"
S="${S_K}/tools/bootconfig"
+CONFIG_CHECK="~BOOT_CONFIG"
+
+PATCHES=( "${FILESDIR}"/${P}-cflags.patch )
+
src_unpack() {
local paths=(
tools/arch tools/build tools/include tools/lib tools/bootconfig tools/scripts
diff --git a/dev-util/bootconfig/files/bootconfig-5.18-cflags.patch b/dev-util/bootconfig/files/bootconfig-5.18-cflags.patch
new file mode 100644
index 000000000000..7d6b23338935
--- /dev/null
+++ b/dev-util/bootconfig/files/bootconfig-5.18-cflags.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 566c3e0..21818c7 100644
+--- a/Makefile
++++ b/Makefile
+@@ -10,7 +10,7 @@ srctree := $(patsubst %/,%,$(dir $(srctree)))
+ endif
+
+ LIBSRC = $(srctree)/lib/bootconfig.c $(srctree)/include/linux/bootconfig.h
+-CFLAGS = -Wall -g -I$(CURDIR)/include
++CFLAGS += -Wall -I$(CURDIR)/include
+
+ ALL_TARGETS := bootconfig
+ ALL_PROGRAMS := $(patsubst %,$(OUTPUT)%,$(ALL_TARGETS))