summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-15 22:38:33 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-15 23:17:30 +0100
commit462c2331a755846c43f6565916e8d29a59440cec (patch)
tree3931716fa6f56239c4815623beaa9294c6ebdfda
parentdev-python/jupyter_console: Bump to 6.4.3 (diff)
downloadgentoo-462c2331a755846c43f6565916e8d29a59440cec.tar.gz
gentoo-462c2331a755846c43f6565916e8d29a59440cec.tar.bz2
gentoo-462c2331a755846c43f6565916e8d29a59440cec.zip
dev-python/xmlschema: Bump to 1.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/xmlschema/Manifest1
-rw-r--r--dev-python/xmlschema/xmlschema-1.10.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/xmlschema/Manifest b/dev-python/xmlschema/Manifest
index 17b3d5d0fd0e..04b583e3741d 100644
--- a/dev-python/xmlschema/Manifest
+++ b/dev-python/xmlschema/Manifest
@@ -1 +1,2 @@
+DIST xmlschema-1.10.0.tar.gz 396057 BLAKE2B 44facdb16e79ddf16ca798b937c4cf35444f9d31278c26121f179e5055134b82d425cc5b69a8a2e4fdd44388cbd3e96534b55794a267a3b4c0b606752ede533e SHA512 c4358b210cc96e46617cc11b1b7e2a4d69c1bd6489cc73602552b184f209eb90b13eff353741aa7b1dbc3ff8514f90b7bb331ac18ffc466b3ce36f42f7497899
DIST xmlschema-1.9.2.tar.gz 394954 BLAKE2B c8d932827f03962fcd6b1408d25cb4079b84d44984227c53922587d9c61dcf16e2b46c7df16a2795623017c1b844f3fca497e5856b6d6b2a475eabf1c49cc4cc SHA512 99abc53da52ba8f7f0f269c791b227d2b5c81d7ede847ccd98e18c5817ddd988ba26b88ad5afe0a0933e0c5af5425c0efdd4a1beb218d009e476de5b2931a0fb
diff --git a/dev-python/xmlschema/xmlschema-1.10.0.ebuild b/dev-python/xmlschema/xmlschema-1.10.0.ebuild
new file mode 100644
index 000000000000..d651b6ba0d71
--- /dev/null
+++ b/dev-python/xmlschema/xmlschema-1.10.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="An XML Schema validator and decoder"
+HOMEPAGE="https://github.com/sissaschool/xmlschema https://pypi.org/project/xmlschema/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/elementpath-2.5.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${EPYTHON}" tests/test_all.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}