summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-02-13 22:25:32 -0800
committerMatt Turner <mattst88@gentoo.org>2022-02-13 22:27:35 -0800
commit46e3094fa778bb4beb47bd82d7bfb283f8249966 (patch)
tree55efb6597f302a5785b5de0325faa6a689b2cc40
parentgnome-extra/gnome-user-docs: Version bump to 41.2 (diff)
downloadgentoo-46e3094fa778bb4beb47bd82d7bfb283f8249966.tar.gz
gentoo-46e3094fa778bb4beb47bd82d7bfb283f8249966.tar.bz2
gentoo-46e3094fa778bb4beb47bd82d7bfb283f8249966.zip
gnome-extra/gucharmap: Version bump to 14.0.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--gnome-extra/gucharmap/Manifest1
-rw-r--r--gnome-extra/gucharmap/gucharmap-14.0.2.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/gnome-extra/gucharmap/Manifest b/gnome-extra/gucharmap/Manifest
index 116f8b6b91c6..d4be1b58e5d6 100644
--- a/gnome-extra/gucharmap/Manifest
+++ b/gnome-extra/gucharmap/Manifest
@@ -1,3 +1,4 @@
DIST gucharmap-13.0.8.tar.gz 1920107 BLAKE2B 247b6683358e1fcbba02cad8146b8b1e7a4ccd5e56d3f9c6e597b47bcd38d11759a02e60d5635c3f2e26defe166b6e4ded696b5d1f6e1be6564d6139e3ed1ab8 SHA512 15eacbf351c8b2357e59913e5b4cccd279aed7a492351c42101dd26020658f2f4d7aaff2a3b95ca340a73606592f47edf9645c93234afb1a086362ef32904bcf
DIST gucharmap-14.0.1.tar.gz 1925102 BLAKE2B 134d48703efb27d5eb3a19e8d90031d6feb8f0fa7321596efc1209377653590fe5f4191af739f012c1dee15df75e2d70ca2ed8850d30b57cc87b97343716de85 SHA512 5a79afe1a7e9f2a54f7499a578a34db690853f096a9374b335786abd3439812f511222792447f6cc603c2611490d3514d6a179844dd03fbf7f289133e29cf015
+DIST gucharmap-14.0.2.tar.gz 1925142 BLAKE2B 3936c187ecdc104534b80830f9089417e8c2166a8e8dbfc848788a58acd9d65889f1242ecd3a2d9a5f2e657dcc052dee22b3ed543d2113509905a472192b19eb SHA512 4cfcebca0cac5cef8e6601c077a49e12aa56e76fec131ccf5ca1fb11bf40e5df8b6ae5ec83c2b64764c9d223d52824d4007c114ee7d85b4246855b8fc15c6c2d
DIST gucharmap-3.0.1.tar.bz2 3275481 BLAKE2B 80dde7791abdc72677add9c65c59f810e6c6952116b92db34059c4c40d2657246b17844c105e68f32c86294e9b4e71e9d48e6f0522855465734d7c24e8d17608 SHA512 4d8a2276b5cb1a0b0fadca2a8522755c5884985a12d5b19341b9cefcd7f749ec1286c0271419e38ec84be7edcfa1293e7f0263eb682c75387d692792de3e1fb1
diff --git a/gnome-extra/gucharmap/gucharmap-14.0.2.ebuild b/gnome-extra/gucharmap/gucharmap-14.0.2.ebuild
new file mode 100644
index 000000000000..4f0a1c3992f6
--- /dev/null
+++ b/gnome-extra/gucharmap/gucharmap-14.0.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+VALA_MIN_API_VERSION="0.26"
+
+inherit gnome2-utils meson python-any-r1 vala xdg
+
+DESCRIPTION="Unicode character map viewer and library"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gucharmap"
+SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="2.90"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+UNICODE_VERSION="14.0"
+
+IUSE="+introspection gtk-doc vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="media-libs/freetype:2
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=dev-libs/libpcre2-10.21:=
+ =app-i18n/unicode-data-${UNICODE_VERSION}*
+ >=x11-libs/pango-1.42.4-r2[introspection?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? ( >=dev-util/gtk-doc-1 )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ vala? ( $(vala_depend) )
+"
+
+PATCHES=(
+ "${FILESDIR}"/14.0.1-install-user-help.patch
+ "${FILESDIR}"/14.0.1-fix-file-conflicts.patch
+)
+
+src_prepare() {
+ use vala && vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dcharmap=true
+ -Ddbg=false # in 14.0.1 all this does is pass -ggdb3
+ $(meson_use gtk-doc docs)
+ $(meson_use introspection gir)
+ -Dgtk3=true
+ -Ducd_path="${EPREFIX}/usr/share/unicode-data"
+ $(meson_use vala vapi)
+ )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}