summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2023-04-25 17:02:14 +0700
committerAndrey Grozin <grozin@gentoo.org>2023-04-25 17:02:14 +0700
commit46f53ab4ba0d24e6b299f9e4577d567e8135ee96 (patch)
treedee95590f660a8190bb55fc603a277bd0df6eb48
parentsci-chemistry/gromacs: Fix build with cuda-12 (diff)
downloadgentoo-46f53ab4ba0d24e6b299f9e4577d567e8135ee96.tar.gz
gentoo-46f53ab4ba0d24e6b299f9e4577d567e8135ee96.tar.bz2
gentoo-46f53ab4ba0d24e6b299f9e4577d567e8135ee96.zip
sci-mathematics/wxmaxima: bump to 23.04.1
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
-rw-r--r--sci-mathematics/wxmaxima/Manifest1
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-23.04.1.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/sci-mathematics/wxmaxima/Manifest b/sci-mathematics/wxmaxima/Manifest
index 8ee8d1d8c5d7..039e93cbb7cc 100644
--- a/sci-mathematics/wxmaxima/Manifest
+++ b/sci-mathematics/wxmaxima/Manifest
@@ -1,3 +1,4 @@
DIST wxmaxima-20.12.2.tar.gz 16262617 BLAKE2B 2f9f910f565158b2011f014d96747498c6286a95bdb69f9b6b2f82a37a569e8a02abbae5cbb9ae2ac1e78d0b976487666794b267c1c40c1245df08c752486403 SHA512 1c3e3f68a2fa2cd798dfb05c52e7ddf3193a15cb45282553c280914bd524d463ad27acc89898cb4a292ff236699d1ec2abb70d83fa52cb126123ab8e2fcd5ceb
DIST wxmaxima-22.12.0.tar.gz 23673254 BLAKE2B b00536c6b6243555f4c00016202d68f9764a2e1ec4c910ee52d7e0b498a5695c3f4746809e594179cda75ec40caeca1a01e21a11c211c329ec2685a8e6217e4e SHA512 842a4c891d757d17307a9bed17f5ffffde9f55e72b749e2356817a1598760b6a16fb9ce8e21f4706530bbe2360400de01b9269872d895944924d8e3eebfc31dc
DIST wxmaxima-23.02.0.tar.gz 23662128 BLAKE2B 10f8a155db9bc3889b9f79892d583e666c6ff250e669883e3fa8f65a91928a38b69df059a9358ca3a1f87a9d915fbb8d8ddeec5bfac21ee8ab3b59869d0cb3cf SHA512 7f30ea7be25269d670b14189b84777e12157209ab20d6f77fa9428743c002b235a09bc732bf253a0c1a0d4618986051bab68f2ec9d360b229bb7fbd6604af9df
+DIST wxmaxima-23.04.1.tar.gz 22060726 BLAKE2B 77583c2461f7c32ac53ad2890d1e7d07a9fc2dd0caa07a1fcdd7c62d39ec63c50173542c74ce2d21093ce724d1777b76e7789f8a5363ff20406d52177c86a016 SHA512 9846c11cbeec8411170e0d55916187cc77274e2758726784bcb5540d55f712b5a557562de0c37dac0c7ef119d43570bd33efc33252fc5359627e527d668580a4
diff --git a/sci-mathematics/wxmaxima/wxmaxima-23.04.1.ebuild b/sci-mathematics/wxmaxima/wxmaxima-23.04.1.ebuild
new file mode 100644
index 000000000000..552ce4da0c45
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-23.04.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.0-gtk3"
+PLOCALES="ca cs da de el en es fi fr gl hu it ja kab nb pl pt_BR ru tr uk zh_CN zh_TW"
+inherit cmake plocale wxwidgets xdg
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="https://wxmaxima-developers.github.io/wxmaxima/"
+SRC_URI="https://github.com/wxMaxima-developers/wxmaxima/archive/Version-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-Version-${PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/libxml2:2
+ x11-libs/wxGTK:${WX_GTK_VER}[webkit]"
+RDEPEND="${DEPEND}
+ media-fonts/jsmath
+ sci-visualization/gnuplot[wxwidgets]
+ sci-mathematics/maxima"
+
+src_prepare() {
+ setup-wxwidgets
+ cmake_src_prepare
+
+ sed -e "s|GPL.txt ||g" -e "s|share/doc/${PN}|share/doc/${PF}|g" -i CMakeLists.txt \
+ || die "sed CMakeLists.txt failed"
+ sed -e "s|share/doc/${PN}|share/doc/${PF}|g" -i info/CMakeLists.txt \
+ || die "sed info/CMakeLists.txt failed"
+
+ # locales
+ rm_po() {
+ rm locales/wxMaxima/${1}.po || die "rm ${1}.po failed"
+ rm -f locales/manual/${1}.po
+ rm -f info/${PN}.${1}.md
+ rm -f info/${PN}.${1}.html
+ sed -e "\\|/${1}/wxmaxima.1|d" -i data/CMakeLists.txt
+ }
+ plocale_find_changes locales/wxMaxima '' '.po'
+ plocale_for_each_disabled_locale rm_po
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWXM_UNIT_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ # Just run the unit tests manually for now as tests fail in a non-descriptive
+ # way even with virtualx
+ # bug #736695
+ cd "${BUILD_DIR}/test/unit_tests" || die
+
+ local tests=(
+ AFontSize
+ CellPtr
+ ImgCell
+ )
+
+ local test
+ for test in "${tests[@]}" ; do
+ ./test_${test} || die "Unit test ${test} failed!"
+ done
+}
+
+src_install() {
+ docompress -x /usr/share/doc/${PF}
+ cmake_src_install
+}