summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-06-19 11:50:59 +1200
committerKent Fredric <kentnl@gentoo.org>2020-06-19 11:53:45 +1200
commit47140a20c3ea4c7fd1d85fbad1474b1a3212eddf (patch)
treef9a2f636e2e0f0c5dd225eeed8da1135dfc29b44
parentdev-lang/rust: un-hardcode wasm linker if system-llvm is used (diff)
downloadgentoo-47140a20c3ea4c7fd1d85fbad1474b1a3212eddf.tar.gz
gentoo-47140a20c3ea4c7fd1d85fbad1474b1a3212eddf.tar.bz2
gentoo-47140a20c3ea4c7fd1d85fbad1474b1a3212eddf.zip
dev-perl/Class-Mix: -r bump for EAPI7
- EAPI7 - Correct LICENSE ( perl-module.eclass does a better default for perl5, as perl5 means Artistic || GPL-1+ - Unconditionally patch bad tests out Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
-rw-r--r--dev-perl/Class-Mix/Class-Mix-0.6.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Class-Mix/Class-Mix-0.6.0-r1.ebuild b/dev-perl/Class-Mix/Class-Mix-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..b8e2063c0d63
--- /dev/null
+++ b/dev-perl/Class-Mix/Class-Mix-0.6.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DIST_AUTHOR=ZEFRAM
+DIST_VERSION=0.006
+inherit perl-module
+
+DESCRIPTION="dynamic class mixing"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Params-Classify
+ virtual/perl-Exporter
+ virtual/perl-if
+ virtual/perl-parent
+"
+DEPEND="
+ dev-perl/Module-Build
+"
+BDEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+PERL_RM_FILES=(
+ t/pod_cvg.t
+ t/pod_syn.t
+)