summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-11-01 17:14:13 +1300
committerKent Fredric <kentnl@gentoo.org>2017-11-01 17:14:13 +1300
commit4724ed6f06cce1f0b33d7dfe2d1b139f7dcbfa96 (patch)
tree28e26af09cdd5ca214c7ca343638c3cf1ebfdb21
parentdev-perl/Net-DNS-Resolver-Mock: Added w/ version 1.201.710.310 (diff)
downloadgentoo-4724ed6f06cce1f0b33d7dfe2d1b139f7dcbfa96.tar.gz
gentoo-4724ed6f06cce1f0b33d7dfe2d1b139f7dcbfa96.tar.bz2
gentoo-4724ed6f06cce1f0b33d7dfe2d1b139f7dcbfa96.zip
dev-perl/Mail-DKIM: Bump to version 0.440.0
Upstream: - Fix tests - Add experimental ARC support Keywords: - New dep, dropped: alpha arm hppa ia64 ppc ppc64 Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--dev-perl/Mail-DKIM/Mail-DKIM-0.440.0.ebuild40
-rw-r--r--dev-perl/Mail-DKIM/Manifest1
-rw-r--r--dev-perl/Mail-DKIM/metadata.xml5
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-perl/Mail-DKIM/Mail-DKIM-0.440.0.ebuild b/dev-perl/Mail-DKIM/Mail-DKIM-0.440.0.ebuild
new file mode 100644
index 000000000000..dc8d71e5af77
--- /dev/null
+++ b/dev-perl/Mail-DKIM/Mail-DKIM-0.440.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MBRADSHAW
+DIST_VERSION=0.44
+DIST_EXAMPLES=("examples/*" "scripts/*")
+inherit perl-module
+
+DESCRIPTION="Signs/verifies Internet mail using DKIM message signatures"
+
+SLOT="0"
+KEYWORDS="~amd64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND=">=dev-perl/Crypt-OpenSSL-RSA-0.24
+ virtual/perl-Digest-SHA
+ virtual/perl-MIME-Base64
+ dev-perl/Net-DNS
+ dev-perl/MailTools
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Net-DNS-Resolver-Mock
+ virtual/perl-Test-Simple
+ dev-perl/YAML-LibYAML
+ )
+"
+mydoc=("doc/*.txt" "HACKING.DKIM")
+
+src_test(){
+ # disable online tests
+ if ! has network ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
+ einfo "Removing network tests w/o DIST_TEST_OVERRIDE=~network"
+ perl_rm_files t/{policy,public_key,verifier,dev-manifest}.t
+ fi
+ perl-module_src_test
+}
diff --git a/dev-perl/Mail-DKIM/Manifest b/dev-perl/Mail-DKIM/Manifest
index ad82d6ce86eb..d5b0549a5b87 100644
--- a/dev-perl/Mail-DKIM/Manifest
+++ b/dev-perl/Mail-DKIM/Manifest
@@ -1,2 +1,3 @@
DIST Mail-DKIM-0.40.tar.gz 95186 SHA256 3c5ea0c3a2028a5a2c3b64bbcd6bd9de6a5fa5ee4e16046dd8875c4796aaa6f1 SHA512 27f10a96f70e56e69f55e5077fb93f29f66d8e7a21846c8fb518403af915f85ac06f0968e6002fa2dc7090746e14a5a7bd973e46bb1d52e4200c3c120cd2e924 WHIRLPOOL 81b33d77b81d76a38e19fef5f2c9e17518eff42ebee736fef0496fd646242f06ae2f9f273ea803337e243d3c2d258e660b70a8383df7fafe228215e38ab7c780
DIST Mail-DKIM-0.41.tar.gz 100564 SHA256 67b07a4dcc70cf1e6af0348a64cd2655e231c806507a765b169e9f0b94b5b74a SHA512 f16a818b058b405ee3ffc0962091e7d47268321b35dcd6ca42e1e37ed1ad5b1b3c1e32655f6f0643e046c53f1247a4b9bb9c0202eca7adce4f14d9b38b414f2e WHIRLPOOL cf899982e27fcfdf27a4aa9ce182f0a8242e26f57f0085b26fe51570cc1660bdbcc239c2bf1e24f206b8dbe0e35060be3f0f7f3c9b1e33d76eade31b0a89101f
+DIST Mail-DKIM-0.44.tar.gz 155301 SHA256 acda95af369b15dd67f2cf9b467493231d60aeb97cd5967353450b8490026bbf SHA512 08501de43ce775454e90b18e95a5320fc590c82a14e8828f53510163bc73d7e82aaad35e6d79b7fd888b45aacc56bd422151c3c2b6e1e6db80a7ca62b2a469c3 WHIRLPOOL 6b80e9665833bcca7d81264ce6e3a383099cea50ffa99509c86ce1666f730b87fe4766de1edd27cb8f116611e9de72821cd368e58397accaa481f7a705037cab
diff --git a/dev-perl/Mail-DKIM/metadata.xml b/dev-perl/Mail-DKIM/metadata.xml
index 79f48791b8de..9aee5efc890b 100644
--- a/dev-perl/Mail-DKIM/metadata.xml
+++ b/dev-perl/Mail-DKIM/metadata.xml
@@ -8,6 +8,10 @@
<upstream>
<remote-id type="cpan">Mail-DKIM</remote-id>
<remote-id type="cpan-module">Mail::DKIM</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::ARC::MessageSignature</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::ARC::Seal</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::ARC::Signer</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::ARC::Verifier</remote-id>
<remote-id type="cpan-module">Mail::DKIM::Algorithm::Base</remote-id>
<remote-id type="cpan-module">Mail::DKIM::Algorithm::dk_rsa_sha1</remote-id>
<remote-id type="cpan-module">Mail::DKIM::Algorithm::rsa_sha1</remote-id>
@@ -20,6 +24,7 @@
<remote-id type="cpan-module">Mail::DKIM::Canonicalization::dk_simple</remote-id>
<remote-id type="cpan-module">Mail::DKIM::Canonicalization::nowsp</remote-id>
<remote-id type="cpan-module">Mail::DKIM::Canonicalization::relaxed</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::Canonicalization::seal</remote-id>
<remote-id type="cpan-module">Mail::DKIM::Canonicalization::simple</remote-id>
<remote-id type="cpan-module">Mail::DKIM::Common</remote-id>
<remote-id type="cpan-module">Mail::DKIM::DNS</remote-id>