summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-02 22:10:51 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-02 22:15:37 +0300
commit474e86b4555b584691bb487562466d31cba6efce (patch)
treec4a57665cac891c5bb7fefcd385abbba4c9f9a8e
parentdev-python/Faker: drop 13.3.3, 13.3.5, 13.4.0 (diff)
downloadgentoo-474e86b4555b584691bb487562466d31cba6efce.tar.gz
gentoo-474e86b4555b584691bb487562466d31cba6efce.tar.bz2
gentoo-474e86b4555b584691bb487562466d31cba6efce.zip
dev-python/cfn-lint: add 0.59.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.59.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 33077eec9fe8..dda121f4c921 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1 +1,2 @@
DIST cfn-lint-0.59.0.tar.gz 9004743 BLAKE2B e778c1081e45dacc813f8a4ae7726eb929fabcdbfaafcbbc5f0d925cfe32773851366c9488363728ae42349cbe899a6cacd114940ee8d76dc284b30ea87fe19a SHA512 e8e9d0fb1f366c49f8a008000a808ec4b6c4299ff3c9650229619d8e48f1812709ecd54274163d8bd389c6823f20accd7d31f6147bec926ec233ede3ee51ee10
+DIST cfn-lint-0.59.1.tar.gz 9065067 BLAKE2B 63fc591f7ed60eed2ef7fa1e9ea212e3e8569cfd20dec8bb8505dbfb8e96ee8f8ab6136d88de58b2db8823675946dc99b38adeb3b5c784d165083e1353100b00 SHA512 a08b4bf4dc8e7ab41bb72eb9309ca4f03eed3b6f5c31b3876dc9d08610312377a7c229de883c287e7e5ed6597f8eada79a111882785888e43b0ff20160e39fe0
diff --git a/dev-python/cfn-lint/cfn-lint-0.59.1.ebuild b/dev-python/cfn-lint/cfn-lint-0.59.1.ebuild
new file mode 100644
index 000000000000..f3316978d184
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.59.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="https://pypi.org/project/cfn-lint/ https://github.com/aws-cloudformation/cfn-lint/"
+SRC_URI="
+ https://github.com/aws-cloudformation/cfn-lint/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.45.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_2
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}