summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-09-18 22:41:44 -0700
committerMatt Turner <mattst88@gentoo.org>2018-09-18 22:51:33 -0700
commit47648102ce6530a8edfc2b9762bf3956256a7052 (patch)
treed34819190f73c0d2701ea278646a19be2151de4d
parentsys-fs/archivemount: remove old (diff)
downloadgentoo-47648102ce6530a8edfc2b9762bf3956256a7052.tar.gz
gentoo-47648102ce6530a8edfc2b9762bf3956256a7052.tar.bz2
gentoo-47648102ce6530a8edfc2b9762bf3956256a7052.zip
www-plugins/browserpass: Version bump to 2.0.22
Also install for Chrome as well, per bug 656962. Closes: https://bugs.gentoo.org/656962
-rw-r--r--www-plugins/browserpass/Manifest1
-rw-r--r--www-plugins/browserpass/browserpass-2.0.22.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/www-plugins/browserpass/Manifest b/www-plugins/browserpass/Manifest
index ddb9a53f2888..8264f541cb7d 100644
--- a/www-plugins/browserpass/Manifest
+++ b/www-plugins/browserpass/Manifest
@@ -1,2 +1,3 @@
DIST browserpass-2.0.11.tar.gz 176787 BLAKE2B 271c3cf340ecc78c3358f21bc0e6bbcaf857b4ca39c7b0dcf58b1fcef62ea5df4f48adb4ac0bf7c884853f359fdb9ca00300e2f99efa48a1fdc0ba99ce7bd172 SHA512 baa362b63c1743273f56cb7576f96c29ca365fb217d3016824cdb1ce215e36b7f98fc7c3340a5a34853bde7c25283c84ceda570d149a8119bc54be2f0194034b
DIST browserpass-2.0.13.tar.gz 180424 BLAKE2B e2a1796edf3b037553cb9bd33f072cd25953d8262fa584c371c3df638c77fc352953c698963325a5cee9b29c81cc010ded72bb31abac9460603796f4a95267ed SHA512 8d28144aef061770f11d7ba288dfa82f8873a263b8ccff235e26e83c55700e5ed0210dec2c2fb45751f3ad15d1894503407ec901d272783b98c466d74d9156f0
+DIST browserpass-2.0.22.tar.gz 49730 BLAKE2B a37d55a7b2a162a54931a3dde53b16e6c4d067f92dad129e92664dac726c3171938d5da94fe45c64227f4e4a860a12d0cdbb1aa147942f0199c2f4b9bed5fd7a SHA512 f3c19df72afd1387d7142b5e818dfe95a730c906277be0f16522986f387f659eb4a9decaf54eef5b6649ddc618d93b055c99b594fc4b949ce09a38cf2e6d9525
diff --git a/www-plugins/browserpass/browserpass-2.0.22.ebuild b/www-plugins/browserpass/browserpass-2.0.22.ebuild
new file mode 100644
index 000000000000..7107e7c52538
--- /dev/null
+++ b/www-plugins/browserpass/browserpass-2.0.22.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN=github.com/dannyvankooten/browserpass
+
+if [[ ${PV} == 9999 ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="WebExtension host binary for pass, a UNIX password manager"
+HOMEPAGE="https://github.com/dannyvankooten/browserpass"
+LICENSE="MIT"
+SLOT="0"
+RDEPEND="app-crypt/gnupg"
+DEPEND="${RDEPEND}
+ dev-go/fuzzy:=
+ dev-go/twofactor:=
+ dev-go/zglob:="
+
+DOCS=( CONTRIBUTING.md README.md )
+
+src_compile() {
+ EGO_PN="${EGO_PN}/cmd/browserpass" golang-build_src_compile
+
+ pushd "src/${EGO_PN}" >/dev/null || die
+ sed -e 's|%%replace%%|'${EPREFIX}'/usr/libexec/browserpass|' \
+ -i firefox/host.json chrome/host.json || die
+ popd >/dev/null || die
+}
+
+src_install() {
+ exeinto /usr/libexec
+ doexe browserpass
+
+ pushd "src/${EGO_PN}" >/dev/null || die
+ insinto /usr/$(get_libdir)/mozilla/native-messaging-hosts
+ newins firefox/host.json com.dannyvankooten.browserpass.json
+
+ insinto /etc/chromium/native-messaging-hosts
+ newins chrome/host.json com.dannyvankooten.browserpass.json
+
+ insinto /etc/opt/chrome/native-messaging-hosts
+ newins chrome/host.json com.dannyvankooten.browserpass.json
+
+ einstalldocs
+ popd >/dev/null || die
+}