summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2019-11-20 18:23:56 +0000
committerIan Whyman <thev00d00@gentoo.org>2019-11-20 18:24:16 +0000
commit478aa705b11104a1a067877e02d959ad109a7b25 (patch)
tree39e9fa5d1e13da48fe98158b542762f614abaeaa
parentnet-misc/knemo: Drop last-rited package (diff)
downloadgentoo-478aa705b11104a1a067877e02d959ad109a7b25.tar.gz
gentoo-478aa705b11104a1a067877e02d959ad109a7b25.tar.bz2
gentoo-478aa705b11104a1a067877e02d959ad109a7b25.zip
media-video/handbrake: Dont search for python
The ebuild would prefer calling python3 even if the eclass had chosen a 2.7 version, upsetting python_wrapper_setup Closes: https://bugs.gentoo.org/700706 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Ian Whyman <thev00d00@gentoo.org>
-rw-r--r--media-video/handbrake/files/handbrake-1.3.0-dont-search-for-python.patch27
-rw-r--r--media-video/handbrake/handbrake-1.3.0-r2.ebuild (renamed from media-video/handbrake/handbrake-1.3.0-r1.ebuild)7
2 files changed, 30 insertions, 4 deletions
diff --git a/media-video/handbrake/files/handbrake-1.3.0-dont-search-for-python.patch b/media-video/handbrake/files/handbrake-1.3.0-dont-search-for-python.patch
new file mode 100644
index 000000000000..551a64ee3817
--- /dev/null
+++ b/media-video/handbrake/files/handbrake-1.3.0-dont-search-for-python.patch
@@ -0,0 +1,27 @@
+diff --git a/configure b/configure
+index 5c870e1d7..2f5834083 100755
+--- a/configure
++++ b/configure
+@@ -14,20 +14,8 @@ inpath()
+ }
+
+ if ( inpath bash ); then
+- pp=""
+- for p in python3 python3.8 python3.7 python3.6 python3.5 python3.4 python3.3 python3.2 python3.1 python2 python2.7 python
+- do
+- if ( inpath $p ); then
+- pp="$p"
+- break
+- fi
+- done
+- if [ pp != "" ]; then
+- exec $pp `dirname $0`/make/configure.py "$@"
+- exit 0
+- else
+- echo "ERROR: no suitable version of python found."
+- fi
++ exec python `dirname $0`/make/configure.py "$@"
++ exit 0
+ else
+ echo "ERROR: bash shell not found."
+ fi
diff --git a/media-video/handbrake/handbrake-1.3.0-r1.ebuild b/media-video/handbrake/handbrake-1.3.0-r2.ebuild
index ddd530597452..21bb95bbbdbb 100644
--- a/media-video/handbrake/handbrake-1.3.0-r1.ebuild
+++ b/media-video/handbrake/handbrake-1.3.0-r2.ebuild
@@ -90,11 +90,10 @@ PATCHES=(
# Fix missing flags
"${FILESDIR}/${P}-missing-linker-flags.patch"
-)
-pkg_setup() {
- python-any-r1_pkg_setup
-}
+ # Use whichever python is set by portage
+ "${FILESDIR}/${P}-dont-search-for-python.patch"
+)
src_prepare() {
# Get rid of leftover bundled library build definitions,