summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-05-03 12:33:00 -0400
committerMichael Orlitzky <mjo@gentoo.org>2023-05-04 10:02:32 -0400
commit4797f957b23ad24e0619afe08b3f22664eba5ff2 (patch)
tree29e8e9812efa751435bc4f563cab6c4163e5da55
parentmail-filter/spf-engine: drop 2.9.3 (diff)
downloadgentoo-4797f957b23ad24e0619afe08b3f22664eba5ff2.tar.gz
gentoo-4797f957b23ad24e0619afe08b3f22664eba5ff2.tar.bz2
gentoo-4797f957b23ad24e0619afe08b3f22664eba5ff2.zip
mail-filter/spf-engine: add 3.0.4
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--mail-filter/spf-engine/Manifest1
-rw-r--r--mail-filter/spf-engine/spf-engine-3.0.4.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/mail-filter/spf-engine/Manifest b/mail-filter/spf-engine/Manifest
index f7084f23353b..cfeb6a304f68 100644
--- a/mail-filter/spf-engine/Manifest
+++ b/mail-filter/spf-engine/Manifest
@@ -1 +1,2 @@
DIST spf-engine-3.0.3.tar.gz 61350 BLAKE2B f28dfb10559bfd61be152a4b65a5653ec50b25718fcb63f8a2c9532fd9d52a51c131c99ba5408bd6aa424adc5ce6094da7eeb97dbacd7e60e8abb48c65c4f188 SHA512 08db392d2cce16651ba416fcd265e6606e1a8af3cb88721ed149a2286d11ac9ea6ed4d01572cea6950740890c3334e8e0d496d1d1e9edcc29d04833fec049ab0
+DIST spf-engine-3.0.4.tar.gz 61428 BLAKE2B b4c1e920cdb6706650341a21abe21a3318649a3bd379aea2d16c30bb9d27d95b83b980dfb0f62c234627f3c87b4d82f6074b88eb0f4ccb878618f61f9d8b9827 SHA512 29a6cd4d2c94ef1d47ff6d6d03bd485961f8c01e838800dd8c1194a51fdfbf384ffb5f073e1262993cd2bb5cbf2eff645048d6f1f3ce57bdebfefe3d0425ee77
diff --git a/mail-filter/spf-engine/spf-engine-3.0.4.ebuild b/mail-filter/spf-engine/spf-engine-3.0.4.ebuild
new file mode 100644
index 000000000000..2c680c53fd35
--- /dev/null
+++ b/mail-filter/spf-engine/spf-engine-3.0.4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_9 python3_10 python3_11 )
+
+# The built-in ipaddress module handles the parsing of IP addresses. If
+# python is built without ipv6 support, then ipaddress can't parse ipv6
+# addresses, and the daemon will crash if it sees an ipv6 SPF record. In
+# other words, it's completely broken.
+PYTHON_REQ_USE="ipv6(+)"
+DISTUTILS_USE_PEP517=flit
+PYPI_NO_NORMALIZE=1
+inherit distutils-r1 pypi
+
+DESCRIPTION="Policy daemon for Postfix SPF verification"
+HOMEPAGE="https://launchpad.net/spf-engine"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/pyspf[${PYTHON_USEDEP}]
+ dev-python/authres[${PYTHON_USEDEP}]"
+
+DOCS=( CHANGES )
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # The tarball has a "data" directory containing a hierarchy that
+ # flit wants to insert right into /usr. Before it does that, we have
+ # to remove the parts we don't want, and fix some of the paths.
+ #
+ # Note that one of our patches already mangles a few of these
+ # before we even see them.
+
+ einfo "removing milter files"
+ rm -v -r data/lib data/etc/init.d data/share/man/man8 || die
+ rm -v data/etc/pyspf-milter/pyspf-milter.conf || die
+ rm -v spf_engine/milter_spf.py || die
+
+ # And don't create a python-exec wrapper for it.
+ sed -e '/^pyspf-milter = /d' -i pyproject.toml || die
+
+ # The commented conf example is documentation, not configuration.
+ mv -v data/etc/python-policyd-spf/policyd-spf.conf.commented \
+ data/share/doc/python-policyd-spf/ || die
+
+ # The man page hard-codes /usr/local/etc, it should be /etc.
+ sed -e 's:/usr/local/etc:/etc:g' \
+ -i data/share/man/man1/policyd-spf.1 || die
+
+ # Fix the documentation path.
+ mv -v data/share/doc/python-policyd-spf "data/share/doc/${PF}" || die
+
+ # The "real" config file mentions the commented one, so we point
+ # users in the right direction. Caveat: the documentation is
+ # compressed, so we're usually off by a ".bz2" suffix anyway.
+ local oldconf="policyd-spf.conf.commented"
+ local newconf="/usr/share/doc/${PF}/${oldconf}"
+ sed -e "1 s~ ${oldconf}~,\n# ${newconf}~" \
+ -i "data/etc/python-policyd-spf/policyd-spf.conf" \
+ || die 'failed to update commented config file path'
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ # The "data" installation is relative to python's prefix, so
+ # data/etc gets installed to /usr/etc. Let's fix that.
+ mv -v "${ED}/usr/etc" "${ED}/" || die 'failed to relocate sysconfdir'
+}