summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-06-04 10:18:26 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-06-04 10:19:01 +0200
commit487516d0a72bff284b6cf330c90ff1e047f0662f (patch)
tree0956565415e92d2fe2001b415271695bd08410c4
parentprofiles/base: remove ruby26 from default RUBY_TARGETS (diff)
downloadgentoo-487516d0a72bff284b6cf330c90ff1e047f0662f.tar.gz
gentoo-487516d0a72bff284b6cf330c90ff1e047f0662f.tar.bz2
gentoo-487516d0a72bff284b6cf330c90ff1e047f0662f.zip
sys-process/btop: update icon cache and desktop database
Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--sys-process/btop/btop-1.2.7-r1.ebuild (renamed from sys-process/btop/btop-1.2.7.ebuild)12
1 files changed, 12 insertions, 0 deletions
diff --git a/sys-process/btop/btop-1.2.7.ebuild b/sys-process/btop/btop-1.2.7-r1.ebuild
index 44d1c8204f7d..59381b7f2690 100644
--- a/sys-process/btop/btop-1.2.7.ebuild
+++ b/sys-process/btop/btop-1.2.7-r1.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit xdg-utils
+
DESCRIPTION="A monitor of resources"
HOMEPAGE="https://github.com/aristocratos/btop"
SRC_URI="https://github.com/aristocratos/btop/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -30,3 +32,13 @@ src_install() {
dodoc README.md CHANGELOG.md
}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}