summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-02 05:25:20 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-02 06:53:47 -0400
commit487ce813759ee430f1b0bd9e4011d073a6b176d4 (patch)
tree0ac4ef410008036381506244e0b105834b7b57ec
parentgames-emulation/fceux: drop 2.2.3-r100 (diff)
downloadgentoo-487ce813759ee430f1b0bd9e4011d073a6b176d4.tar.gz
gentoo-487ce813759ee430f1b0bd9e4011d073a6b176d4.tar.bz2
gentoo-487ce813759ee430f1b0bd9e4011d073a6b176d4.zip
games-emulation/mednafen: drop 0.9.46
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-emulation/mednafen/Manifest1
-rw-r--r--games-emulation/mednafen/mednafen-0.9.46.ebuild112
-rw-r--r--games-emulation/mednafen/metadata.xml3
3 files changed, 0 insertions, 116 deletions
diff --git a/games-emulation/mednafen/Manifest b/games-emulation/mednafen/Manifest
index 73bc534957cc..dff999e5abb8 100644
--- a/games-emulation/mednafen/Manifest
+++ b/games-emulation/mednafen/Manifest
@@ -1,2 +1 @@
-DIST mednafen-0.9.46.tar.xz 3187988 BLAKE2B c33da02bfb0cce37e9029efc98d11e233686c41c7ecb51110a3fe805b3a13f2fef293dd86b7bc7a3ff172f7f0f507e07804a2927e5b41c1927ca52673f068dfb SHA512 ea624f076922570001393d5d04cc1b20b3d005d31de4095ee5c7a985be2b61e8d3aa5e78c64e751e8233adc89a31be955372caeb2818d0a5cc71ba9380931620
DIST mednafen-1.26.1.tar.xz 3319756 BLAKE2B d306a0754ed0c64a99cee4eacfa47f5f46ca059026bfc2ef6bfff4be82e914a2882a864538c8cb6bb948cdb9bd53651d931b033446015ad06be309893a2bfef7 SHA512 c91db3967c09a475fcd3410eb6892a99f3cf2ca2c5a78173669aa52c2e588819595d1d140e0c1888f48885327a9381c64cfb8f2074be8067984a4414c6f282bf
diff --git a/games-emulation/mednafen/mednafen-0.9.46.ebuild b/games-emulation/mednafen/mednafen-0.9.46.ebuild
deleted file mode 100644
index e789c94b3240..000000000000
--- a/games-emulation/mednafen/mednafen-0.9.46.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools flag-o-matic pax-utils
-
-DESCRIPTION="Argument-driven multi-system emulator utilizing OpenGL and SDL"
-HOMEPAGE="https://mednafen.github.io/"
-SRC_URI="https://mednafen.github.io/releases/files/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="alsa altivec cjk debugger jack nls"
-
-RDEPEND="
- dev-libs/libcdio
- >=dev-libs/lzo-2.10
- media-libs/libsdl[sound,joystick,opengl,video]
- media-libs/libsndfile
- sys-libs/zlib[minizip]
- virtual/opengl
- alsa? ( media-libs/alsa-lib )
- jack? ( media-sound/jack-audio-connection-kit )
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/${PN}
-
-pkg_pretend() {
- if has ccache ${FEATURES}; then
- ewarn
- ewarn "If you experience build failure, try turning off ccache in FEATURES."
- ewarn
- fi
-}
-
-src_prepare() {
- default
-
- # Unfortunately, upstream is insane and thinks mucking with CFLAGS is okay, if
- # it prevents "users who don't understand the consequences of what they're doing".
- # We use sed's here, as they're more forward-compatible than patches which need to
- # be constantly rebased. DO NOT REPLACE THEM UNLESS YOU HAVE PERMISSION FROM GAMES.
- sed -e '/-fno-fast-math/d' \
- -e '/-fno-unsafe-math-optimizations/d' \
- -e '/-fno-aggressive-loop-optimizations/d' \
- -e '/-fno-ipa-icf/d' \
- -e '/-fno-printf-return-value/d' \
- -e '/-fomit-frame-pointer/d' \
- -e '/-fno-pic/d' \
- -e '/-fno-pie/d' \
- -e '/-fno-PIC/d' \
- -e '/-fno-PIE/d' \
- -e '/-nopie/d' \
- -e '/-no-pie/d' \
- -e '/-fno-stack-protector/d' \
- -e '/-fno-stack-protector-all/d' \
- -e '/-fno-stack-protector-strong/d' \
- -e '/-mtune=haswell/d' \
- -i configure.ac || die
-
- # Furthermore, upstream is also insane about bundling libraries and considers it
- # "an aesthetics issue" and is even unwilling to make unbundling optional.
- # Libs to unbundle: minilzo, minizip
- sed -e '/PKG_PROG_PKG_CONFIG/a PKG_CHECK_MODULES([LZO], [lzo2])' \
- -i configure.ac || die
- sed -e '/bin_PROGRAMS/a mednafen_CPPFLAGS = \$(LZO_CFLAGS)' \
- -i src/Makefile.am || die
- sed -e 's:"compress/minilzo.h":<lzo1x.h>:' \
- -i src/{mednafen,qtrecord}.cpp || die
- sed -e 's:compress/ioapi.c::' \
- -e 's:compress/unzip.c::' \
- -e 's:compress/minilzo.c::' \
- -i src/compress/Makefile.am.inc || die
- sed -e 's:"compress/unzip.h":<minizip/unzip.h>:' \
- -i src/file.cpp || die
- sed -e 's:\(mednafen_LDADD.*trio/libtrio\.a\):\1 -lminizip \$(LZO_LIBS):' \
- -i src/Makefile.am || die
- # delete bundled files just to be sure...
- rm src/compress/{ioapi.?,*lzo*,unzip.?} || die
-
- # The insanity continues... upstream now believes it needs to
- # warn users when compiling with -fPIC/-fPIE enabled
- sed -e '/Compiling with position-independent code generation enabled is not recommended, for performance reasons/d' \
- -i src/types.h || die
-
- eautoreconf
-}
-
-src_configure() {
- # very dodgy code (bug #539992)
- strip-flags
- append-flags -fomit-frame-pointer -fwrapv
-
- econf \
- $(use_enable alsa) \
- $(use_enable altivec) \
- $(use_enable cjk cjk-fonts) \
- $(use_enable debugger) \
- $(use_enable jack) \
- $(use_enable nls)
-}
-
-src_install() {
- default
- dodoc Documentation/cheats.txt
- pax-mark m "${ED}"usr/bin/mednafen
-}
diff --git a/games-emulation/mednafen/metadata.xml b/games-emulation/mednafen/metadata.xml
index 5c1044a50bb7..8c07f220d0d7 100644
--- a/games-emulation/mednafen/metadata.xml
+++ b/games-emulation/mednafen/metadata.xml
@@ -5,9 +5,6 @@
<email>games@gentoo.org</email>
<name>Gentoo Games Project</name>
</maintainer>
- <use>
- <flag name="debugger">Build with internal debugger</flag>
- </use>
<upstream>
<remote-id type="sourceforge">mednafen</remote-id>
</upstream>