summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-09-13 09:11:18 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-09-13 09:28:37 +0200
commit48b035ef7776f89a069e37b4ddf2eef294e9bc44 (patch)
tree738a71b36714bdfc25dace6f95b4480d2526c14a
parentgui-wm/wayfire: drop 0.7.1 (diff)
downloadgentoo-48b035ef7776f89a069e37b4ddf2eef294e9bc44.tar.gz
gentoo-48b035ef7776f89a069e37b4ddf2eef294e9bc44.tar.bz2
gentoo-48b035ef7776f89a069e37b4ddf2eef294e9bc44.zip
sys-apps/ethtool: Bump to version 5.14
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--sys-apps/ethtool/Manifest1
-rw-r--r--sys-apps/ethtool/ethtool-5.14.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/sys-apps/ethtool/Manifest b/sys-apps/ethtool/Manifest
index 5bffba1c47c6..88da7bfd87a4 100644
--- a/sys-apps/ethtool/Manifest
+++ b/sys-apps/ethtool/Manifest
@@ -1,3 +1,4 @@
DIST ethtool-5.10.tar.xz 310536 BLAKE2B acc91ff2f7cf233a5a7bc85e32fbcf78e3923b240ab3e3300fa11d42769b664b1b5740ad6577daf4ef1b1054432e2323429ee63774af5e0210c1ec1c7d6aa4ac SHA512 128ecc0445ec44e231d95158a71cea2c03f059314f1a844cfb2f424970bd68608fb73b8dc5e8905b88ad0da2b65a8884a626be78d6d25f770ce043c6c87580a6
DIST ethtool-5.12.tar.xz 311004 BLAKE2B 640d4a1576afea60c673a6060b649d10ccb2d2be64a817e4d74daeb6de4da2d30ccb059ff1113e05f9c44898f08beefd706be2ea6e323c42032c4d93926d380a SHA512 9825f0bf10851f0bd9c3e621785144a5ed5f3fbedacb1801aa6a9b4685c870fa9bfac8eb552c900d20be06240c017dd001fde6be7aecc8c466bbe9ade8b1d002
DIST ethtool-5.13.tar.xz 318204 BLAKE2B 5e693368ce56fa155c5d371bc650e5fb7e8e1c8fd30982b45a674da63119e54f005484bea68c7b85e8d070efbf7aa15e92637e7a3b8b2010b4022851154a6809 SHA512 44426653aabd20707d2e597707113f4d30d12696b4f32c0ab0450af0dccece1b6a11e529a22d1299204f63c9e71ae41a1495d3d36b8f630f1734a72694d779be
+DIST ethtool-5.14.tar.xz 318536 BLAKE2B 09b5c9c8103635e33b22e55caff3b0f3751bf14d48de63e025587814c6b0d7e80962cd8ed27b6be7ae35a5a9d5decd0a9127a69a7cbbd52e2218bb3fc9e9b176 SHA512 880c4b6d5f83c25cabc6101222a5abf5f7e5e6501165ba5cdb420da242c351d7c32c1cffacfa1bcf0c4655434d89c64d39f0809af0d38f626a0a78f92ec68f87
diff --git a/sys-apps/ethtool/ethtool-5.14.ebuild b/sys-apps/ethtool/ethtool-5.14.ebuild
new file mode 100644
index 000000000000..4ddb6be7e3ff
--- /dev/null
+++ b/sys-apps/ethtool/ethtool-5.14.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Utility for examining and tuning ethernet-based network interfaces"
+HOMEPAGE="https://www.kernel.org/pub/software/network/ethtool/"
+SRC_URI="https://www.kernel.org/pub/software/network/ethtool/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+netlink"
+
+BDEPEND="app-arch/xz-utils"
+RDEPEND="netlink? ( net-libs/libmnl )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf $(use_enable netlink)
+}