summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-03 08:54:57 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-03 10:09:05 +0100
commit48f31e1dc381cea38fd7671978f8a7bec26381ef (patch)
tree89c0f624a2de1b0c4d61cf4f236fef4f7e0416c4
parentdev-python/botocore: Bump to 1.29.22 (diff)
downloadgentoo-48f31e1dc381cea38fd7671978f8a7bec26381ef.tar.gz
gentoo-48f31e1dc381cea38fd7671978f8a7bec26381ef.tar.bz2
gentoo-48f31e1dc381cea38fd7671978f8a7bec26381ef.zip
dev-python/boto3: Bump to 1.26.22
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.26.22.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 304d5e3aa12d..3abb182727fb 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,4 +3,5 @@ DIST boto3-1.26.16.gh.tar.gz 565753 BLAKE2B 7b30f4a3e15ca893cacca7ea58e18d654f38
DIST boto3-1.26.18.gh.tar.gz 570818 BLAKE2B 2f77acbb6fa77c867cda0b1d7828c5aafdfc8b6e5d7cced4beda08f151c9ed889356ec32b4b0ad2724bffbaa20690f149caf69f89dfbf70761ca354893685cb7 SHA512 b67d62057c7c421eedbf8778c2bd10d9cad9a81678dfc68415cb5ca546182c418d1c8a6619d20be066d78891af7720ec29209fecd27628e1d456b04965edfb83
DIST boto3-1.26.20.gh.tar.gz 572957 BLAKE2B 27286beaeabc0227376640fd3ee583656470ee324805ac716411a6c87fc2f301f6430c4f82e58c4a5371fe38a4cb3a6cebe32de39c0bae35f051fd340257c315 SHA512 4623e29b4396cd131e76ad44d24e32014e9f79642db471f64b5b06553ffbd0a0492883188e3658fe629e6af0a91b8274dbda3103a3ecf6d2dd6fe5b1a91b9503
DIST boto3-1.26.21.gh.tar.gz 573776 BLAKE2B a608b875d052cb895cae4bc20924836284dd924bfc9939023d452fbb2af2ca32fe1503b32552d19cdde6a9347dce26991a70aa4a1b980fcb7f711ed246b8e63a SHA512 3fd3aba935950738c62d5c7d8249768c352a4106be0cac989d1f0635a45606022749b4d34cb3093d44b18501ff14c30545df76d7d1f9681886ff71ec62bff888
+DIST boto3-1.26.22.gh.tar.gz 574580 BLAKE2B 35027efcfaa0ec27ff7e8769af32c4ea621fea842a84b689f76ef412305318a16fd3fe3b139f00a66f91892455a14cbb9753ea4f3d07ac24e4e18725cb6c7fb7 SHA512 5035f8be58384b1c8634ab801dd3930043febfbcc5d23f1c4385ce7e4aac37fda61a04ca3adcf86010db21f8d26403b491990746c578d91fa173c9629bb501bb
DIST boto3-1.26.8.gh.tar.gz 557012 BLAKE2B 211bb7441acc8b1f901ebf5251288dc7c9073fa6e34f5a34426424ef064efb0fb3031deaf48ef336ec43bb015f95f618598da43d12ec83cbf814e1b4097b28a0 SHA512 738190cedfb0b85d3a1e9558b03e7f2fb14e43b152bc9627fd95c8ecc4a0ddc17f4c87ccb6129c1fbf5f47db9eea4dbc5c2cfbb69b903bc6f3ff417ef86b6f6b
diff --git a/dev-python/boto3/boto3-1.26.22.ebuild b/dev-python/boto3/boto3-1.26.22.ebuild
new file mode 100644
index 000000000000..6edcc751d54b
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.22.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}