summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-06-09 19:24:53 -0400
committerMike Gilbert <floppym@gentoo.org>2020-06-09 19:41:21 -0400
commit48f36331a5098f7300c979758fac756605ff1df8 (patch)
tree09beb37ba6689e13f2a4bd7efb984016db293a03
parentdev-python/black-19.10_beta0: Fix sed to remove setuptools_scm (diff)
downloadgentoo-48f36331a5098f7300c979758fac756605ff1df8.tar.gz
gentoo-48f36331a5098f7300c979758fac756605ff1df8.tar.bz2
gentoo-48f36331a5098f7300c979758fac756605ff1df8.zip
sys-fs/ntfs3g: bump to 2017.3.23AR.5
Switch the "advanced release" series since upstream has not cut a stable release since 2017. Drop support for external FUSE due to bug 724464. Closes: https://bugs.gentoo.org/601290 Closes: https://bugs.gentoo.org/727464 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--sys-fs/ntfs3g/Manifest1
-rw-r--r--sys-fs/ntfs3g/ntfs3g-2017.3.23.5.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/sys-fs/ntfs3g/Manifest b/sys-fs/ntfs3g/Manifest
index 1bbd0f6e1e42..d9a6eaac1cf2 100644
--- a/sys-fs/ntfs3g/Manifest
+++ b/sys-fs/ntfs3g/Manifest
@@ -1,2 +1,3 @@
DIST ntfs-3g_ntfsprogs-2016.2.22.tgz 1264364 BLAKE2B 6028048d676372c062cda1cf9ee43f2c1f035d080dde1201746d994e705756ab219de8359b1f8708e83e11c0036cdc33339e54299aa433f383e698e425ff2fed SHA512 dbd36fadd2881db1d17fdbf5d2b4e50bbe11dc9dd0ad4917e7f8bc4032c2287346143756ce8754df0d46ce9209f2c0c41b626cad929d76a9bc881712c7101c15
DIST ntfs-3g_ntfsprogs-2017.3.23.tgz 1259054 BLAKE2B 4f12a6061ef0c116f26225eb3fb5cb84e469b63710115fbfb54fa3802ea94192afa973a553742818ff6849b72919069ec92aca2d4d6f58d8cabca1b0fefa3abe SHA512 3a607f0d7be35204c992d8931de0404fbc52032c13b4240d2c5e6f285c318a28eb2a385d7cf5ac4cd445876aee5baa5753bb636ada0d870d84a9d3fdbce794ef
+DIST ntfs-3g_ntfsprogs-2017.3.23AR.5.tgz 1278315 BLAKE2B d4f84bf744b12fec7faff82bd3d3048282a3cbcde2ca75e5d3a295206585c4cee68e25dff5fb20b034f516a3f2cd95c489105d9df810f8a9378024ef065b67d3 SHA512 8534970ba9f07999c5ff433144ad3a59640fb9a28fb30b37b5d736101e19f9fec1c222152338be382c894f972fce2b2a83680b85a28cf147cb5500b40a0a25cc
diff --git a/sys-fs/ntfs3g/ntfs3g-2017.3.23.5.ebuild b/sys-fs/ntfs3g/ntfs3g-2017.3.23.5.ebuild
new file mode 100644
index 000000000000..329adc5f6862
--- /dev/null
+++ b/sys-fs/ntfs3g/ntfs3g-2017.3.23.5.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit linux-info udev toolchain-funcs libtool
+
+MY_P="ntfs-3g_ntfsprogs-${PV%.*}AR.${PV##*.}"
+
+DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
+HOMEPAGE="http://www.tuxera.com/community/ntfs-3g-download/"
+HOMEPAGE="https://jp-andre.pagesperso-orange.fr/advanced-ntfs-3g.html"
+#SRC_URI="http://tuxera.com/opensource/${MY_P}.tgz"
+SRC_URI="https://jp-andre.pagesperso-orange.fr/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+# The subslot matches the SONAME major #.
+SLOT="0/885"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="acl debug ntfsdecrypt +ntfsprogs static-libs suid xattr"
+
+RDEPEND="
+ sys-apps/util-linux:0=
+ ntfsdecrypt? (
+ >=dev-libs/libgcrypt-1.2.2:0
+ >=net-libs/gnutls-1.4.4
+ )
+"
+DEPEND="${RDEPEND}
+ sys-apps/attr
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ CONFIG_CHECK="~FUSE_FS"
+ FUSE_FS_WARNING="You need to have FUSE module built to use ntfs-3g"
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ tc-ld-disable-gold
+
+ local myconf=(
+ # passing --exec-prefix is needed as the build system is trying to be clever
+ # and install itself into / instead of /usr in order to be compatible with
+ # separate-/usr setups (which we don't support without an initrd).
+ --exec-prefix="${EPREFIX}"/usr
+
+ --disable-ldconfig
+ --enable-extras
+ $(use_enable debug)
+ $(use_enable acl posix-acls)
+ $(use_enable xattr xattr-mappings)
+ $(use_enable ntfsdecrypt crypto)
+ $(use_enable ntfsprogs)
+ $(use_enable ntfsprogs quarantined)
+ $(use_enable static-libs static)
+
+ --with-uuid
+
+ # disable hd library until we have the right library in the tree and
+ # don't links to hwinfo one causing issues like bug #602360
+ --without-hd
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ use suid && fperms u+s /usr/bin/ntfs-3g
+ dosym "${EPREFIX}"/usr/bin/ntfs-3g /sbin/mount.ntfs
+ find "${D}" -name '*.la' -type f -delete || die
+}