summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-03 16:39:13 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-03 16:44:00 +0100
commit49bfa4ac6d63c6b9de048e9c00ea92fa538cc36e (patch)
tree3824c7c3809603e78fd7c9a8f72c0be8f3be25ab
parentnet-p2p/syncthing: add 1.19.0, drop 1.18.6-r1 (diff)
downloadgentoo-49bfa4ac6d63c6b9de048e9c00ea92fa538cc36e.tar.gz
gentoo-49bfa4ac6d63c6b9de048e9c00ea92fa538cc36e.tar.bz2
gentoo-49bfa4ac6d63c6b9de048e9c00ea92fa538cc36e.zip
dev-libs/libclc: Remove 13.0.1.9999
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-libs/libclc/libclc-13.0.1.9999.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/dev-libs/libclc/libclc-13.0.1.9999.ebuild b/dev-libs/libclc/libclc-13.0.1.9999.ebuild
deleted file mode 100644
index de9b38e9f826..000000000000
--- a/dev-libs/libclc/libclc-13.0.1.9999.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit cmake llvm llvm.org python-any-r1
-
-DESCRIPTION="OpenCL C library"
-HOMEPAGE="https://libclc.llvm.org/"
-
-LICENSE="Apache-2.0-with-LLVM-exceptions || ( MIT BSD )"
-SLOT="0"
-KEYWORDS=""
-IUSE_VIDEO_CARDS="video_cards_nvidia video_cards_r600 video_cards_radeonsi"
-IUSE="${IUSE_VIDEO_CARDS}"
-REQUIRED_USE="|| ( ${IUSE_VIDEO_CARDS} )"
-
-LLVM_MAX_SLOT=13
-BDEPEND="
- || (
- sys-devel/clang:13
- sys-devel/clang:12
- sys-devel/clang:11
- sys-devel/clang:10
- )
- ${PYTHON_DEPS}"
-
-LLVM_COMPONENTS=( libclc )
-llvm.org_set_globals
-
-llvm_check_deps() {
- has_version -b "sys-devel/clang:${LLVM_SLOT}"
-}
-
-pkg_setup() {
- # we do not need llvm_pkg_setup
- python-any-r1_pkg_setup
-}
-
-src_configure() {
- local libclc_targets=()
-
- use video_cards_nvidia && libclc_targets+=(
- "nvptx--"
- "nvptx64--"
- "nvptx--nvidiacl"
- "nvptx64--nvidiacl"
- )
- use video_cards_r600 && libclc_targets+=(
- "r600--"
- )
- use video_cards_radeonsi && libclc_targets+=(
- "amdgcn--"
- "amdgcn-mesa-mesa3d"
- "amdgcn--amdhsa"
- )
- # TODO: spirv
- [[ ${#libclc_targets[@]} ]] || die "libclc target missing!"
-
- libclc_targets=${libclc_targets[*]}
- local mycmakeargs=(
- -DLIBCLC_TARGETS_TO_BUILD="${libclc_targets// /;}"
- -DLLVM_CONFIG="$(get_llvm_prefix "${LLVM_MAX_SLOT}")/bin/llvm-config"
- )
- cmake_src_configure
-}