summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2020-01-12 18:08:47 -0500
committerJames Le Cuirot <chewi@gentoo.org>2020-01-25 14:15:07 +0000
commit49c7e42863ef52bcc5fed594e7ea4660c4107b1f (patch)
treec2223c42564dc20633bab114f9f6539ebd733946
parentprofiles: Cancel games-strategy/ufoai last-rites (diff)
downloadgentoo-49c7e42863ef52bcc5fed594e7ea4660c4107b1f.tar.gz
gentoo-49c7e42863ef52bcc5fed594e7ea4660c4107b1f.tar.bz2
gentoo-49c7e42863ef52bcc5fed594e7ea4660c4107b1f.zip
games-fps/gzdoom: Version bump to 4.3.3
Closes: https://bugs.gentoo.org/705322 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/14324 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--games-fps/gzdoom/Manifest1
-rw-r--r--games-fps/gzdoom/gzdoom-4.3.3.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/games-fps/gzdoom/Manifest b/games-fps/gzdoom/Manifest
index 1fb177efd010..a4ae231fe4bc 100644
--- a/games-fps/gzdoom/Manifest
+++ b/games-fps/gzdoom/Manifest
@@ -1 +1,2 @@
DIST gzdoom-4.3.1.tar.gz 13689272 BLAKE2B 3bc26732bc2f3281d0e5a1c667226153d411048877d3a716b6e4ce89534a38cde3763e5cf5d409d99bb053e75d5922b20b4b4d93ce574de58420ae89158eab32 SHA512 6904b8a132f720f07ba15bb4959cf248bba753c318e248d882c5701d919d35492a4fb460a4d4716bc26fde8a1c59d4bceaf3f626326a90a06d4f6cde6a180b96
+DIST gzdoom-4.3.3.tar.gz 13704956 BLAKE2B 4c9338b8958a408bee268eadadd779be8488540e68d5f46d7d0b18a825cd6391368b2c5149eff965685dd97f7ee51f12050e07f558c7f62551c8e239049110ea SHA512 ef8e3a7cfa4d03a98536deddb53ded4b23609b834dd07af4224cd2eb1136bca2a318a99a959a36b2e423038938a2175c015c48d89510f124bd32b7656004e1d1
diff --git a/games-fps/gzdoom/gzdoom-4.3.3.ebuild b/games-fps/gzdoom/gzdoom-4.3.3.ebuild
new file mode 100644
index 000000000000..1ba984d753b4
--- /dev/null
+++ b/games-fps/gzdoom/gzdoom-4.3.3.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake desktop xdg
+
+DESCRIPTION="A modder-friendly OpenGL source port based on the DOOM engine"
+HOMEPAGE="https://zdoom.org"
+SRC_URI="https://github.com/coelckers/${PN}/archive/g${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD BZIP2 DUMB-0.9.3 GPL-3 LGPL-3 MIT
+ non-free? ( Activision ChexQuest3 DOOM-COLLECTORS-EDITION freedist )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="alsa fluidsynth gtk gtk2 mpg123 +non-free openmp sndfile"
+
+DEPEND="
+ media-libs/libsdl2[opengl]
+ media-libs/openal
+ sys-libs/zlib
+ virtual/jpeg:0
+ alsa? ( media-libs/alsa-lib )
+ fluidsynth? ( media-sound/fluidsynth:= )
+ gtk? (
+ gtk2? ( x11-libs/gtk+:2 )
+ !gtk2? ( x11-libs/gtk+:3 )
+ )
+ mpg123? ( media-sound/mpg123 )
+ sndfile? ( media-libs/libsndfile )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-g${PV}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.2.1-install_soundfonts.patch"
+ "${FILESDIR}/${PN}-4.2.1-Introduce-the-BUILD_NONFREE-option.patch"
+)
+
+src_prepare() {
+ rm -rf docs/licenses || die
+ if ! use non-free ; then
+ rm -rf wadsrc_bm wadsrc_extra || die
+ fi
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_DOCS_PATH="${EPREFIX}/usr/share/doc/${PF}"
+ -DINSTALL_PK3_PATH="${EPREFIX}/usr/share/doom"
+ -DINSTALL_SOUNDFONT_PATH="${EPREFIX}/usr/share/doom"
+ -DDYN_FLUIDSYNTH=OFF
+ -DDYN_OPENAL=OFF
+ -DDYN_SNDFILE=OFF
+ -DDYN_MPG123=OFF
+ -DNO_GTK="$(usex !gtk)"
+ -DNO_OPENAL=OFF
+ -DNO_OPENMP="$(usex !openmp)"
+ -DBUILD_NONFREE="$(usex non-free)"
+ -DCMAKE_DISABLE_FIND_PACKAGE_ALSA="$(usex !alsa)"
+ -DCMAKE_DISABLE_FIND_PACKAGE_FluidSynth="$(usex !fluidsynth)"
+ -DCMAKE_DISABLE_FIND_PACKAGE_MPG123="$(usex !mpg123)"
+ -DCMAKE_DISABLE_FIND_PACKAGE_SndFile="$(usex !sndfile)"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ newicon src/posix/zdoom.xpm "${PN}.xpm"
+ make_desktop_entry "${PN}" "GZDoom" "${PN}" "Game;ActionGame"
+ cmake_src_install
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if ! use non-free ; then
+ ewarn
+ ewarn "GZDoom installed without non-free components."
+ ewarn "Note: The non-free game_support.pk3 file is needed to play"
+ ewarn " games natively supported by GZDoom."
+ ewarn "A list of games natively supported by GZDoom is available"
+ ewarn "on the ZDoom wiki: https://zdoom.org/wiki/IWAD"
+ ewarn
+ fi
+}