summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-03-01 09:21:11 +0100
committerHans de Graaff <graaff@gentoo.org>2020-03-01 09:22:36 +0100
commit4a09c71dc7c9ee35735f5832fe5eb87867050fde (patch)
treeca8943329ba38029959a119364dfe4e9605274dd
parentdev-ruby/mustermann: add 1.1.1 (diff)
downloadgentoo-4a09c71dc7c9ee35735f5832fe5eb87867050fde.tar.gz
gentoo-4a09c71dc7c9ee35735f5832fe5eb87867050fde.tar.bz2
gentoo-4a09c71dc7c9ee35735f5832fe5eb87867050fde.zip
dev-ruby/rack-protection: add 2.0.8.1
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/rack-protection/Manifest1
-rw-r--r--dev-ruby/rack-protection/rack-protection-2.0.8.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/rack-protection/Manifest b/dev-ruby/rack-protection/Manifest
index 6fa2c52715a8..7d2f3c9b869f 100644
--- a/dev-ruby/rack-protection/Manifest
+++ b/dev-ruby/rack-protection/Manifest
@@ -1,3 +1,4 @@
DIST rack-protection-1.5.5.gem 18432 BLAKE2B abda1313e7e0d04299a689c55241cd92d0f5ed2048395ab79f09ba271100a8dc99fbf5f924e3b3cbe28f318090144539eb0174cc1813d371d9f37df31ab04315 SHA512 c4066a50771247fc89d4ddee44ff87e40a24bad95e914ed2f72cbf9c45152e67e51d2ccc7d1725ade637296a080b06f304157a1a024613a97595b144e03e2e70
DIST rack-protection-2.0.5.gem 16896 BLAKE2B 144888ca499739017ffec494785ca5cba0d1cbfabdf08b11aad4fc88aaaa737408d1801412f05919830c65fd11b2f344f0f758a0334b109174805d5089352521 SHA512 9c4c80a8f70042bea81a67260e26aa25c0a33c73835e4e49cd44c83930f97d8c4d63004d3e39ed631f016e44d66fba238f9c509b0e44eddb2f484d174adea9b4
DIST rack-protection-2.0.7.gem 16896 BLAKE2B e9d6c91cebc62e6f1efa91a790edc218c78b8336ebcb03ac086e070360be0e5ded4a897042b85bef8e5625dd8c1bf035a825202f0a619f10e584fafce1ab0d0d SHA512 9001bee93859c87060450b83171eab80bf085c0238f978673ac6e31e3e1884a0de1a6d789a61900d1fc429e64f2eb3893e88cf32bef0b3e2a9f58e6f3a3abea1
+DIST rack-protection-2.0.8.1.gem 16896 BLAKE2B 013fc8a5ceaadbfde52a7aca0dab8116cb01d6f034f3370d22a09545885a61adef92ad5ed9f82faf4434507a079ff9a0c3781b906ab6aba69fa032216f276fcb SHA512 264aef904d9ae1c38197ad4ad44f1638905bd180fc4bb402c47856c37168059e8e975ca2de5518b1e5cebf79b970024b7d9f5f8b8908880451357dea5e428562
diff --git a/dev-ruby/rack-protection/rack-protection-2.0.8.1.ebuild b/dev-ruby/rack-protection/rack-protection-2.0.8.1.ebuild
new file mode 100644
index 000000000000..86e10045f0ae
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-2.0.8.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+# There are no specs in the gem and the source cannot be downloaded separately.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem protects against typical web attacks"
+HOMEPAGE="https://github.com/rkh/rack-protection"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rack:*"
+
+# ruby_add_bdepend "test? ( dev-ruby/rack-test )"