summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-24 14:58:55 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-24 15:02:40 +0200
commit4a2faed7f6272ed5f80b3a50fdb4b75fc94dd026 (patch)
tree998d96a065c604b572b682cf276ee0a6b008cdab
parentdev-python/mkdocs-git-authors-plugin: enable py3.11 (diff)
downloadgentoo-4a2faed7f6272ed5f80b3a50fdb4b75fc94dd026.tar.gz
gentoo-4a2faed7f6272ed5f80b3a50fdb4b75fc94dd026.tar.bz2
gentoo-4a2faed7f6272ed5f80b3a50fdb4b75fc94dd026.zip
dev-python/mkautodoc: update EAPI 7 -> 8, enable py3.11, pep517
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/mkautodoc/mkautodoc-0.1.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/mkautodoc/mkautodoc-0.1.0-r1.ebuild b/dev-python/mkautodoc/mkautodoc-0.1.0-r1.ebuild
new file mode 100644
index 000000000000..05071c660cc5
--- /dev/null
+++ b/dev-python/mkautodoc/mkautodoc-0.1.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Auto documentation for MkDocs"
+HOMEPAGE="
+ https://github.com/tomchristie/mkautodoc/
+ https://pypi.org/project/mkautodoc/
+"
+SRC_URI="https://github.com/tomchristie/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/markdown[${PYTHON_USEDEP}]"
+
+BDEPEND="test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+
+python_test() {
+ PYTHONPATH="${WORKDIR}/${P}/tests/mocklib:${WORKDIR}/${P}" \
+ distutils-r1_python_test
+}