summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-12-14 13:08:03 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-12-14 13:08:03 +0200
commit4a54fb852b29e6b2e671397c642860fa96748273 (patch)
tree4c244862bd95dc05d6ecadc98596c847975ba50c
parentapp-emulation/virtualbox-modules: Fixed build with kernel-5.10 (diff)
downloadgentoo-4a54fb852b29e6b2e671397c642860fa96748273.tar.gz
gentoo-4a54fb852b29e6b2e671397c642860fa96748273.tar.bz2
gentoo-4a54fb852b29e6b2e671397c642860fa96748273.zip
sys-kernel/pf-sources: bump to 5.9-pf7
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--sys-kernel/pf-sources/Manifest1
-rw-r--r--sys-kernel/pf-sources/pf-sources-5.9_p7.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index 99026c9bee2e..a5d29b17a7f0 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -14,3 +14,4 @@ DIST pf-sources-5.9_p2.patch 1222181 BLAKE2B 1a444ba68ade78f7862c474d52c021064ed
DIST pf-sources-5.9_p4.patch 1978557 BLAKE2B 1863fbf17732dad7e6f96b2ddfb66b424cc4cf9649eaff06b9e043e763a6d7a5941a80f3a1d2b6edc9987da41b3e9eb346c1fd63422f14f5cee285fb2de12f0e SHA512 d08011d285cfc1db431a92de9e58f5c3bde3e556cbca3237a7fd9ca234b9598c34b71482d0a9ac117e1fa15860c64aaa60c61435443c7cfa0548a620fe992b16
DIST pf-sources-5.9_p5.patch 2334422 BLAKE2B e90fa94cc371995f36dda11b0d758c157254a4bf7f47ee31af34a83b6a4b6ebb3720d9bfaf752705c5cf3e2fd53cb7df1399654bdf20803c5a1a72e9c731aad8 SHA512 e562acccafa1ca2cd743ad20f5920a61607b27aa1310552e5a3cbf822668886c49ce020fd381d4ce987ec9f77f3c6e861fe83e697acfcbe2d0a5665619614cc8
DIST pf-sources-5.9_p6.patch 2906787 BLAKE2B 23478dbafee1637661544d0deba45b619acadfc4a368b7f1530358450a0c4112556a779866a31de3b68f1bc1788028d408cc530b40fd1250e30c92f7b85f996a SHA512 eb31a8efbf80c1b22bb491b59b540a1cd3e03b8d20dd97a233b6ab118baa5d4ed7b4f3bd5c02df6ab268f1f38bee08c6219e0d2f88a73da73ee8897c75223b1f
+DIST pf-sources-5.9_p7.patch 3027972 BLAKE2B 9247ea63b30f9d42d79303b73a900d468a71e703333932f7f15ae697cdba52c46358297023e037226c219fad5df912fb5d21e6f4b7190556ca799fa84924480e SHA512 c69e14f59bf98944b3329c65b7e2c271d74a756bc8c890130bf3cc68b4b96d31f1c33c4edb128580fcaefeb6e42dd04b1eb3d7f071b2d58bc764d26322bda8cd
diff --git a/sys-kernel/pf-sources/pf-sources-5.9_p7.ebuild b/sys-kernel/pf-sources/pf-sources-5.9_p7.ebuild
new file mode 100644
index 000000000000..f2344adc15dc
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-5.9_p7.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Define what default functions to run
+ETYPE="sources"
+
+# No 'experimental' USE flag provided, but we still want to use genpatches
+K_EXP_GENPATCHES_NOUSE="1"
+
+# Just get basic genpatches, -pf patch set already includes vanilla-linux
+# updates
+K_GENPATCHES_VER="1"
+
+# -pf already sets EXTRAVERSION to kernel Makefile
+K_NOSETEXTRAVERSION="1"
+
+# Not supported by the Gentoo security team
+K_SECURITY_UNSUPPORTED="1"
+
+# We want the very basic patches from gentoo-sources, experimental patch is
+# already included in pf-sources
+K_WANT_GENPATCHES="base extras"
+
+inherit kernel-2 optfeature
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+HOMEPAGE="https://gitlab.com/post-factum/pf-kernel/-/wikis/README
+ https://dev.gentoo.org/~mpagano/genpatches/"
+SRC_URI="${KERNEL_URI}
+ https://github.com/pfactum/pf-kernel/compare/v${PV/_p*/}...v${PV/_p*/}-pf${PV/*_p/}.diff -> ${P}.patch
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.extras.tar.xz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/linux-${PVR}-pf"
+
+PATCHES=( "${DISTDIR}/${P}.patch" )
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+ see: ${HOMEPAGE}."
+
+pkg_setup() {
+ ewarn ""
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn ""
+
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ kernel-2_src_prepare
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ elog "Optional features:"
+ optfeature "Userspace KSM helper" sys-process/uksmd
+}