summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2020-02-26 02:35:59 +0200
committerStefan Strogin <steils@gentoo.org>2020-02-26 02:37:50 +0200
commit4a7ea6d83d36125cbeae45801e4430f2f300a785 (patch)
tree9860fe294487e737ceb86ebc96c97ae15ccd4184
parentapp-admin/helm: 3.1.1 bump (diff)
downloadgentoo-4a7ea6d83d36125cbeae45801e4430f2f300a785.tar.gz
gentoo-4a7ea6d83d36125cbeae45801e4430f2f300a785.tar.bz2
gentoo-4a7ea6d83d36125cbeae45801e4430f2f300a785.zip
net-libs/nodejs: replace wrongly used subshell with 'if'
Closes: https://bugs.gentoo.org/710784 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Stefan Strogin <steils@gentoo.org>
-rw-r--r--net-libs/nodejs/nodejs-10.19.0.ebuild6
-rw-r--r--net-libs/nodejs/nodejs-12.16.1.ebuild6
-rw-r--r--net-libs/nodejs/nodejs-13.9.0.ebuild6
-rw-r--r--net-libs/nodejs/nodejs-99999999.ebuild6
4 files changed, 20 insertions, 4 deletions
diff --git a/net-libs/nodejs/nodejs-10.19.0.ebuild b/net-libs/nodejs/nodejs-10.19.0.ebuild
index db37b4f35189..1aedca2b28c8 100644
--- a/net-libs/nodejs/nodejs-10.19.0.ebuild
+++ b/net-libs/nodejs/nodejs-10.19.0.ebuild
@@ -100,7 +100,11 @@ src_configure() {
use inspector || myconf+=( --without-inspector )
use npm || myconf+=( --without-npm )
use snapshot && myconf+=( --with-snapshot )
- use ssl && ( use system-ssl && myconf+=( --shared-openssl ) ) || myconf+=( --without-ssl )
+ if use ssl; then
+ use system-ssl && myconf+=( --shared-openssl )
+ else
+ myconf+=( --without-ssl )
+ fi
local myarch=""
case ${ABI} in
diff --git a/net-libs/nodejs/nodejs-12.16.1.ebuild b/net-libs/nodejs/nodejs-12.16.1.ebuild
index 6c929f702786..d0e7e0c5b4cf 100644
--- a/net-libs/nodejs/nodejs-12.16.1.ebuild
+++ b/net-libs/nodejs/nodejs-12.16.1.ebuild
@@ -107,7 +107,11 @@ src_configure() {
use inspector || myconf+=( --without-inspector )
use npm || myconf+=( --without-npm )
use snapshot || myconf+=( --without-node-snapshot )
- use ssl && ( use system-ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store ) ) || myconf+=( --without-ssl )
+ if use ssl; then
+ use system-ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store )
+ else
+ myconf+=( --without-ssl )
+ fi
local myarch=""
case ${ABI} in
diff --git a/net-libs/nodejs/nodejs-13.9.0.ebuild b/net-libs/nodejs/nodejs-13.9.0.ebuild
index 4d35b0880936..00513e8978c4 100644
--- a/net-libs/nodejs/nodejs-13.9.0.ebuild
+++ b/net-libs/nodejs/nodejs-13.9.0.ebuild
@@ -105,7 +105,11 @@ src_configure() {
use inspector || myconf+=( --without-inspector )
use npm || myconf+=( --without-npm )
use snapshot || myconf+=( --without-node-snapshot )
- use ssl && ( use system-ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store ) ) || myconf+=( --without-ssl )
+ if use ssl; then
+ use system-ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store )
+ else
+ myconf+=( --without-ssl )
+ fi
local myarch=""
case ${ABI} in
diff --git a/net-libs/nodejs/nodejs-99999999.ebuild b/net-libs/nodejs/nodejs-99999999.ebuild
index 71618f3c5232..7a8dc689fddd 100644
--- a/net-libs/nodejs/nodejs-99999999.ebuild
+++ b/net-libs/nodejs/nodejs-99999999.ebuild
@@ -102,7 +102,11 @@ src_configure() {
use inspector || myconf+=( --without-inspector )
use npm || myconf+=( --without-npm )
use snapshot || myconf+=( --without-node-snapshot )
- use ssl && ( use system-ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store ) ) || myconf+=( --without-ssl )
+ if use ssl; then
+ use system-ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store )
+ else
+ myconf+=( --without-ssl )
+ fi
local myarch=""
case ${ABI} in