summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2020-09-12 07:47:29 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2020-09-12 07:47:33 -0400
commit4a9a6820195d545dba2d79a24c372b4b8d2a291d (patch)
tree2a254cc5c2184315c8cfdd5a710a132e5889c299
parentx11-wm/qtile: Drop live ebuild (diff)
downloadgentoo-4a9a6820195d545dba2d79a24c372b4b8d2a291d.tar.gz
gentoo-4a9a6820195d545dba2d79a24c372b4b8d2a291d.tar.bz2
gentoo-4a9a6820195d545dba2d79a24c372b4b8d2a291d.zip
dev-python/flask-compress: Initial Commit
Required by dev-db/pgadmin4-4.25. Package initially created/curated by Jorge Pizarro Callejas, a.k.a. Jorgicio, via https://github.com/jorgicio/jorgicio-gentoo-overlay. Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
-rw-r--r--dev-python/flask-compress/Manifest1
-rw-r--r--dev-python/flask-compress/flask-compress-1.5.0.ebuild36
-rw-r--r--dev-python/flask-compress/metadata.xml15
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/flask-compress/Manifest b/dev-python/flask-compress/Manifest
new file mode 100644
index 000000000000..ee9d97ab0a94
--- /dev/null
+++ b/dev-python/flask-compress/Manifest
@@ -0,0 +1 @@
+DIST Flask-Compress-1.5.0.tar.gz 6473 BLAKE2B eba68544018d587a7651c07739ac14218ff9918031fee740893245816daa7494d4998cf60b533971ba8dc0c7c9e3d1e1c14ee746d9e29deab70b30478a3c4eae SHA512 fe2d1dfef8be8d04b78a2938dd52a1f6068e6c35741f593fbb0d3d050b789b8d70188d683f7028b92a180653afda0566bda29b82475b20444f6563c8620ff1ec
diff --git a/dev-python/flask-compress/flask-compress-1.5.0.ebuild b/dev-python/flask-compress/flask-compress-1.5.0.ebuild
new file mode 100644
index 000000000000..115c157c65c1
--- /dev/null
+++ b/dev-python/flask-compress/flask-compress-1.5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+MY_PN="Flask-Compress"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Compress responses in your Flask app with gzip"
+HOMEPAGE="https://pypi.org/project/Flask-Compress"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ pytest
+}
diff --git a/dev-python/flask-compress/metadata.xml b/dev-python/flask-compress/metadata.xml
new file mode 100644
index 000000000000..09014f03117e
--- /dev/null
+++ b/dev-python/flask-compress/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>titanofold@gentoo.org</email>
+ <name>Aaron W. Swenson</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">Flask-Gravatar</remote-id>
+ </upstream>
+</pkgmetadata>