summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-12-23 22:16:41 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-23 22:32:42 +0100
commit4aad45800cd19d30050ebc9eb5c39fe94ca4436c (patch)
treec8036bc6c7022e308763b5d80ec9978d7d06737c
parentkde-apps/dolphin: Drop 20.12.0 (r0) (diff)
downloadgentoo-4aad45800cd19d30050ebc9eb5c39fe94ca4436c.tar.gz
gentoo-4aad45800cd19d30050ebc9eb5c39fe94ca4436c.tar.bz2
gentoo-4aad45800cd19d30050ebc9eb5c39fe94ca4436c.zip
kde-frameworks/kio: Crash fix
Upstream commit 9dc9e26b9196111eeacb5609b36957f74f5a14c4 See also: https://mail.kde.org/pipermail/distributions/2020-December/000913.html KDE-bug: https://bugs.kde.org/show_bug.cgi?id=430374 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-frameworks/kio/files/kio-5.77.0-crashfix.patch29
-rw-r--r--kde-frameworks/kio/kio-5.77.0-r1.ebuild96
2 files changed, 125 insertions, 0 deletions
diff --git a/kde-frameworks/kio/files/kio-5.77.0-crashfix.patch b/kde-frameworks/kio/files/kio-5.77.0-crashfix.patch
new file mode 100644
index 000000000000..d24a0d976c01
--- /dev/null
+++ b/kde-frameworks/kio/files/kio-5.77.0-crashfix.patch
@@ -0,0 +1,29 @@
+From 9dc9e26b9196111eeacb5609b36957f74f5a14c4 Mon Sep 17 00:00:00 2001
+From: Ismael Asensio <isma.af@gmail.com>
+Date: Tue, 22 Dec 2020 22:23:17 +0100
+Subject: [PATCH] RenameDialog: Add missing nullptr initialization
+
+It fixes a crash when pressing `Apply to All` in those cases where
+the action was not present, as the code checks for nullptr
+
+BUG: 430374
+FIXED-IN: 5.78
+---
+ src/widgets/renamedialog.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/widgets/renamedialog.cpp b/src/widgets/renamedialog.cpp
+index ac1d91d2..c3e04753 100644
+--- a/src/widgets/renamedialog.cpp
++++ b/src/widgets/renamedialog.cpp
+@@ -161,6 +161,7 @@ public:
+ bCancel = nullptr;
+ bRename = bSkip = nullptr;
+ bOverwrite = nullptr;
++ bOverwriteWhenOlder = nullptr;
+ bResume = bSuggestNewName = nullptr;
+ bApplyAll = nullptr;
+ m_pLineEdit = nullptr;
+--
+GitLab
+
diff --git a/kde-frameworks/kio/kio-5.77.0-r1.ebuild b/kde-frameworks/kio/kio-5.77.0-r1.ebuild
new file mode 100644
index 000000000000..5089ee6dac27
--- /dev/null
+++ b/kde-frameworks/kio/kio-5.77.0-r1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_DESIGNERPLUGIN="true"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.1
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org xdg-utils
+
+DESCRIPTION="Framework providing transparent file and data management"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="acl +handbook kerberos +kwallet X"
+
+RDEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5[ssl]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ =kde-frameworks/kauth-${PVCUT}*:5
+ =kde-frameworks/karchive-${PVCUT}*:5
+ =kde-frameworks/kbookmarks-${PVCUT}*:5
+ =kde-frameworks/kcodecs-${PVCUT}*:5
+ =kde-frameworks/kcompletion-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kcrash-${PVCUT}*:5
+ =kde-frameworks/kdbusaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/kitemviews-${PVCUT}*:5
+ =kde-frameworks/kjobwidgets-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/ktextwidgets-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5
+ =kde-frameworks/kxmlgui-${PVCUT}*:5
+ =kde-frameworks/solid-${PVCUT}*:5
+ acl? (
+ sys-apps/attr
+ virtual/acl
+ )
+ handbook? ( =kde-frameworks/kdoctools-${PVCUT}*:5 )
+ kerberos? ( virtual/krb5 )
+ kwallet? ( =kde-frameworks/kwallet-${PVCUT}*:5 )
+ X? ( >=dev-qt/qtx11extras-${QTMIN}:5 )
+"
+DEPEND="${RDEPEND}
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ test? ( sys-libs/zlib )
+ X? (
+ x11-base/xorg-proto
+ x11-libs/libX11
+ x11-libs/libXrender
+ )
+"
+PDEPEND="
+ >=kde-frameworks/kded-${PVCUT}:5
+"
+
+# tests hang
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}/${P}-crashfix.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package acl ACL)
+ $(cmake_use_find_package handbook KF5DocTools)
+ $(cmake_use_find_package kerberos GSSAPI)
+ $(cmake_use_find_package kwallet KF5Wallet)
+ $(cmake_use_find_package X X11)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ ecm_pkg_postrm
+ xdg_desktop_database_update
+}