summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-10-24 17:01:28 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-10-24 17:13:23 -0700
commit4ad0a3b530fd0f9a4df1dcadf747f8db8f09f6a0 (patch)
tree8201dba50aa0d60332b380174cdd3e67bf93ea53
parentdev-lang/jsonnet: add ~arm64 keyword (diff)
downloadgentoo-4ad0a3b5.tar.gz
gentoo-4ad0a3b5.tar.bz2
gentoo-4ad0a3b5.zip
dev-lang/jsonnet: revbump, fix many issues
It was installing broken soname symlinks and no libs at all. Now we install both c and c++ libs Also install jsonnetfmt and public headers. Add doc and examples useflag, all files are pre-rendered. Declare python3_9 and pypy3 support. Closes: https://bugs.gentoo.org/723058 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--dev-lang/jsonnet/jsonnet-0.16.0-r1.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/dev-lang/jsonnet/jsonnet-0.16.0-r1.ebuild b/dev-lang/jsonnet/jsonnet-0.16.0-r1.ebuild
new file mode 100644
index 000000000000..7987e9655559
--- /dev/null
+++ b/dev-lang/jsonnet/jsonnet-0.16.0-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+
+inherit toolchain-funcs flag-o-matic distutils-r1
+
+DESCRIPTION="A data templating language for app and tool developers "
+HOMEPAGE="https://jsonnet.org/"
+SRC_URI="https://github.com/google/jsonnet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE="custom-optimization doc examples python"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+DEPEND="
+ python? ( ${PYTHON_DEPS} )
+"
+RDEPEND="
+ python? ( ${PYTHON_DEPS} )
+"
+BDEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ )
+"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=(
+ "${FILESDIR}/jsonnet-0.14.0-makefile.patch"
+ "${FILESDIR}/jsonnet-0.12.1-dont-call-make-from-setuppy.patch"
+)
+
+distutils_enable_tests setup.py
+
+src_prepare() {
+ default
+ use python && distutils-r1_src_prepare
+ sed -i "s@\(PREFIX\)/lib@\(PREFIX\)/$(get_libdir)@g" Makefile || die
+}
+
+src_configure() {
+ use custom-optimization || replace-flags '-O*' -O3
+ tc-export CC CXX
+ default
+}
+
+src_compile() {
+ emake bins libs
+ use python && distutils-r1_src_compile
+}
+
+src_test() {
+ emake test
+ use python && distutils-r1_src_test
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" install
+ use python && distutils-r1_src_install
+ if use doc; then
+ find doc -name '.gitignore' -delete || die
+ docinto html
+ dodoc -r doc/.
+ fi
+ if use examples; then
+ docinto examples
+ dodoc -r examples/.
+ fi
+}