summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-01 16:18:50 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-05 06:10:35 +0100
commit4b2c68e4202483764817dbd11b5460f07aa0dba3 (patch)
tree1e1b274c41328cda0f058063462f31a75dd56005
parentdev-python/ensurepip-pip: Use pypi.eclass (diff)
downloadgentoo-4b2c68e4202483764817dbd11b5460f07aa0dba3.tar.gz
gentoo-4b2c68e4202483764817dbd11b5460f07aa0dba3.tar.bz2
gentoo-4b2c68e4202483764817dbd11b5460f07aa0dba3.zip
dev-python/ensurepip-setuptools: Use pypi.eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ensurepip-setuptools/ensurepip-setuptools-66.1.1.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/dev-python/ensurepip-setuptools/ensurepip-setuptools-66.1.1.ebuild b/dev-python/ensurepip-setuptools/ensurepip-setuptools-66.1.1.ebuild
index 22682736bd2f..c13c3370cbbe 100644
--- a/dev-python/ensurepip-setuptools/ensurepip-setuptools-66.1.1.ebuild
+++ b/dev-python/ensurepip-setuptools/ensurepip-setuptools-66.1.1.ebuild
@@ -3,14 +3,11 @@
EAPI=8
-MY_PN=${PN#ensurepip-}
-WHL=${MY_PN}-${PV}-py3-none-any.whl
+inherit pypi
DESCRIPTION="Shared setuptools wheel for ensurepip Python module"
HOMEPAGE="https://pypi.org/project/setuptools/"
-SRC_URI="
- https://files.pythonhosted.org/packages/py3/${MY_PN::1}/${MY_PN}/${WHL}
-"
+SRC_URI="$(pypi_wheel_url "${PN#ensurepip-}")"
S=${DISTDIR}
LICENSE="MIT"
@@ -23,5 +20,5 @@ RDEPEND="
src_install() {
insinto /usr/lib/python/ensurepip
- doins "${WHL}"
+ doins "${A}"
}